summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/avinfo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/avinfo')
-rw-r--r--media-video/avinfo/Manifest3
-rw-r--r--media-video/avinfo/avinfo-1.0_alpha15.ebuild30
-rw-r--r--media-video/avinfo/avinfo-1.0_alpha15_p1.ebuild37
-rw-r--r--media-video/avinfo/metadata.xml8
4 files changed, 78 insertions, 0 deletions
diff --git a/media-video/avinfo/Manifest b/media-video/avinfo/Manifest
new file mode 100644
index 000000000000..6bc8dbef9f36
--- /dev/null
+++ b/media-video/avinfo/Manifest
@@ -0,0 +1,3 @@
+DIST avinfo-1.0.a15unix-patch1.tar.gz 5665 RMD160 df4ce2cb51a9c57845345bf5602db17dc3831c23 SHA1 9d2033388f07e703aa07db0c4e057d5a6e06ea23 SHA256 b239c7a414dc92e4a6d3881801e981e71f66242d0e38ffae774a3a0f8c8bdf81
+DIST avinfo-1.0.a15unix.tar.gz 105743 RMD160 8a8082b90b05a1371087aa5ac74197fc6332e5c9 SHA1 2744b9112c3f6ed0a3ec5b32e0db67fb403943c8 SHA256 3e3404a76e6057c1703e0c49b63910a8ffcb5ea15ae7b2d0a7d2ede4b4c19887
+DIST avinfo-1.0a15.zip 140885 RMD160 9358cd885b904df4e15587ac77aa85f92f5739c9 SHA1 a93baef29b222aded6c88339bb2ea3fb29d27fd6 SHA256 f0c5e165091c170fd45f3a398b0ae59522da8a885ea96291cd134365194ef8df
diff --git a/media-video/avinfo/avinfo-1.0_alpha15.ebuild b/media-video/avinfo/avinfo-1.0_alpha15.ebuild
new file mode 100644
index 000000000000..5fcfb99306d5
--- /dev/null
+++ b/media-video/avinfo/avinfo-1.0_alpha15.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+MY_P="${PN}-1.0a15"
+DESCRIPTION="Utility for displaying AVI information"
+HOMEPAGE="http://shounen.ru/soft/avinfo/english.shtml"
+SRC_URI="http://shounen.ru/soft/avinfo/${MY_P}.zip"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc x86"
+
+IUSE=""
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}
+
+src_compile() {
+ cd src
+ emake CFLAGS="${CFLAGS}" OUTPUTNAME=avinfo || die
+}
+
+src_install() {
+ dobin src/avinfo
+ dodoc CHANGELOG README
+ dodoc doc/*
+}
diff --git a/media-video/avinfo/avinfo-1.0_alpha15_p1.ebuild b/media-video/avinfo/avinfo-1.0_alpha15_p1.ebuild
new file mode 100644
index 000000000000..40a44c7d8770
--- /dev/null
+++ b/media-video/avinfo/avinfo-1.0_alpha15_p1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+MY_P=${PN}-1.0.a15unix
+
+DESCRIPTION="Utility for displaying AVI information"
+HOMEPAGE="http://shounen.ru/soft/avinfo/english.shtml"
+SRC_URI="http://shounen.ru/soft/${PN}/${MY_P}.tar.gz
+ http://shounen.ru/soft/${PN}/${MY_P}-patch1.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+S="${WORKDIR}"/${PN}-1.0.a15
+
+src_prepare() {
+ epatch "${WORKDIR}"/${MY_P}-patch1/${MY_P}-patch1.diff
+ sed -i -e 's/$(CC) $(OBJ)/$(CC) $(LDFLAGS) $(OBJ)/' src/Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin src/avinfo
+ doman src/avinfo.1
+ dodoc CHANGELOG README "${WORKDIR}"/${MY_P}-patch1/FIXES
+ dodoc doc/*
+}
diff --git a/media-video/avinfo/metadata.xml b/media-video/avinfo/metadata.xml
new file mode 100644
index 000000000000..edccfe5754d2
--- /dev/null
+++ b/media-video/avinfo/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>video</herd>
+<maintainer>
+<email>media-video@gentoo.org</email>
+</maintainer>
+</pkgmetadata>