summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2024-02-21 23:29:17 +0000
committerJames Le Cuirot <chewi@gentoo.org>2024-02-21 23:29:17 +0000
commit8b4661e4909f4361a2af0caaa172092502a61335 (patch)
treefc61c2c53304e48231a7eb319683ffbdf559428f /media-video/ffmpeg/ffmpeg-9999.ebuild
parentdev-util/ruff: add 0.2.2, drop 0.2.1 (diff)
downloadgentoo-8b4661e4909f4361a2af0caaa172092502a61335.tar.gz
gentoo-8b4661e4909f4361a2af0caaa172092502a61335.tar.bz2
gentoo-8b4661e4909f4361a2af0caaa172092502a61335.zip
media-video/ffmpeg: Fix tests with USE=soc and check patch with verify-sig
I will sign the patch myself so that it can be checked against openpgp-keys-gentoo-developers. I had originally allowed for more than one USE=soc patch, but let's just assume one now for simplicity. Closes: https://bugs.gentoo.org/924986 Closes: https://bugs.gentoo.org/925094 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'media-video/ffmpeg/ffmpeg-9999.ebuild')
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild34
1 files changed, 25 insertions, 9 deletions
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index db1b3604cfde..12bc542e102c 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -14,9 +14,7 @@ EAPI=8
# doing so since such a case is unlikely.
FFMPEG_SUBSLOT=58.60.60
-SOC_PATCHES=(
- ffmpeg-rpi-6.1-r2.patch
-)
+SOC_PATCH="ffmpeg-rpi-6.1-r3.patch"
SCM=""
if [ "${PV#9999}" != "${PV}" ] ; then
@@ -29,18 +27,36 @@ inherit flag-o-matic multilib multilib-minimal toolchain-funcs ${SCM}
DESCRIPTION="Complete solution to record/convert/stream audio and video. Includes libavcodec"
HOMEPAGE="https://ffmpeg.org/"
-SRC_URI="soc? ( "${SOC_PATCHES[@]/#/https://dev.gentoo.org/~chewi/distfiles/}" )"
+SRC_URI="soc? ( https://dev.gentoo.org/~chewi/distfiles/${SOC_PATCH} )"
if [ "${PV#9999}" != "${PV}" ] ; then
:
elif [ "${PV%_p*}" != "${PV}" ] ; then # Snapshot
SRC_URI+=" mirror://gentoo/${P}.tar.xz"
else # Release
- VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/ffmpeg.asc
inherit verify-sig
- SRC_URI+=" https://ffmpeg.org/releases/${P/_/-}.tar.xz"
- SRC_URI+=" verify-sig? ( https://ffmpeg.org/releases/${P/_/-}.tar.xz.asc )"
- BDEPEND=" verify-sig? ( sec-keys/openpgp-keys-ffmpeg )"
+ SRC_URI+="
+ https://ffmpeg.org/releases/${P/_/-}.tar.xz
+ verify-sig? (
+ https://ffmpeg.org/releases/${P/_/-}.tar.xz.asc
+ soc? ( https://dev.gentoo.org/~chewi/distfiles/${SOC_PATCH}.asc )
+ )
+ "
+
+ BDEPEND="
+ verify-sig? (
+ sec-keys/openpgp-keys-ffmpeg
+ soc? ( sec-keys/openpgp-keys-gentoo-developers )
+ )
+ "
+
+ src_unpack() {
+ if use verify-sig; then
+ verify-sig_verify_detached "${DISTDIR}"/${P/_/-}.tar.xz{,.asc} /usr/share/openpgp-keys/ffmpeg.asc
+ use soc && verify-sig_verify_detached "${DISTDIR}"/${SOC_PATCH}{,.asc} /usr/share/openpgp-keys/gentoo-developers.asc
+ fi
+ default
+ }
fi
FFMPEG_REVISION="${PV#*_p}"
@@ -387,7 +403,7 @@ src_prepare() {
fi
use soc &&
- eapply "${SOC_PATCHES[@]/#/${DISTDIR}/}"
+ eapply "${DISTDIR}"/${SOC_PATCH}
default