summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorQuincy Fleming <quincyf467@protonmail.com>2024-11-11 01:41:33 -0600
committerSam James <sam@gentoo.org>2024-11-25 20:06:40 +0000
commitc43b019c1265f5c3400528056e9e943d6e87e63b (patch)
tree8a3d410509e180e9038bdaf0be4924568e37ec0f /media-video/ffmpeg/ffmpeg-9999.ebuild
parentnet-im/discord: add 0.0.76, drop 0.0.75 (diff)
downloadgentoo-c43b019c1265f5c3400528056e9e943d6e87e63b.tar.gz
gentoo-c43b019c1265f5c3400528056e9e943d6e87e63b.tar.bz2
gentoo-c43b019c1265f5c3400528056e9e943d6e87e63b.zip
media-video/ffmpeg: Fix build on musl
Closes: https://bugs.gentoo.org/940733 Signed-off-by: Quincy Fleming <quincyf467@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/39269 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-video/ffmpeg/ffmpeg-9999.ebuild')
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index 357a04d67a61..ba89f852efa0 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -549,6 +549,10 @@ multilib_src_configure() {
$(multilib_native_enable manpages)
)
+ if use elibc_musl ; then
+ append-cflags -DHAVE_POSIX_IOCTL
+ fi
+
# Use --extra-libs if needed for LIBS
set -- "${S}/configure" \
--prefix="${EPREFIX}/usr" \