summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-21 03:39:06 +0100
committerSam James <sam@gentoo.org>2022-08-21 03:39:06 +0100
commita73ef46b806cc76752ac0f6c3b453452787261bb (patch)
tree89ecc6ee0620b2c1e7c6513fd09a88616703a3ad /media-video/ffmpeg
parentmetadata/install-qa-check.d: add 60noop-testsuites (diff)
downloadgentoo-a73ef46b806cc76752ac0f6c3b453452787261bb.tar.gz
gentoo-a73ef46b806cc76752ac0f6c3b453452787261bb.tar.bz2
gentoo-a73ef46b806cc76752ac0f6c3b453452787261bb.zip
media-video/ffmpeg: fix configure with >=media-libs/libsdl2-2.24.0
ffmpeg needed adaptation to the new libsdl2 versioning scheme. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-video/ffmpeg')
-rw-r--r--media-video/ffmpeg/ffmpeg-4.4.2.ebuild3
-rw-r--r--media-video/ffmpeg/ffmpeg-5.0.1.ebuild3
-rw-r--r--media-video/ffmpeg/files/ffmpeg-4.4.2-libsdl2-new-version-scheme.patch25
-rw-r--r--media-video/ffmpeg/files/ffmpeg-5.0.1-libsdl2-new-version-scheme.patch25
4 files changed, 54 insertions, 2 deletions
diff --git a/media-video/ffmpeg/ffmpeg-4.4.2.ebuild b/media-video/ffmpeg/ffmpeg-4.4.2.ebuild
index 161cb301720b..49985fd883f3 100644
--- a/media-video/ffmpeg/ffmpeg-4.4.2.ebuild
+++ b/media-video/ffmpeg/ffmpeg-4.4.2.ebuild
@@ -332,7 +332,8 @@ S=${WORKDIR}/${P/_/-}
PATCHES=(
"${FILESDIR}"/chromium-r1.patch
- "${FILESDIR}"/ffmpeg-5.0-backport-ranlib-build-fix.patch
+ "${FILESDIR}"/${PN}-5.0-backport-ranlib-build-fix.patch
+ "${FILESDIR}"/${P}-libsdl2-new-version-scheme.patch
)
MULTILIB_WRAPPED_HEADERS=(
diff --git a/media-video/ffmpeg/ffmpeg-5.0.1.ebuild b/media-video/ffmpeg/ffmpeg-5.0.1.ebuild
index 17f3f4c919f0..09f3d902db11 100644
--- a/media-video/ffmpeg/ffmpeg-5.0.1.ebuild
+++ b/media-video/ffmpeg/ffmpeg-5.0.1.ebuild
@@ -332,7 +332,8 @@ S=${WORKDIR}/${P/_/-}
PATCHES=(
"${FILESDIR}"/chromium-r1.patch
- "${FILESDIR}"/ffmpeg-5.0-backport-ranlib-build-fix.patch
+ "${FILESDIR}"/${PN}-5.0-backport-ranlib-build-fix.patch
+ "${FILESDIR}"/${P}-libsdl2-new-version-scheme.patch
)
MULTILIB_WRAPPED_HEADERS=(
diff --git a/media-video/ffmpeg/files/ffmpeg-4.4.2-libsdl2-new-version-scheme.patch b/media-video/ffmpeg/files/ffmpeg-4.4.2-libsdl2-new-version-scheme.patch
new file mode 100644
index 000000000000..b592c2f9b72d
--- /dev/null
+++ b/media-video/ffmpeg/files/ffmpeg-4.4.2-libsdl2-new-version-scheme.patch
@@ -0,0 +1,25 @@
+https://git.ffmpeg.org/gitweb/ffmpeg.git/commitdiff/839f98ff6719cf2db0cbd88cd787a1b19b9cbf47
+
+From: Christopher Degawa <ccom@randomderp.com>
+Date: Wed, 11 May 2022 15:11:04 -0500
+Subject: [PATCH] configure: extend SDL check to accept all 2.x versions
+
+sdl2 recently changed their versioning, moving the patch level to minor level
+https://github.com/libsdl-org/SDL/commit/cd7c2f1de7d9e418bb554047d714dd7cacc020ff
+and have said that they will instead ship sdl3.pc for 3.0.0
+
+Fixes ticket 9768
+
+Signed-off-by: Christopher Degawa <ccom@randomderp.com>
+Signed-off-by: Gyan Doshi <ffmpeg@gyani.pro>
+--- a/configure
++++ b/configure
+@@ -6383,7 +6383,7 @@ fi
+
+ if enabled sdl2; then
+ SDL2_CONFIG="${cross_prefix}sdl2-config"
+- test_pkg_config sdl2 "sdl2 >= 2.0.1 sdl2 < 2.1.0" SDL_events.h SDL_PollEvent
++ test_pkg_config sdl2 "sdl2 >= 2.0.1 sdl2 < 3.0.0" SDL_events.h SDL_PollEvent
+ if disabled sdl2 && "${SDL2_CONFIG}" --version > /dev/null 2>&1; then
+ sdl2_cflags=$("${SDL2_CONFIG}" --cflags)
+ sdl2_extralibs=$("${SDL2_CONFIG}" --libs)
diff --git a/media-video/ffmpeg/files/ffmpeg-5.0.1-libsdl2-new-version-scheme.patch b/media-video/ffmpeg/files/ffmpeg-5.0.1-libsdl2-new-version-scheme.patch
new file mode 100644
index 000000000000..f95ff1cb7065
--- /dev/null
+++ b/media-video/ffmpeg/files/ffmpeg-5.0.1-libsdl2-new-version-scheme.patch
@@ -0,0 +1,25 @@
+https://git.ffmpeg.org/gitweb/ffmpeg.git/commitdiff/240d82f26eef10461c8b78b09a0db76c464deea8
+
+From: Christopher Degawa <ccom@randomderp.com>
+Date: Wed, 11 May 2022 15:11:04 -0500
+Subject: [PATCH] configure: extend SDL check to accept all 2.x versions
+
+sdl2 recently changed their versioning, moving the patch level to minor level
+https://github.com/libsdl-org/SDL/commit/cd7c2f1de7d9e418bb554047d714dd7cacc020ff
+and have said that they will instead ship sdl3.pc for 3.0.0
+
+Fixes ticket 9768
+
+Signed-off-by: Christopher Degawa <ccom@randomderp.com>
+Signed-off-by: Gyan Doshi <ffmpeg@gyani.pro>
+--- a/configure
++++ b/configure
+@@ -6739,7 +6739,7 @@ fi
+
+ if enabled sdl2; then
+ SDL2_CONFIG="${cross_prefix}sdl2-config"
+- test_pkg_config sdl2 "sdl2 >= 2.0.1 sdl2 < 2.1.0" SDL_events.h SDL_PollEvent
++ test_pkg_config sdl2 "sdl2 >= 2.0.1 sdl2 < 3.0.0" SDL_events.h SDL_PollEvent
+ if disabled sdl2 && "${SDL2_CONFIG}" --version > /dev/null 2>&1; then
+ sdl2_cflags=$("${SDL2_CONFIG}" --cflags)
+ sdl2_extralibs=$("${SDL2_CONFIG}" --libs)