summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/isight-firmware-tools
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/isight-firmware-tools')
-rw-r--r--media-video/isight-firmware-tools/Manifest1
-rw-r--r--media-video/isight-firmware-tools/files/isight-firmware-tools-1.5.90-build-O0.patch32
-rw-r--r--media-video/isight-firmware-tools/isight-firmware-tools-1.6-r1.ebuild60
-rw-r--r--media-video/isight-firmware-tools/metadata.xml10
4 files changed, 103 insertions, 0 deletions
diff --git a/media-video/isight-firmware-tools/Manifest b/media-video/isight-firmware-tools/Manifest
new file mode 100644
index 000000000000..092183649d2d
--- /dev/null
+++ b/media-video/isight-firmware-tools/Manifest
@@ -0,0 +1 @@
+DIST isight-firmware-tools-1.6.tar.gz 229122 SHA256 3181973db8a1cadd68785cd81959c8e1e9dc8110342ec1639a50db53d82a367e SHA512 1d72e10d1ff97665c96113c70786307e0b5d1cd24cd8f5fcd15ddd7b608ff1596023139a41f550a9fd288bd8968f69d348b433f5a739179fc0e3f8fa3e143fea WHIRLPOOL ac29469f205a3150f8ef0d95fc7c3b113559f325b172a8c4ccb1758195da32024b278d3e46b2eb899eca4e140758ef6b2381086b7f6e5c837adbb5b4bd3d520f
diff --git a/media-video/isight-firmware-tools/files/isight-firmware-tools-1.5.90-build-O0.patch b/media-video/isight-firmware-tools/files/isight-firmware-tools-1.5.90-build-O0.patch
new file mode 100644
index 000000000000..8308cf6860b2
--- /dev/null
+++ b/media-video/isight-firmware-tools/files/isight-firmware-tools-1.5.90-build-O0.patch
@@ -0,0 +1,32 @@
+--- src/export.c
++++ src/export.c
+@@ -35,6 +35,8 @@
+ #include <glib/gi18n.h>
+ #include <glib/gstdio.h>
+
++#include <locale.h>
++
+ /* OPTIONS */
+ static gchar *input = NULL;
+ static gchar *output = "isight.ihx";
+--- src/extract.c
++++ src/extract.c
+@@ -36,6 +36,8 @@
+ #include <glib/gi18n.h>
+ #include <glib/gstdio.h>
+
++#include <locale.h>
++
+ /*
+ * Foreach file identified by their sha1sum, we store the offset where
+ * the firmware begin in the file.
+--- src/load.h
++++ src/load.h
+@@ -36,6 +36,8 @@
+ #include <glib.h>
+ #include <usb.h>
+
++#include <locale.h>
++
+ #ifndef _LOAD_H_
+ #define _LOAD_H_
diff --git a/media-video/isight-firmware-tools/isight-firmware-tools-1.6-r1.ebuild b/media-video/isight-firmware-tools/isight-firmware-tools-1.6-r1.ebuild
new file mode 100644
index 000000000000..dec6aa14dde1
--- /dev/null
+++ b/media-video/isight-firmware-tools/isight-firmware-tools-1.6-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils versionator udev
+
+MY_MAJORV="$(get_version_component_range 1).6"
+
+DESCRIPTION="Extract, load or export firmware for the iSight webcams"
+HOMEPAGE="https://launchpad.net/isight-firmware-tools"
+SRC_URI="http://launchpad.net/${PN}/main/${MY_MAJORV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.14:2
+ dev-libs/libgcrypt:0
+ virtual/libusb:0
+ virtual/udev"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ sys-apps/texinfo
+ virtual/pkgconfig"
+
+src_prepare() {
+ # Fix build with -O0, bug #221325
+ epatch "${FILESDIR}"/${PN}-1.5.90-build-O0.patch
+
+ sed -i \
+ -e "s:@udevdir@:$(get_udevdir):" \
+ src/isight.rules.in.in || die
+}
+
+src_configure() {
+ # https://bugs.launchpad.net/isight-firmware-tools/+bug/243255
+ econf --docdir=/usr/share/doc/${PF}
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ libudevdir="$(get_udevdir)" \
+ rulesdir="$(get_udevdir)"/rules.d \
+ install
+
+ mv -vf "${D}/$(get_udevdir)"/rules.d/{isight.rules,70-isight.rules}
+
+ dodoc AUTHORS ChangeLog HOWTO NEWS README
+ rm -f "${D}"/usr/share/doc/${PF}/HOWTO
+}
+
+pkg_postinst() {
+ elog "You need to extract your firmware prior to being able to loading it"
+ elog "ift-extract --apple-driver /macos/System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns/AppleUSBVideoSupport.kext/Contents/MacOS/AppleUSBVideoSupport"
+ elog "If you do not have OSX you can get AppleUSBVideoSupport from"
+ elog "http://www.mediafire.com/?81xtkqyttjt"
+}
diff --git a/media-video/isight-firmware-tools/metadata.xml b/media-video/isight-firmware-tools/metadata.xml
new file mode 100644
index 000000000000..b480f9f9e385
--- /dev/null
+++ b/media-video/isight-firmware-tools/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>eva@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="launchpad">isight-firmware-tools</remote-id>
+ </upstream>
+</pkgmetadata>