summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-30 03:14:17 +0100
committerSam James <sam@gentoo.org>2022-09-30 03:14:26 +0100
commit7a0da2bafd776dfc30935a497316ec668a10aa24 (patch)
tree7e78fe85ddd942f95fb9a4bbe77412918301b711 /media-video/xine-ui
parentapp-emulation/uxn: bump to 0_p20220921 (diff)
downloadgentoo-7a0da2bafd776dfc30935a497316ec668a10aa24.tar.gz
gentoo-7a0da2bafd776dfc30935a497316ec668a10aa24.tar.bz2
gentoo-7a0da2bafd776dfc30935a497316ec668a10aa24.zip
media-video/xine-ui: backport build fix patch
Closes: https://bugs.gentoo.org/871951 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-video/xine-ui')
-rw-r--r--media-video/xine-ui/files/xine-ui-0.99.13-build.patch43
-rw-r--r--media-video/xine-ui/xine-ui-0.99.13.ebuild1
2 files changed, 44 insertions, 0 deletions
diff --git a/media-video/xine-ui/files/xine-ui-0.99.13-build.patch b/media-video/xine-ui/files/xine-ui-0.99.13-build.patch
new file mode 100644
index 000000000000..dc24720d97da
--- /dev/null
+++ b/media-video/xine-ui/files/xine-ui-0.99.13-build.patch
@@ -0,0 +1,43 @@
+hg diff -r e352b6eef94b6441f4afc86f96abe247acc2a60b -r f9a98e02460348ca23ca2f5c2b39e62c8758b22d
+https://sourceforge.net/p/xine/xine-ui/ci/e352b6eef94b6441f4afc86f96abe247acc2a60b/
+https://sourceforge.net/p/xine/tickets/10/
+https://bugs.gentoo.org/871951
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -600,8 +600,10 @@ int n = my_strlen ("what");
+ ])], [have_attr_iaso=yes], [have_attr_iaso=no])
+ AC_MSG_RESULT([$have_attr_iaso])
+ if test x"$have_attr_iaso" = x"yes" ; then
+- AC_DEFINE([ATTR_INLINE_ALL_STRINGOPS],
+- [__attribute__ ((__target__ ("inline-all-stringops")))],
++ AC_DEFINE([ATTR_INLINE_ALL_STRINGOPS], [__attribute__ ((__target__ ("inline-all-stringops")))],
++ [Define this to a function attribute that inlines string handling code])
++else
++ AC_DEFINE([ATTR_INLINE_ALL_STRINGOPS], [],
+ [Define this to a function attribute that inlines string handling code])
+ fi
+
+--- a/src/common/utils.h
++++ b/src/common/utils.h
+@@ -21,7 +21,7 @@
+ #ifndef _COMMON_UTILS_H
+ #define _COMMON_UTILS_H
+
+-#ifndef HAVE_CONFIG_H
++#ifndef PACKAGE_NAME
+ #error config.h not included
+ #endif
+
+--- a/src/xitk/network.c
++++ b/src/xitk/network.c
+@@ -34,7 +34,9 @@
+
+ //#warning IMPLEMENT POST SUPPORT
+
++#ifdef HAVE_CONFIG_H
+ #include "config.h"
++#endif
+
+ #ifdef HAVE_READLINE
+
diff --git a/media-video/xine-ui/xine-ui-0.99.13.ebuild b/media-video/xine-ui/xine-ui-0.99.13.ebuild
index 799cc50106f2..cba68d230908 100644
--- a/media-video/xine-ui/xine-ui-0.99.13.ebuild
+++ b/media-video/xine-ui/xine-ui-0.99.13.ebuild
@@ -50,6 +50,7 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}"/${PN}-0.99.10-desktop.patch
+ "${FILESDIR}"/${P}-build.patch
)
src_prepare() {