summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-04-18 18:17:45 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-04-18 18:19:14 +0200
commit7290f2c0a8a9297ca21df9e4d1fabbced4780845 (patch)
tree9487a62ee520a4ffb7b209e8ef3faf67692e22c3 /media-video
parentpackage.mask: Unmask dev-python/importlib_metadata (diff)
downloadgentoo-7290f2c0a8a9297ca21df9e4d1fabbced4780845.tar.gz
gentoo-7290f2c0a8a9297ca21df9e4d1fabbced4780845.tar.bz2
gentoo-7290f2c0a8a9297ca21df9e4d1fabbced4780845.zip
media-video/raspberrypi-omxplayer: Drop unmaintained live ebuild
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/raspberrypi-omxplayer/files/Makefile-0_p20160217.patch26
-rw-r--r--media-video/raspberrypi-omxplayer/raspberrypi-omxplayer-9999.ebuild50
2 files changed, 0 insertions, 76 deletions
diff --git a/media-video/raspberrypi-omxplayer/files/Makefile-0_p20160217.patch b/media-video/raspberrypi-omxplayer/files/Makefile-0_p20160217.patch
deleted file mode 100644
index c6f945209b95..000000000000
--- a/media-video/raspberrypi-omxplayer/files/Makefile-0_p20160217.patch
+++ /dev/null
@@ -1,26 +0,0 @@
---- omxplayer-9999/Makefile
-+++ omxplayer-9999/Makefile
-@@ -2,9 +2,11 @@
-
- CFLAGS+=-std=c++0x -D__STDC_CONSTANT_MACROS -D__STDC_LIMIT_MACROS -DTARGET_POSIX -DTARGET_LINUX -fPIC -DPIC -D_REENTRANT -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -DHAVE_CMAKE_CONFIG -D__VIDEOCORE4__ -U_FORTIFY_SOURCE -Wall -DHAVE_OMXLIB -DUSE_EXTERNAL_FFMPEG -DHAVE_LIBAVCODEC_AVCODEC_H -DHAVE_LIBAVUTIL_OPT_H -DHAVE_LIBAVUTIL_MEM_H -DHAVE_LIBAVUTIL_AVUTIL_H -DHAVE_LIBAVFORMAT_AVFORMAT_H -DHAVE_LIBAVFILTER_AVFILTER_H -DHAVE_LIBSWRESAMPLE_SWRESAMPLE_H -DOMX -DOMX_SKIP64BIT -ftree-vectorize -DUSE_EXTERNAL_OMX -DTARGET_RASPBERRY_PI -DUSE_EXTERNAL_LIBBCM_HOST
-
--LDFLAGS+=-L./ -Lffmpeg_compiled/usr/local/lib/ -lc -lWFC -lGLESv2 -lEGL -lbcm_host -lopenmaxil -lfreetype -lz
-+PKGS=freetype2 dbus-1 libavcodec libavutil libavformat libswresample libswscale libpcre
-+
-+LIBS+=-lrt -lpthread $(shell pkg-config --libs $(PKGS)) -L/opt/vc/lib
-
--INCLUDES+=-I./ -Ilinux -Iffmpeg_compiled/usr/local/include/ -I /usr/include/dbus-1.0 -I /usr/lib/arm-linux-gnueabihf/dbus-1.0/include
-+INCLUDES+=$(shell pkg-config --cflags $(PKGS)) -I/opt/vc/include -I. -Ilinux
-
- DIST ?= omxplayer-dist
-
-@@ -51,8 +47,7 @@
- bash gen_version.sh > version.h
-
- omxplayer.bin: version $(OBJS)
-- $(CXX) $(LDFLAGS) -o omxplayer.bin $(OBJS) -lvchiq_arm -lvcos -ldbus-1 -lrt -lpthread -lavutil -lavcodec -lavformat -lswscale -lswresample -lpcre
-- $(STRIP) omxplayer.bin
-+ $(CXX) $(LDFLAGS) -o omxplayer.bin $(OBJS) $(LIBS)
-
- help.h: README.md Makefile
- awk '/SYNOPSIS/{p=1;print;next} p&&/KEY BINDINGS/{p=0};p' $< \
diff --git a/media-video/raspberrypi-omxplayer/raspberrypi-omxplayer-9999.ebuild b/media-video/raspberrypi-omxplayer/raspberrypi-omxplayer-9999.ebuild
deleted file mode 100644
index 90690f9a531d..000000000000
--- a/media-video/raspberrypi-omxplayer/raspberrypi-omxplayer-9999.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit epatch git-r3 toolchain-funcs flag-o-matic
-
-DESCRIPTION="Command line media player for the Raspberry Pi"
-HOMEPAGE="https://github.com/popcornmix/omxplayer"
-EGIT_REPO_URI="https://github.com/popcornmix/omxplayer.git"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS=""
-IUSE="X"
-
-RDEPEND="dev-libs/libpcre
- media-fonts/freefont
- || ( media-libs/raspberrypi-userland media-libs/raspberrypi-userland-bin )
- sys-apps/dbus
- sys-apps/fbset
- media-video/ffmpeg
- dev-libs/boost
- media-libs/freetype:2
- X? (
- x11-apps/xrefresh
- x11-apps/xset
- )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_prepare() {
- epatch "${FILESDIR}"/Makefile-0_p20160217.patch \
- "${FILESDIR}"/fonts-path.patch
-
- cat > Makefile.include << EOF
-LIBS=-lvchiq_arm -lvcos -lbcm_host -lEGL -lGLESv2 -lopenmaxil -lrt -lpthread
-EOF
-
- tc-export CXX
-}
-
-src_compile() {
- emake omxplayer.bin
-}
-
-src_install() {
- dobin omxplayer omxplayer.bin
- dodoc README.md
-}