summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2017-07-25 10:50:05 -0600
committerSteve Dibb <beandog@gentoo.org>2017-07-25 10:50:05 -0600
commita78247bc9eb78753ac88a9c4d227f4e0f48930c8 (patch)
tree11684b4eee887176ee99cefe0133058bd0abc5a7 /media-video
parentkde-apps/kde4-l10n: Re-add missing blocker (diff)
downloadgentoo-a78247bc9eb78753ac88a9c4d227f4e0f48930c8.tar.gz
gentoo-a78247bc9eb78753ac88a9c4d227f4e0f48930c8.tar.bz2
gentoo-a78247bc9eb78753ac88a9c4d227f4e0f48930c8.zip
media-video/gpac: version bump
Drop old patches, new configure patch, bug 621004 Package-Manager: Portage-2.3.0, Repoman-2.3.1
Diffstat (limited to 'media-video')
-rw-r--r--media-video/gpac/Manifest1
-rw-r--r--media-video/gpac/files/gpac-0.7.1-configure.patch94
-rw-r--r--media-video/gpac/gpac-0.7.1.ebuild136
3 files changed, 231 insertions, 0 deletions
diff --git a/media-video/gpac/Manifest b/media-video/gpac/Manifest
index 82a0e27b6dfb..02aa8d5998f9 100644
--- a/media-video/gpac/Manifest
+++ b/media-video/gpac/Manifest
@@ -1 +1,2 @@
DIST gpac-0.6.1.tar.gz 9113143 SHA256 67d1ac8f8b3e74da0e4e38ea926dc15bca6e9941e8f366e3538abcf13c103c09 SHA512 b1409a8ebcda08c3af504d7de591528ef84f5c3d8d506dd490502e16493de11c2435ea3f5957f39100a2ce040d5e431c86a5a203f806fcc865ae4b08f6cf5595 WHIRLPOOL bd0c87841036220623021898f0b82d2364fd37c5254f58cd7db33617350f0864ce9672b8cbfa10f0d08948f2842fe9b19db9f562074c43df6d94cf2b13a7d141
+DIST gpac-0.7.1.tar.gz 10654838 SHA256 c7a18b9eea1264fee392e7222d16b180e0acdd6bb173ff6b8baadbf50b3b1d7f SHA512 0377d9471db9e5ccf75f85dfd0c9f4e37a211108b5e128a5411ac015bd9c906257320d517717f0fa03d434e1fce24bd8a9c3a73200fac5c21b80895b716ab403 WHIRLPOOL a82e6de4a48b29ca0b74eb206075302aa9db34cfa6681a1e98f22cfc88c43c5f0d0557ade6e770fe9b9f47756039fcb8ef42bd892ab08ef7a7e0fbbd4f239057
diff --git a/media-video/gpac/files/gpac-0.7.1-configure.patch b/media-video/gpac/files/gpac-0.7.1-configure.patch
new file mode 100644
index 000000000000..8bc3ec9f9079
--- /dev/null
+++ b/media-video/gpac/files/gpac-0.7.1-configure.patch
@@ -0,0 +1,94 @@
+--- gpac-0.7.1/Makefile.orig 2017-07-25 09:34:51.910379115 -0600
++++ gpac-0.7.1/Makefile 2017-07-25 09:36:18.906385736 -0600
+@@ -252,7 +252,9 @@
+ $(INSTALL) $(INSTFLAGS) -m 644 $(SRC_PATH)/include/gpac/enst/*.h "$(DESTDIR)$(prefix)/include/gpac/enst"
+ endif
+ mkdir -p "$(DESTDIR)$(prefix)/$(libdir)"
++ifeq ($(STATIC_LIBS),yes)
+ $(INSTALL) $(INSTFLAGS) -m 644 "./bin/gcc/libgpac_static.a" "$(DESTDIR)$(prefix)/$(libdir)"
++endif
+ $(MAKE) installdylib
+
+ uninstall-lib:
+--- gpac-0.7.1/src/Makefile.orig 2017-07-25 09:37:48.157392528 -0600
++++ gpac-0.7.1/src/Makefile 2017-07-25 09:39:06.092398459 -0600
+@@ -267,16 +267,20 @@
+
+ ifeq ($(CONFIG_DARWIN),yes)
+
++ifeq ($(STATICLIBS),yes)
+ $(LIBTOOL) -s -o ../bin/gcc/libgpac_static.a $(OBJS)
+ $(RANLIB) ../bin/gcc/libgpac_static.a
++endif
+ ifneq ($(STATICBUILD),yes)
+ $(CC) $(SHFLAGS) $(LD_SONAME) -o $@ $(OBJS) $(EXTRALIBS) $(LDFLAGS)
+ endif
+
+ else
+
++ifeq ($(STATICLIBS),yes)
+ $(AR) cr ../bin/gcc/libgpac_static.a $(OBJS)
+ $(RANLIB) ../bin/gcc/libgpac_static.a
++endif
+ ifneq ($(STATICBUILD),yes)
+ $(CC) $(SHFLAGS) $(LD_SONAME) -o $@ $(OBJS) $(EXTRALIBS) $(LDFLAGS)
+ mv $@ $@.$(VERSION_SONAME)
+--- gpac-0.7.1/configure.orig 2017-07-25 10:01:58.789502926 -0600
++++ gpac-0.7.1/configure 2017-07-25 10:02:54.110507136 -0600
+@@ -109,6 +109,7 @@
+ has_openjpeg="no"
+ gprof_build="no"
+ static_build="no"
++static_libs="no"
+ want_pic="no"
+ want_gcov="no"
+ has_joystick="no"
+@@ -260,6 +261,7 @@
+ --enable-amr-wb enable AMR WB library
+ --enable-amr enable both AMR NB and WB libraries
+ --enable-static-bin link statically against libgpac
++ --enable-static-lib GPAC static libraries build
+ --static-mp4box configure for static linking of MP4Box only.
+ --enable-depth enables depth handling in the compositor
+
+@@ -705,15 +707,6 @@
+ CFLAGS="$CFLAGS -Wno-pointer-sign"
+ fi
+
+-
+-#GCC opt
+-if test "$no_gcc_opt" = "no"; then
+- CFLAGS="-O3 $CFLAGS"
+-else
+- CFLAGS="-O0 $CFLAGS"
+-fi
+-
+-
+ #GCC PIC
+ if test "$cross_prefix" != "" ; then
+ want_pic="no"
+@@ -1885,6 +1878,8 @@
+ ;;
+ --enable-static-bin) static_build="yes";
+ ;;
++ --enable-static-lib) static_libs="yes";
++ ;;
+ --disable-ipv6) has_ipv6="no"
+ ;;
+ --disable-wx) has_wx="no"
+@@ -2559,6 +2554,7 @@
+ echo "debug version: $debuginfo"
+ echo "GProf enabled: $gprof_build"
+ echo "Static build enabled: $static_build"
++echo "Static libs enabled: $static_libs"
+ echo "Memory tracking enabled: $use_memory_tracking"
+ echo "Fixed-Point Version: $use_fixed_point"
+ echo "IPV6 Support: $has_ipv6"
+@@ -3194,6 +3190,7 @@
+ echo "GPROFBUILD=$gprof_build" >> config.mak
+ echo "MP4BOX_STATIC=$static_mp4box" >> config.mak
+ echo "STATICBUILD=$static_build" >> config.mak
++echo "STATICLIBS=$static_libs" >> config.mak
+
+ echo "CONFIG_IPV6=$has_ipv6" >> config.mak
+ if test "$has_ipv6" = "yes" ; then
diff --git a/media-video/gpac/gpac-0.7.1.ebuild b/media-video/gpac/gpac-0.7.1.ebuild
new file mode 100644
index 000000000000..a17425b4c9f1
--- /dev/null
+++ b/media-video/gpac/gpac-0.7.1.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == *9999 ]] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/gpac/gpac"
+else
+ SRC_URI="https://github.com/gpac/gpac/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+fi
+
+inherit eutils flag-o-matic multilib toolchain-funcs ${SCM}
+
+DESCRIPTION="Implementation of the MPEG-4 Systems standard developed from scratch in ANSI C"
+HOMEPAGE="https://gpac.wp.imt.fr/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="a52 aac alsa debug dvb ffmpeg ipv6 jack jpeg jpeg2k libav libressl mad opengl oss png
+ pulseaudio sdl ssl static-libs theora truetype vorbis xml xvid X"
+
+RDEPEND="
+ a52? ( media-libs/a52dec )
+ aac? ( >=media-libs/faad2-2.0 )
+ alsa? ( media-libs/alsa-lib )
+ dvb? ( media-tv/linuxtv-dvb-apps )
+ ffmpeg? (
+ !libav? ( media-video/ffmpeg:0= )
+ libav? ( media-video/libav:0= ) )
+ jack? ( media-sound/jack-audio-connection-kit )
+ jpeg? ( virtual/jpeg:0 )
+ mad? ( >=media-libs/libmad-0.15.1b )
+ opengl? ( virtual/opengl media-libs/freeglut virtual/glu )
+ >=media-libs/libogg-1.1
+ png? ( >=media-libs/libpng-1.4:0= )
+ vorbis? ( >=media-libs/libvorbis-1.1 )
+ theora? ( media-libs/libtheora )
+ truetype? ( >=media-libs/freetype-2.1.4:2 )
+ xml? ( >=dev-libs/libxml2-2.6.0:2 )
+ xvid? ( >=media-libs/xvid-1.0.1 )
+ sdl? ( media-libs/libsdl )
+ jpeg2k? ( media-libs/openjpeg:0 )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= ) )
+ pulseaudio? ( media-sound/pulseaudio )
+ X? (
+ x11-libs/libXt
+ x11-libs/libX11
+ x11-libs/libXv
+ x11-libs/libXext
+ )
+"
+# disabled upstream, see applications/Makefile
+# wxwidgets? ( =x11-libs/wxGTK-2.8* )
+DEPEND="${RDEPEND}"
+
+# DOCS="AUTHORS BUGS Changelog README.md TODO doc/CODING_STYLE doc/*.doc doc/*.bt doc/SceneGenerators doc/ipmpx_syntax.bt doc/*.txt"
+PATCHES=(
+ "${FILESDIR}/${PN}-0.7.1-configure.patch"
+)
+
+DOCS=(
+ doc/CODING_STYLE
+ doc/GPAC\ UPnP.doc
+ doc/ISO\ 639-2\ codes.txt
+ doc/SceneGenerators
+ doc/ipmpx_syntax.bt
+ Changelog
+ AUTHORS
+ BUGS
+ README.md
+ TODO
+)
+HTML_DOCS="doc/*.html"
+
+my_use() {
+ local flag="$1" pflag="${2:-$1}"
+ if use ${flag}; then
+ echo "--use-${pflag}=system"
+ else
+ echo "--use-${pflag}=no"
+ fi
+}
+
+src_prepare() {
+ default
+ sed -i -e "s:\(--disable-.*\)=\*):\1):" configure || die
+}
+
+src_configure() {
+ tc-export CC CXX AR RANLIB
+
+ econf \
+ --enable-svg \
+ --enable-pic \
+ --disable-amr \
+ --use-js=no \
+ --use-ogg=system \
+ $(use_enable alsa) \
+ $(use_enable debug) \
+ $(use_enable ipv6) \
+ $(use_enable jack jack yes) \
+ $(use_enable opengl 3d) \
+ $(use_enable oss oss-audio) \
+ $(use_enable pulseaudio pulseaudio yes) \
+ $(use_enable sdl) \
+ $(use_enable ssl) \
+ $(use_enable static-libs static-lib) \
+ $(use_enable X x11) $(use_enable X x11-shm) $(use_enable X x11-xv) \
+ --disable-wx \
+ $(my_use a52) \
+ $(my_use aac faad) \
+ $(my_use dvb dvbx) \
+ $(my_use ffmpeg) \
+ $(my_use jpeg) \
+ $(my_use jpeg2k openjpeg) \
+ $(my_use mad) \
+ $(my_use png) \
+ $(my_use theora) \
+ $(my_use truetype ft) \
+ $(my_use vorbis) \
+ $(my_use xvid) \
+ --extra-cflags="${CFLAGS}" \
+ --cc="$(tc-getCC)" \
+ --libdir="/$(get_libdir)" \
+ --verbose
+}
+
+src_install() {
+ einstalldocs
+ emake STRIP="true" DESTDIR="${D}" install
+ emake STRIP="true" DESTDIR="${D}" install-lib
+}