summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZamarin Arthur <arthurzam@gmail.com>2021-03-27 16:58:00 +0300
committerJoonas Niilola <juippis@gentoo.org>2021-03-31 14:09:19 +0300
commitb9b38d4a9ecd37f38c397b088744ebcf1510618e (patch)
treed0b601b413a3673848319fb829b0838e87dbd9d2 /media-video
parentmedia-video/qmplay2: add 21.03.09 (diff)
downloadgentoo-b9b38d4a9ecd37f38c397b088744ebcf1510618e.tar.gz
gentoo-b9b38d4a9ecd37f38c397b088744ebcf1510618e.tar.bz2
gentoo-b9b38d4a9ecd37f38c397b088744ebcf1510618e.zip
media-video/qmplay2: update live version
- add pipewire use flag Signed-off-by: Zamarin Arthur <arthurzam@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/20147 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/qmplay2/qmplay2-9999.ebuild22
1 files changed, 6 insertions, 16 deletions
diff --git a/media-video/qmplay2/qmplay2-9999.ebuild b/media-video/qmplay2/qmplay2-9999.ebuild
index 264d28c79f26..b626780caa01 100644
--- a/media-video/qmplay2/qmplay2-9999.ebuild
+++ b/media-video/qmplay2/qmplay2-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake xdg-utils
+inherit cmake xdg
DESCRIPTION="A Qt-based video player, which can play most formats and codecs"
HOMEPAGE="https://github.com/zaps166/QMPlay2"
@@ -21,11 +21,11 @@ LICENSE="LGPL-3"
SLOT="0"
IUSE="avdevice +audiofilters +alsa cdio cuvid dbus extensions
- gme inputs libass modplug notifications opengl portaudio
+ gme inputs libass modplug notifications opengl pipewire portaudio
pulseaudio sid shaders vaapi vdpau +videofilters visualizations vulkan xv"
REQUIRED_USE="
- audiofilters? ( || ( alsa portaudio pulseaudio ) )
+ audiofilters? ( || ( alsa pipewire portaudio pulseaudio ) )
extensions? ( dbus )
shaders? ( vulkan )"
@@ -49,6 +49,7 @@ RDEPEND="
gme? ( media-libs/game-music-emu )
libass? ( media-libs/libass )
opengl? ( virtual/opengl )
+ pipewire? ( media-video/pipewire )
portaudio? ( media-libs/portaudio )
pulseaudio? ( media-sound/pulseaudio )
sid? ( media-libs/libsidplayfp )
@@ -108,6 +109,7 @@ src_configure() {
-DUSE_CUVID=$(usex cuvid)
-DUSE_INPUTS=$(usex inputs)
-DUSE_MODPLUG=$(usex modplug)
+ -DUSE_PIPEWIRE=$(usex pipewire)
-DUSE_PORTAUDIO=$(usex portaudio)
-DUSE_PULSEAUDIO=$(usex pulseaudio)
-DUSE_VIDEOFILTERS=$(usex videofilters)
@@ -135,15 +137,3 @@ src_configure() {
cmake_src_configure
}
-
-pkg_postinst() {
- xdg_icon_cache_update
- xdg_mimeinfo_database_update
- xdg_desktop_database_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
- xdg_mimeinfo_database_update
- xdg_desktop_database_update
-}