summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-08-11 02:00:15 +0100
committerSam James <sam@gentoo.org>2021-08-11 02:00:15 +0100
commit00402f66d1cdf8144ff08f446010cfdbd8d2fe4a (patch)
tree6cb9dda284d447fd76a1d47786f8dd53f6ce2e05 /net-analyzer/fail2ban/fail2ban-9999.ebuild
parentdev-util/diffoscope: fix DISTUTILS_USE_SETUPTOOLS (diff)
downloadgentoo-00402f66d1cdf8144ff08f446010cfdbd8d2fe4a.tar.gz
gentoo-00402f66d1cdf8144ff08f446010cfdbd8d2fe4a.tar.bz2
gentoo-00402f66d1cdf8144ff08f446010cfdbd8d2fe4a.zip
net-analyzer/fail2ban: fix Apache log path
Closes: https://bugs.gentoo.org/805485 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/fail2ban/fail2ban-9999.ebuild')
-rw-r--r--net-analyzer/fail2ban/fail2ban-9999.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/net-analyzer/fail2ban/fail2ban-9999.ebuild b/net-analyzer/fail2ban/fail2ban-9999.ebuild
index 2ad8f462e23d..9d117cebef47 100644
--- a/net-analyzer/fail2ban/fail2ban-9999.ebuild
+++ b/net-analyzer/fail2ban/fail2ban-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8,9} )
DISTUTILS_SINGLE_IMPL=1
inherit bash-completion-r1 distutils-r1 systemd tmpfiles
@@ -38,6 +38,10 @@ RDEPEND="
DOCS=( ChangeLog DEVELOP README.md THANKS TODO doc/run-rootless.txt )
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.11.2-adjust-apache-logs-paths.patch
+)
+
python_prepare_all() {
# Replace /var/run with /run, but not in the top source directory
find . -mindepth 2 -type f -exec \