summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-02-24 06:32:35 +0100
committerJeroen Roovers <jer@gentoo.org>2016-02-24 06:32:35 +0100
commitfb18f46168250ca341ab2ee95f1c3e0891edebd3 (patch)
tree32c971abe6144e7415e0a8727a80148df5904082 /net-analyzer/fwlogwatch/fwlogwatch-1.5.ebuild
parentnet-misc/youtube-dl: Old. (diff)
downloadgentoo-fb18f46168250ca341ab2ee95f1c3e0891edebd3.tar.gz
gentoo-fb18f46168250ca341ab2ee95f1c3e0891edebd3.tar.bz2
gentoo-fb18f46168250ca341ab2ee95f1c3e0891edebd3.zip
net-analyzer/fwlogwatch: Version bump.
Package-Manager: portage-2.2.27
Diffstat (limited to 'net-analyzer/fwlogwatch/fwlogwatch-1.5.ebuild')
-rw-r--r--net-analyzer/fwlogwatch/fwlogwatch-1.5.ebuild87
1 files changed, 87 insertions, 0 deletions
diff --git a/net-analyzer/fwlogwatch/fwlogwatch-1.5.ebuild b/net-analyzer/fwlogwatch/fwlogwatch-1.5.ebuild
new file mode 100644
index 000000000000..1479b995f8d8
--- /dev/null
+++ b/net-analyzer/fwlogwatch/fwlogwatch-1.5.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="A packet filter and firewall log analyzer"
+HOMEPAGE="http://fwlogwatch.inside-security.de/"
+SRC_URI="${HOMEPAGE}sw/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+LICENSE="GPL-1"
+SLOT="0"
+IUSE="nls zlib"
+
+RDEPEND="
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="
+ ${RDEPEND}
+ sys-devel/flex
+ nls? ( sys-devel/gettext )
+"
+
+src_prepare() {
+ if use nls; then
+ strip-linguas -i po/
+ local lingua pofile
+ for pofile in po/*.po; do
+ lingua=${pofile/po\/}
+ lingua=${lingua/.po}
+ if ! has ${lingua} ${LINGUAS}; then
+ sed -i \
+ -e "/${lingua}.[mp]o/d" \
+ Makefile po/Makefile || die
+ fi
+ done
+ fi
+
+ sed -i \
+ -e '/^INSTALL_/s|$| -D|g' \
+ -e 's|make|$(MAKE)|g ' \
+ Makefile || die
+}
+
+src_configure() {
+ if ! use zlib; then
+ sed -i Makefile -e '/^LIBS/ s|-lz||g' || die
+ else
+ append-cflags -DHAVE_ZLIB
+ fi
+
+ use nls && append-cflags -DHAVE_GETTEXT
+}
+
+src_compile() {
+ emake \
+ CC=$(tc-getCC) \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+ use nls && emake -C po
+}
+
+src_install() {
+ emake \
+ LOCALE_DIR="${D}/usr" INSTALL_DIR="${D}/usr" \
+ install
+ use nls && emake \
+ LOCALE_DIR="${D}/usr" INSTALL_DIR="${D}/usr" \
+ install-i18n
+
+ dosbin contrib/fwlw_notify
+ dosbin contrib/fwlw_respond
+
+ dodoc AUTHORS ChangeLog CREDITS README
+
+ insinto /usr/share/fwlogwatch/contrib
+
+ doins contrib/fwlogsummary.cgi
+ doins contrib/fwlogsummary_small.cgi
+ doins contrib/fwlogwatch.php
+
+ insinto /etc
+ doins fwlogwatch.config
+}