summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2018-06-25 12:11:53 +0200
committerLouis Sautier <sbraz@gentoo.org>2018-06-25 23:24:34 +0200
commitd4c60400f9bcd7871e8aa78426f86904d1099118 (patch)
treed483a28e825059d6b2e540951ac3363546eb0b79 /net-analyzer/graphite-web/files
parentnet-analyzer/graphite-web: update HOMEPAGE, add GitHub to metadata.xml (diff)
downloadgentoo-d4c60400f9bcd7871e8aa78426f86904d1099118.tar.gz
gentoo-d4c60400f9bcd7871e8aa78426f86904d1099118.tar.bz2
gentoo-d4c60400f9bcd7871e8aa78426f86904d1099118.zip
net-analyzer/graphite-web: fix deps, re-add USE=ldap, misc.
* Sort dependencies. * Do not require python[sqlite], it is never directly used. * Do not require twisted or txAMQP, they are not directly used by graphite-web. * Do not require zope-interface, it was removed in https://github.com/graphite-project/graphite-web/commit/bed2d5b82d128b751ea080d86a4ccb9c27bb6c58 * Do not require whisper. It is optional and in the future we could probably use carbon with ceres instead of whisper. * pytz and pyparsing are not bundled any more, remove the call to rm. * Use python_prepare_all instead of src_prepare. * Install examples only once in the _all function. Use dodoc instead of doins. Do not compress them. * Use the recommended way to configure the app instead of re-creating manage.py. * Do not remove build-index from install but rename it. * Run build-index during pkg_config() instead of just creating an empty file. This allows us to drop the complex python file parsing. * Mention build-index in the postinst message. Only display the message for new installs. Use elog instead of einfo. * Create the /var/{lib,log}/graphite-web directories which are referenced in local_settings.py. * Add the example database location to the FHS-style settings patch. * Fix STATIC_ROOT in the FHS-style settings patch. * Add missing || die to the ln call. * bump to EAPI=7. Closes: https://github.com/gentoo/gentoo/pull/8962 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'net-analyzer/graphite-web/files')
-rw-r--r--net-analyzer/graphite-web/files/graphite-web-1.1.3-fhs-paths.patch14
1 files changed, 12 insertions, 2 deletions
diff --git a/net-analyzer/graphite-web/files/graphite-web-1.1.3-fhs-paths.patch b/net-analyzer/graphite-web/files/graphite-web-1.1.3-fhs-paths.patch
index 39d325984245..aa6ea74ff93f 100644
--- a/net-analyzer/graphite-web/files/graphite-web-1.1.3-fhs-paths.patch
+++ b/net-analyzer/graphite-web/files/graphite-web-1.1.3-fhs-paths.patch
@@ -10,11 +10,12 @@ Install FHS-style paths
from graphite.wsgi import application
--- a/setup.py
+++ b/setup.py
-@@ -59,8 +59,7 @@
+@@ -59,8 +59,8 @@
],
package_data={'graphite' :
['templates/*', 'local_settings.py.example']},
- scripts=glob('bin/*'),
++ scripts=['bin/graphite-web-build-index'],
- data_files=list(webapp_content.items()) + storage_dirs + conf_files + examples,
+ data_files=list(webapp_content.items()),
install_requires=['Django>=1.8,<1.11.99', 'django-tagging==0.4.3', 'pytz', 'pyparsing', 'cairocffi', 'urllib3', 'scandir', 'six'],
@@ -36,7 +37,7 @@ Install FHS-style paths
#INDEX_FILE = '/opt/graphite/storage/index' # Search index file
+CONF_DIR = '@GENTOO_PORTAGE_EPREFIX@/etc/graphite-web'
+STORAGE_DIR = '@GENTOO_PORTAGE_EPREFIX@/var/lib/carbon'
-+STATIC_ROOT = '@GENTOO_PORTAGE_EPREFIX@/usr/share/graphite-web'
++STATIC_ROOT = '@GENTOO_PORTAGE_EPREFIX@/usr/share/graphite-web/webapp/content'
+LOG_DIR = '@GENTOO_PORTAGE_EPREFIX@/var/log/graphite-web'
+INDEX_FILE = '@GENTOO_PORTAGE_EPREFIX@/var/lib/graphite-web/index' # Search index file
@@ -51,3 +52,12 @@ Install FHS-style paths
#
# Data directories using the "Standard" metrics finder (i.e. not Ceres)
#STANDARD_DIRS = [WHISPER_DIR, RRD_DIR] # Default: set from the above variables
+@@ -244,7 +244,7 @@
+ #
+ #DATABASES = {
+ # 'default': {
+-# 'NAME': '/opt/graphite/storage/graphite.db',
++# 'NAME': '@GENTOO_PORTAGE_EPREFIX@/var/lib/graphite-web/graphite.db',
+ # 'ENGINE': 'django.db.backends.sqlite3',
+ # 'USER': '',
+ # 'PASSWORD': '',