summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/nethogs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/nethogs')
-rw-r--r--net-analyzer/nethogs/Manifest1
-rw-r--r--net-analyzer/nethogs/files/nethogs-0.8.0-gentoo.patch70
-rw-r--r--net-analyzer/nethogs/metadata.xml16
-rw-r--r--net-analyzer/nethogs/nethogs-0.8.0-r4.ebuild33
4 files changed, 120 insertions, 0 deletions
diff --git a/net-analyzer/nethogs/Manifest b/net-analyzer/nethogs/Manifest
new file mode 100644
index 000000000000..27b656dec1ad
--- /dev/null
+++ b/net-analyzer/nethogs/Manifest
@@ -0,0 +1 @@
+DIST nethogs-0.8.0.tar.gz 38036 SHA256 b09cb3c2690a522f8b1314221095d5abb1958d50b56de6d36b11a8e6f28961d0 SHA512 6530c1bdbdf1ace7368941e8e0e53a83ac808bbea7a952936fa570ad2d49e8b4cef6a37d433f1873655edfd63cce556146a48ff81665905827237edf50419446 WHIRLPOOL 1b7c7456e2c55df0be188a0858ee039f7fde52ae58554ca16f7b92f732735ad4e225341526f6c4d36051898160cb063dac6fc4479ff1e3decabc9d62346dd3d5
diff --git a/net-analyzer/nethogs/files/nethogs-0.8.0-gentoo.patch b/net-analyzer/nethogs/files/nethogs-0.8.0-gentoo.patch
new file mode 100644
index 000000000000..292af8e4175b
--- /dev/null
+++ b/net-analyzer/nethogs/files/nethogs-0.8.0-gentoo.patch
@@ -0,0 +1,70 @@
+--- a/Makefile
++++ b/Makefile
+@@ -5,15 +5,17 @@
+ #DESTDIR := /usr
+ DESTDIR := /usr/local
+
+-sbin := $(DESTDIR)/sbin
+-man8 := $(DESTDIR)/share/man/man8/
++sbin := $(DESTDIR)/usr/sbin
++man8 := $(DESTDIR)/usr/share/man/man8/
+
+ all: nethogs decpcap_test
+ # nethogs_testsum
+
+-CFLAGS=-g -Wall -Wextra
+-#CFLAGS=-O2
++CXXFLAGS+= -Wall -Wextra
+ OBJS=packet.o connection.o process.o refresh.o decpcap.o cui.o inode2prog.o conninode.o devices.o
++
++LIBS = $(shell $(PKG_CONFIG) --libs ncurses)
++
+ .PHONY: tgz
+
+ tgz: clean
+@@ -30,33 +32,33 @@
+ install -m 644 nethogs.8 $(man8)
+
+ nethogs: nethogs.cpp $(OBJS)
+- $(CXX) $(CFLAGS) nethogs.cpp $(OBJS) -o nethogs -lpcap -lm -lncurses -DVERSION=\"$(VERSION)\" -DSUBVERSION=\"$(SUBVERSION)\" -DMINORVERSION=\"$(MINORVERSION)\"
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) nethogs.cpp $(OBJS) -o nethogs -lpcap -lm $(LIBS) -DVERSION=\"$(VERSION)\" -DSUBVERSION=\"$(SUBVERSION)\" -DMINORVERSION=\"$(MINORVERSION)\"
+ nethogs_testsum: nethogs_testsum.cpp $(OBJS)
+- $(CXX) $(CFLAGS) -g nethogs_testsum.cpp $(OBJS) -o nethogs_testsum -lpcap -lm -lncurses -DVERSION=\"$(VERSION)\" -DSUBVERSION=\"$(SUBVERSION)\" -DMINORVERSION=\"$(MINORVERSION)\"
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -g nethogs_testsum.cpp $(OBJS) -o nethogs_testsum -lpcap -lm $(LIBS) -DVERSION=\"$(VERSION)\" -DSUBVERSION=\"$(SUBVERSION)\" -DMINORVERSION=\"$(MINORVERSION)\"
+
+ decpcap_test: decpcap_test.cpp decpcap.o
+- $(CXX) $(CFLAGS) decpcap_test.cpp decpcap.o -o decpcap_test -lpcap -lm
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) decpcap_test.cpp decpcap.o -o decpcap_test -lpcap -lm
+
+ #-lefence
+
+ refresh.o: refresh.cpp refresh.h nethogs.h
+- $(CXX) $(CFLAGS) -c refresh.cpp
++ $(CXX) $(CXXFLAGS) -c refresh.cpp
+ process.o: process.cpp process.h nethogs.h
+- $(CXX) $(CFLAGS) -c process.cpp
++ $(CXX) $(CXXFLAGS) -c process.cpp
+ packet.o: packet.cpp packet.h nethogs.h
+- $(CXX) $(CFLAGS) -c packet.cpp
++ $(CXX) $(CXXFLAGS) -c packet.cpp
+ connection.o: connection.cpp connection.h nethogs.h
+- $(CXX) $(CFLAGS) -c connection.cpp
++ $(CXX) $(CXXFLAGS) -c connection.cpp
+ decpcap.o: decpcap.c decpcap.h
+- $(CC) $(CFLAGS) -c decpcap.c
++ $(CC) $(CXXFLAGS) -c decpcap.c
+ inode2prog.o: inode2prog.cpp inode2prog.h nethogs.h
+- $(CXX) $(CFLAGS) -c inode2prog.cpp
++ $(CXX) $(CXXFLAGS) -c inode2prog.cpp
+ conninode.o: conninode.cpp nethogs.h conninode.h
+- $(CXX) $(CFLAGS) -c conninode.cpp
++ $(CXX) $(CXXFLAGS) -c conninode.cpp
+ #devices.o: devices.cpp devices.h
+-# $(CXX) $(CFLAGS) -c devices.cpp
++# $(CXX) $(CXXFLAGS) -c devices.cpp
+ cui.o: cui.cpp cui.h nethogs.h
+- $(CXX) $(CFLAGS) -c cui.cpp -DVERSION=\"$(VERSION)\" -DSUBVERSION=\"$(SUBVERSION)\" -DMINORVERSION=\"$(MINORVERSION)\"
++ $(CXX) $(CXXFLAGS) -c cui.cpp -DVERSION=\"$(VERSION)\" -DSUBVERSION=\"$(SUBVERSION)\" -DMINORVERSION=\"$(MINORVERSION)\"
+
+ .PHONY: clean
+ clean:
diff --git a/net-analyzer/nethogs/metadata.xml b/net-analyzer/nethogs/metadata.xml
new file mode 100644
index 000000000000..312bf770c96d
--- /dev/null
+++ b/net-analyzer/nethogs/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+ <longdescription>
+NetHogs is a small 'net top' tool. Instead of breaking the traffic down
+ per protocol or per subnet, like most tools do, it groups bandwidth by
+process. NetHogs does not rely on a special kernel module to be loaded.
+If there's suddenly a lot of network traffic, you can fire up NetHogs and
+immediately see which PID is causing this. This makes it easy to indentify
+programs that have gone wild and are suddenly taking up your bandwidth.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">nethogs</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-analyzer/nethogs/nethogs-0.8.0-r4.ebuild b/net-analyzer/nethogs/nethogs-0.8.0-r4.ebuild
new file mode 100644
index 000000000000..9356d4f1c57e
--- /dev/null
+++ b/net-analyzer/nethogs/nethogs-0.8.0-r4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A small 'net top' tool, grouping bandwidth by process"
+HOMEPAGE="http://nethogs.sf.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ia64 x86"
+
+RDEPEND="
+ net-libs/libpcap
+ sys-libs/ncurses
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+DOCS=( Changelog DESIGN README )
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ tc-export CC CXX PKG_CONFIG
+}