summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorQuentin Retornaz <gentoo@retornaz.com>2022-06-05 19:55:31 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-06-17 19:29:13 +0300
commit5fe467832ed42b523887aa610e8244d468d99c14 (patch)
treed6d19c8c96079b37734e61183cd69f2ee1a9c95b /net-analyzer/nikto/nikto-2.1.6_p20220602.ebuild
parentnet-firewall/nftables: backport upstream revert (diff)
downloadgentoo-5fe467832ed42b523887aa610e8244d468d99c14.tar.gz
gentoo-5fe467832ed42b523887aa610e8244d468d99c14.tar.bz2
gentoo-5fe467832ed42b523887aa610e8244d468d99c14.zip
net-analyzer/nikto: version bump to 2.1.6_p20220602
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Quentin Retornaz <gentoo@retornaz.com> Closes: https://github.com/gentoo/gentoo/pull/25769 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-analyzer/nikto/nikto-2.1.6_p20220602.ebuild')
-rw-r--r--net-analyzer/nikto/nikto-2.1.6_p20220602.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-analyzer/nikto/nikto-2.1.6_p20220602.ebuild b/net-analyzer/nikto/nikto-2.1.6_p20220602.ebuild
new file mode 100644
index 000000000000..c5fef7c17092
--- /dev/null
+++ b/net-analyzer/nikto/nikto-2.1.6_p20220602.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Web server vulnerability scanner"
+HOMEPAGE="https://www.cirt.net/Nikto2"
+COMMIT="dc98b86d3860ea18d82b5a427ab7abcd57e01552"
+MY_P="${PN}-${COMMIT}"
+SRC_URI="https://github.com/sullo/nikto/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+# nikto provides its own libwhisker, do no use net-libs/libwhisker[ssl]
+# https://bugs.gentoo.org/533900
+RDEPEND="
+ dev-lang/perl
+ dev-perl/Net-SSLeay
+ net-analyzer/nmap
+ virtual/perl-JSON-PP
+"
+
+S="${WORKDIR}/${MY_P}/program"
+
+src_prepare() {
+ sed -i -e 's:/etc/nikto.conf:/etc/nikto/nikto.conf:' nikto.pl || die
+ sed -i -e 's:# EXECDIR=/opt/nikto:EXECDIR=/usr/share/nikto:' nikto.conf.default || die
+
+ default
+}
+
+src_install() {
+ insinto /etc/nikto
+ newins nikto.conf.default nikto.conf
+
+ dobin nikto.pl replay.pl
+ dosym nikto.pl /usr/bin/nikto
+
+ insinto /usr/share/nikto
+ doins -r plugins templates databases
+
+ dodoc docs/nikto_manual.html
+ dodoc docs/nikto_schema.sql
+ doman docs/nikto.1
+}