summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2016-11-18 16:16:45 -0800
committerRobin H. Johnson <robbat2@gentoo.org>2016-11-18 16:16:58 -0800
commitf751259651621515c6e710e65d4d7660a0c2169f (patch)
tree604d2414dee9938265069709c23685601e11a47e /net-analyzer/thc-ipv6/thc-ipv6-3.0.ebuild
parentsys-power/apcupsd: Add support for modbus (diff)
downloadgentoo-f751259651621515c6e710e65d4d7660a0c2169f.tar.gz
gentoo-f751259651621515c6e710e65d4d7660a0c2169f.tar.bz2
gentoo-f751259651621515c6e710e65d4d7660a0c2169f.zip
net-analyzer/thc-ipv6: bump.
Package-Manager: portage-2.3.2
Diffstat (limited to 'net-analyzer/thc-ipv6/thc-ipv6-3.0.ebuild')
-rw-r--r--net-analyzer/thc-ipv6/thc-ipv6-3.0.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/net-analyzer/thc-ipv6/thc-ipv6-3.0.ebuild b/net-analyzer/thc-ipv6/thc-ipv6-3.0.ebuild
new file mode 100644
index 000000000000..72b7ea5135c4
--- /dev/null
+++ b/net-analyzer/thc-ipv6/thc-ipv6-3.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+[[ ${PV} == *9999 ]] && SCM="git-r3"
+EGIT_REPO_URI="https://github.com/vanhauser-thc/thc-ipv6.git"
+EGIT_BRANCH=master
+
+inherit eutils toolchain-funcs ${SCM}
+
+DESCRIPTION="complete tool set to attack the inherent protocol weaknesses of IPV6 and ICMP6"
+HOMEPAGE="https://www.thc.org/thc-ipv6/"
+LICENSE="AGPL-3 openssl"
+SLOT="0"
+IUSE="ssl"
+
+if [[ ${PV} != *9999 ]]; then
+ SRC_URI="http://www.thc.org/releases/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DEPEND="net-libs/libpcap
+ net-libs/libnetfilter_queue
+ ssl? ( dev-libs/openssl:* )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ if [[ ${PV} != *9999 ]]; then
+ default_src_unpack
+ else
+ git-r3_src_unpack
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.0-Makefile.patch
+ sed -i \
+ -e '/^CFLAGS=/s,CFLAGS=,CFLAGS?=,' \
+ Makefile
+ if ! use ssl ; then
+ sed -e '/^HAVE_SSL/s:^:#:' \
+ -i Makefile
+ fi
+ eapply_user
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" STRIP="true" install
+ dodoc CHANGES HOWTO-INJECT README
+}