summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrahmajit Das <brahmajit.xyz@gmail.com>2023-09-30 16:28:36 +0000
committerSam James <sam@gentoo.org>2023-10-01 09:38:36 +0100
commitb3e58f3d564d70dc0725455d1eb88104130c5498 (patch)
treeebe88edd9bb5b37f0740ff1e94b236d009d57753 /net-analyzer/tptest
parentx11-libs/fox: add 1.7.84 (diff)
downloadgentoo-b3e58f3d564d70dc0725455d1eb88104130c5498.tar.gz
gentoo-b3e58f3d564d70dc0725455d1eb88104130c5498.tar.bz2
gentoo-b3e58f3d564d70dc0725455d1eb88104130c5498.zip
net-analyzer/tptest: Fix call to undeclared function open
And update EAPI 7 -> 8 Closes: https://bugs.gentoo.org/897832 Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/33138 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/tptest')
-rw-r--r--net-analyzer/tptest/files/tptest-3.1.7-clang16-build-fix.patch11
-rw-r--r--net-analyzer/tptest/tptest-3.1.7-r3.ebuild50
2 files changed, 61 insertions, 0 deletions
diff --git a/net-analyzer/tptest/files/tptest-3.1.7-clang16-build-fix.patch b/net-analyzer/tptest/files/tptest-3.1.7-clang16-build-fix.patch
new file mode 100644
index 000000000000..69b27d97ad05
--- /dev/null
+++ b/net-analyzer/tptest/files/tptest-3.1.7-clang16-build-fix.patch
@@ -0,0 +1,11 @@
+Bug: https://bugs.gentoo.org/897832
+--- a/apps/unix/server/server.c
++++ b/apps/unix/server/server.c
+@@ -50,6 +50,7 @@
+ #include <sys/file.h>
+ #include <sys/stat.h>
+ #include <sys/wait.h>
++#include <fcntl.h>
+
+ // #include <net/if.h>
+ // #include <netinet/in.h>
diff --git a/net-analyzer/tptest/tptest-3.1.7-r3.ebuild b/net-analyzer/tptest/tptest-3.1.7-r3.ebuild
new file mode 100644
index 000000000000..bb6a9fe8ac01
--- /dev/null
+++ b/net-analyzer/tptest/tptest-3.1.7-r3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PV="${PV/./_}"
+
+DESCRIPTION="Internet bandwidth tester"
+HOMEPAGE="http://tptest.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.1.7-getstatsfromlinevuln.patch
+ "${FILESDIR}"/${PN}-3.1.7-clang16-build-fix.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i apps/unix/{client,server}/Makefile \
+ -e "s:^CFLAGS[[:space:]]*=:CFLAGS+=:" \
+ || die
+
+ cp -f os-dep/unix/* . || die
+ cp -f engine/* . || die
+}
+
+src_compile() {
+ emake -C apps/unix/client \
+ CC="$(tc-getCC)" \
+ LDFLAGS="${LDFLAGS}"
+
+ emake -C apps/unix/server \
+ CC="$(tc-getCC)" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin apps/unix/client/tptestclient
+ dosbin apps/unix/server/tptestserver
+
+ insinto /etc
+ doins apps/unix/server/tptest.conf
+}