summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2023-04-29 18:58:30 -0700
committerSam James <sam@gentoo.org>2023-05-10 17:35:32 +0100
commit3c567ba631c14b1605c441fba76cdaf65e05e828 (patch)
treefe45e2de3436959a7394bae47d40fa55fa648e3c /net-analyzer
parentnet-libs/serf: add upstream libressl patch (diff)
downloadgentoo-3c567ba631c14b1605c441fba76cdaf65e05e828.tar.gz
gentoo-3c567ba631c14b1605c441fba76cdaf65e05e828.tar.bz2
gentoo-3c567ba631c14b1605c441fba76cdaf65e05e828.zip
net-analyzer/ettercap: add upstream libressl patch
This patch was accepted upstream and disables APIs not supported by LibreSSL <= 3.7.2. Bug: https://bugs.gentoo.org/903001 Bug: https://bugs.gentoo.org/736990 Upstream-Issue: https://github.com/Ettercap/ettercap/issues/1068 Upstream-PR: https://github.com/Ettercap/ettercap/pull/1069 Upstream-Commit: https://github.com/Ettercap/ettercap/commit/b2fc8e959dc71fdbaba08aecb1f157c914490a07 Signed-off-by: orbea <orbea@riseup.net> Closes: https://github.com/gentoo/gentoo/pull/30813 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/ettercap/ettercap-0.8.3.1-r3.ebuild1
-rw-r--r--net-analyzer/ettercap/files/ettercap-0.8.3.1-libressl.patch36
2 files changed, 37 insertions, 0 deletions
diff --git a/net-analyzer/ettercap/ettercap-0.8.3.1-r3.ebuild b/net-analyzer/ettercap/ettercap-0.8.3.1-r3.ebuild
index 26b54257f1db..75306f098cca 100644
--- a/net-analyzer/ettercap/ettercap-0.8.3.1-r3.ebuild
+++ b/net-analyzer/ettercap/ettercap-0.8.3.1-r3.ebuild
@@ -56,6 +56,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${P}-curl-8.patch
+ "${FILESDIR}"/${P}-libressl.patch #903001, 736990
"${FILESDIR}"/${P}-musl.patch #897820
)
diff --git a/net-analyzer/ettercap/files/ettercap-0.8.3.1-libressl.patch b/net-analyzer/ettercap/files/ettercap-0.8.3.1-libressl.patch
new file mode 100644
index 000000000000..a56e75c88b75
--- /dev/null
+++ b/net-analyzer/ettercap/files/ettercap-0.8.3.1-libressl.patch
@@ -0,0 +1,36 @@
+https://bugs.gentoo.org/903001
+https://bugs.gentoo.org/736990
+https://github.com/Ettercap/ettercap/pull/1069
+https://github.com/Ettercap/ettercap/commit/b2fc8e959dc71fdbaba08aecb1f157c914490a07
+
+From b2f7634c9dbc0ef68640f0571787d92300e9f9f9 Mon Sep 17 00:00:00 2001
+From: Stefan Strogin <stefan@steils.org>
+Date: Sat, 15 Aug 2020 07:18:31 +0300
+Subject: [PATCH] ec_sslwrap: fix compilation with LibreSSL
+
+Disable taking over SNI extension from ClientHello and SSL configuration
+operations until LibreSSL supports the required API.
+
+Fixes: https://github.com/Ettercap/ettercap/issues/1068
+---
+ src/ec_sslwrap.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/ec_sslwrap.c b/src/ec_sslwrap.c
+index b9f26a142..1e4c24fc1 100644
+--- a/src/ec_sslwrap.c
++++ b/src/ec_sslwrap.c
+@@ -71,11 +71,11 @@
+ #define TLS_server_method SSLv23_server_method
+ #endif
+
+-#if (OPENSSL_VERSION_NUMBER >= 0x10100000L)
++#if (OPENSSL_VERSION_NUMBER >= 0x10100000L) && !defined(LIBRESSL_VERSION_NUMBER)
+ #define HAVE_OPENSSL_1_1_0
+ #endif
+
+-#if (OPENSSL_VERSION_NUMBER >= 0x10101000L)
++#if (OPENSSL_VERSION_NUMBER >= 0x10101000L) && !defined(LIBRESSL_VERSION_NUMBER)
+ #define HAVE_OPENSSL_1_1_1
+ #endif
+