summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-01 13:40:50 +0100
committerSam James <sam@gentoo.org>2023-05-01 13:48:48 +0100
commit7574e3d313fe106bbda3f1c735be7009a13443d8 (patch)
tree88983b25e61e1731ba9a55c485ed32f27f9ba314 /net-analyzer
parentnet-analyzer/graphite-web: drop 1.1.8-r3 (diff)
downloadgentoo-7574e3d313fe106bbda3f1c735be7009a13443d8.tar.gz
gentoo-7574e3d313fe106bbda3f1c735be7009a13443d8.tar.bz2
gentoo-7574e3d313fe106bbda3f1c735be7009a13443d8.zip
net-analyzer/ifstatus: drop 1.1.0-r2
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/ifstatus/Manifest1
-rw-r--r--net-analyzer/ifstatus/files/ifstatus-1.1.0-gcc43.patch10
-rw-r--r--net-analyzer/ifstatus/files/ifstatus-1.1.0-gcc6.patch14
-rw-r--r--net-analyzer/ifstatus/files/ifstatus-1.1.0-tinfo.patch22
-rw-r--r--net-analyzer/ifstatus/ifstatus-1.1.0-r2.ebuild42
5 files changed, 0 insertions, 89 deletions
diff --git a/net-analyzer/ifstatus/Manifest b/net-analyzer/ifstatus/Manifest
index 699157aedea9..3d533a2aa938 100644
--- a/net-analyzer/ifstatus/Manifest
+++ b/net-analyzer/ifstatus/Manifest
@@ -1,2 +1 @@
-DIST ifstatus-v1.1.0.tar.gz 25233 BLAKE2B de9d088bf7001799c3a54775c0c63d5dcf4f1f3f4998ce02b82a11bea7a6dabb1263829ff42ba1cd05ebd6b202827196757727c24db022ffa7d06ece38db6616 SHA512 2660310be7186067315414218e3d3d269499e391c7ffa12022ac53a0456ddbe0f7d5562b788fe6b2569b7d0eba7acf5699e0386769a91606a3e14b51239a2766
DIST ifstatus-v2.0.0.tar.gz 24058 BLAKE2B 09a2b0af26cb05dfc24eefdbb6ac52b0ac289a687301f5fa67f0fcaf2622da96e149af3f7c08257e0ef8418f4f08b5ca1b77af71ba7c00dabddcb87cc95ddce7 SHA512 e1720f5dcc26788149cc72ccb72b85fffc72b367f2268e1e4f06a8fe4d80685146d310746c0b1a913e24995f6e93011d7d75ea5b4f9ca479af2d79264b89e27d
diff --git a/net-analyzer/ifstatus/files/ifstatus-1.1.0-gcc43.patch b/net-analyzer/ifstatus/files/ifstatus-1.1.0-gcc43.patch
deleted file mode 100644
index 27111d7576f4..000000000000
--- a/net-analyzer/ifstatus/files/ifstatus-1.1.0-gcc43.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/Main.h
-+++ b/Main.h
-@@ -38,6 +38,7 @@
- #include <unistd.h>
- #include <string.h>
- #include <curses.h>
-+#include <stdlib.h>
-
- #include <sys/time.h>
- #include <sys/types.h>
diff --git a/net-analyzer/ifstatus/files/ifstatus-1.1.0-gcc6.patch b/net-analyzer/ifstatus/files/ifstatus-1.1.0-gcc6.patch
deleted file mode 100644
index 760a09fbf2c6..000000000000
--- a/net-analyzer/ifstatus/files/ifstatus-1.1.0-gcc6.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- a/Interface.h
-+++ b/Interface.h
-@@ -57,7 +57,11 @@
-
- InterfaceData & operator=(InterfaceData & rInterfaceData);
- InterfaceData operator-(InterfaceData & rInterfaceData);
-
-+#if __cplusplus >= 201103L
-+ InterfaceData & operator=(InterfaceData && rInterfaceData) = default;
-+ InterfaceData(const InterfaceData&) = default;
-+#endif
- private:
-
- unsigned long long m_ullReceived[eTotalTypes];
diff --git a/net-analyzer/ifstatus/files/ifstatus-1.1.0-tinfo.patch b/net-analyzer/ifstatus/files/ifstatus-1.1.0-tinfo.patch
deleted file mode 100644
index e2c14e6add71..000000000000
--- a/net-analyzer/ifstatus/files/ifstatus-1.1.0-tinfo.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -1,9 +1,7 @@
- # Makefile for IFStatus
- # Gabriel Montenegro
-
--GCC = g++
--LDFLAGS = -lncurses
--CFLAGS = -O2 -Wall
-+LDLIBS = $(shell $(PKG_CONFIG) --libs ncurses)
-
- BIN = ifstatus
- OBJ = BorderDecorator.o\
-@@ -30,7 +28,7 @@
- all : ifstatus printdone
-
- ifstatus : $(OBJ)
-- $(GCC) $(CFLAGS) $(LDFLAGS) $^ -o $@
-+ $(LINK.cc) $^ $(LDLIBS) -o $@
-
- printdone:
- @if [ -e "./${BIN}" ]; then echo "Compiled.."; else echo "Error compiling!"; fi
diff --git a/net-analyzer/ifstatus/ifstatus-1.1.0-r2.ebuild b/net-analyzer/ifstatus/ifstatus-1.1.0-r2.ebuild
deleted file mode 100644
index 986b1e4ad565..000000000000
--- a/net-analyzer/ifstatus/ifstatus-1.1.0-r2.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-DESCRIPTION="A simple CLI program for displaying network statistics in real time"
-HOMEPAGE="http://ifstatus.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${PN}-v${PV}.tar.gz"
-S="${WORKDIR}/${PN}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 arm ~ppc x86"
-
-RDEPEND=">=sys-libs/ncurses-4.2:0="
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}"/${P}-gcc43.patch
- "${FILESDIR}"/${P}-tinfo.patch
- "${FILESDIR}"/${P}-gcc6.patch
-)
-
-src_prepare() {
- default
- tc-export CXX PKG_CONFIG
-}
-
-src_install() {
- dobin ifstatus
- dodoc AUTHORS README
-}
-
-pkg_postinst() {
- elog "You may want to configure ~/.ifstatus/ifstatus.cfg"
- elog "before running ifstatus. For example, you may add"
- elog "Interfaces = eth0 there. Read the README file for"
- elog "more information."
-}