summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-01 04:09:00 +0000
committerSam James <sam@gentoo.org>2022-12-01 04:09:00 +0000
commit83d8d592d9ead4682680138e973c0211bffe835e (patch)
treeca6c9cb144edf86aad9546ec31bf36ca48055c90 /net-analyzer
parentdev-perl/TermReadKey: fix configure w/ clang 16 (diff)
downloadgentoo-83d8d592d9ead4682680138e973c0211bffe835e.tar.gz
gentoo-83d8d592d9ead4682680138e973c0211bffe835e.tar.bz2
gentoo-83d8d592d9ead4682680138e973c0211bffe835e.zip
net-analyzer/argus: fix configure w/ clang 16
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/argus/argus-3.0.8.3-r2.ebuild (renamed from net-analyzer/argus/argus-3.0.8.3-r1.ebuild)7
-rw-r--r--net-analyzer/argus/files/argus-3.0.8.3-configure-clang16.patch41
2 files changed, 45 insertions, 3 deletions
diff --git a/net-analyzer/argus/argus-3.0.8.3-r1.ebuild b/net-analyzer/argus/argus-3.0.8.3-r2.ebuild
index a4176cf571c4..e316b6bc37ef 100644
--- a/net-analyzer/argus/argus-3.0.8.3-r1.ebuild
+++ b/net-analyzer/argus/argus-3.0.8.3-r2.ebuild
@@ -1,13 +1,14 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools toolchain-funcs
DESCRIPTION="network Audit Record Generation and Utilization System"
HOMEPAGE="https://openargus.org/"
SRC_URI="https://www.qosient.com/argus/dev/${P/_rc/.rc.}.tar.gz"
+S="${WORKDIR}"/${P/_rc/.rc.}
LICENSE="GPL-3"
SLOT="0"
@@ -35,8 +36,8 @@ PATCHES=(
"${FILESDIR}"/${PN}-3.0.7.3-DLT_IPNET.patch
"${FILESDIR}"/${PN}-3.0.8.3-ar.patch
"${FILESDIR}"/${PN}-3.0.8.3-as-needed.patch
+ "${FILESDIR}"/${PN}-3.0.8.3-configure-clang16.patch
)
-S=${WORKDIR}/${P/_rc/.rc.}
src_prepare() {
find . -type f -execdir chmod +w {} \; #561360
diff --git a/net-analyzer/argus/files/argus-3.0.8.3-configure-clang16.patch b/net-analyzer/argus/files/argus-3.0.8.3-configure-clang16.patch
new file mode 100644
index 000000000000..2e9720c04326
--- /dev/null
+++ b/net-analyzer/argus/files/argus-3.0.8.3-configure-clang16.patch
@@ -0,0 +1,41 @@
+https://github.com/openargus/argus/pull/5
+
+From dd987328bd2b99977a1a686a1a6b36d1a3155ff7 Mon Sep 17 00:00:00 2001
+From: Florian Weimer <fweimer@redhat.com>
+Date: Fri, 25 Nov 2022 19:03:24 +0100
+Subject: [PATCH] configure (AC_LBL_UNALIGNED_ACCESS): Avoid implicit function
+ decls
+
+Implicit function declarations were removed from the C language
+in 1999. Include the relevant header files to ensure that the
+check still works with future compilers. C99 also requires
+to declare the return types of all functions.
+--- a/acsite.m4
++++ b/acsite.m4
+@@ -298,8 +298,10 @@ AC_DEFUN([AC_LBL_UNALIGNED_ACCESS],
+ # include <sys/types.h>
+ # include <sys/wait.h>
+ # include <stdio.h>
++# include <stdlib.h>
++# include <unistd.h>
+ unsigned char a[[5]] = { 1, 2, 3, 4, 5 };
+- main() {
++ int main() {
+ unsigned int i;
+ pid_t pid;
+ int status;
+--- a/configure
++++ b/configure
+@@ -5791,8 +5791,10 @@ else
+ # include <sys/types.h>
+ # include <sys/wait.h>
+ # include <stdio.h>
++# include <stdlib.h>
++# include <unistd.h>
+ unsigned char a[5] = { 1, 2, 3, 4, 5 };
+- main() {
++ int main() {
+ unsigned int i;
+ pid_t pid;
+ int status;
+