summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-07 07:12:47 +0000
committerSam James <sam@gentoo.org>2021-12-07 07:12:55 +0000
commit86721c622f6e75874b3dc83b0133f5973b5ba84b (patch)
treef398949ce3df9b9d709f2463971f5cbb0d08722a /net-analyzer
parentsys-fs/encfs: drop 1.9.5 (cmake-utils--, EAPI 6--) (diff)
downloadgentoo-86721c622f6e75874b3dc83b0133f5973b5ba84b.tar.gz
gentoo-86721c622f6e75874b3dc83b0133f5973b5ba84b.tar.bz2
gentoo-86721c622f6e75874b3dc83b0133f5973b5ba84b.zip
net-analyzer/wireshark: fix USE=-tshark build for 3.6.0
Bug: https://bugs.gentoo.org/823720 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/wireshark/files/wireshark-3.6.0-fix-no-tshark.patch32
-rw-r--r--net-analyzer/wireshark/wireshark-3.6.0-r1.ebuild1
2 files changed, 33 insertions, 0 deletions
diff --git a/net-analyzer/wireshark/files/wireshark-3.6.0-fix-no-tshark.patch b/net-analyzer/wireshark/files/wireshark-3.6.0-fix-no-tshark.patch
new file mode 100644
index 000000000000..dd497c51391c
--- /dev/null
+++ b/net-analyzer/wireshark/files/wireshark-3.6.0-fix-no-tshark.patch
@@ -0,0 +1,32 @@
+https://gitlab.com/wireshark/wireshark/-/commit/411df7ca34027d87fe6ecc06a07c816a401c4cb5
+https://gitlab.com/wireshark/wireshark/-/issues/17766
+https://bugs.gentoo.org/823720
+
+From: Gerald Combs <gerald@wireshark.org>
+Date: Mon, 6 Dec 2021 19:01:10 -0800
+Subject: [PATCH] CMake: Remove the update_tools_help target.
+
+Remove the update_tools_help target. Despite the comment, the weekly
+update job doesn't use it, we don't have targets for our other update
+scripts, and it currently causes issues if BUILD_tshark is disabled.
+Fixes #17766.
+--- a/docbook/CMakeLists.txt
++++ b/docbook/CMakeLists.txt
+@@ -33,16 +33,6 @@ set(COMMON_GRAPHICS
+
+ set(GUIDE_INSTALL_DIRS)
+
+-# This is automatically updated each week. You probably don't need to run it
+-# or depend on it.
+-add_custom_target(update_tools_help
+- COMMAND ${CMAKE_COMMAND} -E env PYTHONIOENCODING=UTF-8
+- ${PYTHON_EXECUTABLE} ${CMAKE_SOURCE_DIR}/tools/update-tools-help.py
+- --program-path $<TARGET_FILE_DIR:tshark>
+- WORKING_DIRECTORY ${CMAKE_BINARY_DIR}
+-)
+-set_docbook_target_properties(update_tools_help)
+-
+ set(WSUG_TITLE "Wireshark User's Guide")
+
+ set(WSUG_FILES
+GitLab
diff --git a/net-analyzer/wireshark/wireshark-3.6.0-r1.ebuild b/net-analyzer/wireshark/wireshark-3.6.0-r1.ebuild
index 3b3d7769e8ea..cd262a13d500 100644
--- a/net-analyzer/wireshark/wireshark-3.6.0-r1.ebuild
+++ b/net-analyzer/wireshark/wireshark-3.6.0-r1.ebuild
@@ -97,6 +97,7 @@ RDEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}"/${PN}-2.6.0-redhat.patch
"${FILESDIR}"/${PN}-3.4.2-cmake-lua-version.patch
+ "${FILESDIR}"/${PN}-3.6.0-fix-no-tshark.patch
)
pkg_setup() {