summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-22 04:29:02 +0100
committerSam James <sam@gentoo.org>2022-05-22 04:49:13 +0100
commitfe645421ab7b81fab82f8062563ef9ee3a06fa44 (patch)
tree82d3f4ad0c5eb625a935c26672cb5be33772ecb3 /net-analyzer
parentnet-mail/automx2: Remove obsolete ebuild (diff)
downloadgentoo-fe645421ab7b81fab82f8062563ef9ee3a06fa44.tar.gz
gentoo-fe645421ab7b81fab82f8062563ef9ee3a06fa44.tar.bz2
gentoo-fe645421ab7b81fab82f8062563ef9ee3a06fa44.zip
net-analyzer/pypacker: add 5.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/pypacker/Manifest1
-rw-r--r--net-analyzer/pypacker/metadata.xml2
-rw-r--r--net-analyzer/pypacker/pypacker-5.1.ebuild29
3 files changed, 31 insertions, 1 deletions
diff --git a/net-analyzer/pypacker/Manifest b/net-analyzer/pypacker/Manifest
index eababc35475a..9885b80185e5 100644
--- a/net-analyzer/pypacker/Manifest
+++ b/net-analyzer/pypacker/Manifest
@@ -1 +1,2 @@
DIST pypacker-4.9.tar.gz 602068 BLAKE2B 1ddc16e361ba0aa57b4dab62c38c37aabeffe2cab5cb819e627aeaac5452201117c2f806f2f443cad96d673f93bf0f0a159fa6a7d59564879d038524a2de1eb1 SHA512 804bb32eda76a00121c88d38722a6fb51a9fcff0a5625bd46bda68329e39139624c4fb8e2736208733a6b97ec0df02f173d304fcf3bb39549f3fa119fcf0ae2f
+DIST pypacker-5.1.tar.gz 623638 BLAKE2B 329e8ec2af336118a4ff8d200ced2e356a10dae5217582fb69b77be336e830d3c2356165ea42be6224ef8fd2291637b23fde35733652969affae1f81eb2411dc SHA512 427d2afc45735e920867098c77be8256e28840031a7a01dfae5c9817ff78d2ddb699bf94721eda3b1f4b568bb70bd3bd25ccb8cb77076b84e2aa71898ba0bf57
diff --git a/net-analyzer/pypacker/metadata.xml b/net-analyzer/pypacker/metadata.xml
index 953978987176..61659fe10b68 100644
--- a/net-analyzer/pypacker/metadata.xml
+++ b/net-analyzer/pypacker/metadata.xml
@@ -6,7 +6,7 @@
<name>Gentoo network monitoring and analysis project</name>
</maintainer>
<upstream>
- <remote-id type="github">mike01/pypacker</remote-id>
+ <remote-id type="gitlab">mike01/pypacker</remote-id>
<maintainer>
<email>michael.stahn.42@googlemail.com</email>
<name>Michael Stahn</name>
diff --git a/net-analyzer/pypacker/pypacker-5.1.ebuild b/net-analyzer/pypacker/pypacker-5.1.ebuild
new file mode 100644
index 000000000000..af71a3b3868d
--- /dev/null
+++ b/net-analyzer/pypacker/pypacker-5.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Fast and simple packet creation and parsing library for Python"
+HOMEPAGE="https://gitlab.com/mike01/pypacker"
+SRC_URI="https://gitlab.com/mike01/pypacker/-/archive/v${PV}/pypacker-v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DOCS=( AUTHORS CHANGES HACKING README.md )
+
+python_test() {
+ "${EPYTHON}" tests/test_pypacker.py || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ use examples && dodoc -r examples
+}