summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2021-05-17 11:47:18 +0300
committerSergey Popov <pinkbyte@gentoo.org>2021-05-17 11:57:47 +0300
commit5f5601126811de0285e0a83c31bb2d203af1eb37 (patch)
treee09543ca18235907a13cd2149983fd40143502ca /net-dialup/accel-ppp/accel-ppp-9999.ebuild
parentsys-apps/lshw: sparc stable wrt bug #790497 (diff)
downloadgentoo-5f5601126811de0285e0a83c31bb2d203af1eb37.tar.gz
gentoo-5f5601126811de0285e0a83c31bb2d203af1eb37.tar.bz2
gentoo-5f5601126811de0285e0a83c31bb2d203af1eb37.zip
net-dialup/accel-ppp: version bump
- add new snapshot - add support for dev-libs/libtomcrypt - sync live ebuild Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Sergey Popov <pinkbyte@gentoo.org>
Diffstat (limited to 'net-dialup/accel-ppp/accel-ppp-9999.ebuild')
-rw-r--r--net-dialup/accel-ppp/accel-ppp-9999.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/net-dialup/accel-ppp/accel-ppp-9999.ebuild b/net-dialup/accel-ppp/accel-ppp-9999.ebuild
index fd43b44ecd20..f517be83f27b 100644
--- a/net-dialup/accel-ppp/accel-ppp-9999.ebuild
+++ b/net-dialup/accel-ppp/accel-ppp-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -15,13 +15,14 @@ SRC_URI=""
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="debug doc ipoe lua postgres radius shaper snmp valgrind"
+IUSE="debug doc ipoe libtomcrypt lua postgres radius shaper snmp valgrind"
-RDEPEND="lua? ( ${LUA_DEPS} )
+RDEPEND="!libtomcrypt? ( dev-libs/openssl:0= )
+ libtomcrypt? ( dev-libs/libtomcrypt:0= )
+ lua? ( ${LUA_DEPS} )
postgres? ( dev-db/postgresql:* )
snmp? ( net-analyzer/net-snmp )
- dev-libs/libpcre
- dev-libs/openssl:0="
+ dev-libs/libpcre"
DEPEND="${RDEPEND}
valgrind? ( dev-util/valgrind )"
PDEPEND="net-dialup/ppp-scripts"
@@ -60,13 +61,12 @@ src_prepare() {
src_configure() {
local libdir="$(get_libdir)"
- # There must be also dev-libs/tomcrypt (TOMCRYPT) as crypto alternative to OpenSSL
local mycmakeargs=(
-DLIB_SUFFIX="${libdir#lib}"
-DBUILD_IPOE_DRIVER="$(usex ipoe)"
-DBUILD_PPTP_DRIVER=no
-DBUILD_VLAN_MON_DRIVER="$(usex ipoe)"
- -DCRYPTO=OPENSSL
+ -DCRYPTO="$(usex libtomcrypt TOMCRYPT OPENSSL)"
-DLOG_PGSQL="$(usex postgres)"
-DLUA="$(usex lua TRUE FALSE)"
-DMEMDEBUG="$(usex debug)"