summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-16 20:16:39 +0000
committerSam James <sam@gentoo.org>2021-03-16 20:16:39 +0000
commit18904ab53465199a1eac1a65af941d4ed7eef394 (patch)
tree4bec9370e386686ac788fbde0cd06e8ca48fe6d1 /net-dialup/xl2tpd/xl2tpd-1.3.16.ebuild
parentnet-dialup/xl2tpd: fix UnusedLocalUse (diff)
downloadgentoo-18904ab53465199a1eac1a65af941d4ed7eef394.tar.gz
gentoo-18904ab53465199a1eac1a65af941d4ed7eef394.tar.bz2
gentoo-18904ab53465199a1eac1a65af941d4ed7eef394.zip
net-dialup/xl2tpd: add 1.3.16
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-dialup/xl2tpd/xl2tpd-1.3.16.ebuild')
-rw-r--r--net-dialup/xl2tpd/xl2tpd-1.3.16.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-dialup/xl2tpd/xl2tpd-1.3.16.ebuild b/net-dialup/xl2tpd/xl2tpd-1.3.16.ebuild
new file mode 100644
index 000000000000..e20c5ce6dfa5
--- /dev/null
+++ b/net-dialup/xl2tpd/xl2tpd-1.3.16.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd toolchain-funcs tmpfiles
+
+DESCRIPTION="A modern version of the Layer 2 Tunneling Protocol (L2TP) daemon"
+HOMEPAGE="https://github.com/xelerance/xl2tpd"
+SRC_URI="https://github.com/xelerance/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86"
+IUSE="+kernel"
+
+DEPEND="
+ net-libs/libpcap
+ >=sys-kernel/linux-headers-2.6"
+
+RDEPEND="
+ ${DEPEND}
+ net-dialup/ppp"
+
+DOCS=(CREDITS README.md BUGS CHANGES TODO doc/README.patents)
+
+src_compile() {
+ tc-export CC
+ local OSFLAGS="-DLINUX"
+ use kernel && OSFLAGS+=" -DUSE_KERNEL"
+ emake OSFLAGS="$OSFLAGS"
+}
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install
+
+ newinitd "${FILESDIR}"/xl2tpd-init-r1 xl2tpd
+
+ systemd_dounit "${FILESDIR}"/xl2tpd.service
+ dotmpfiles "${FILESDIR}"/xl2tpd.conf
+
+ einstalldocs
+
+ insinto /etc/xl2tpd
+ newins doc/l2tpd.conf.sample xl2tpd.conf
+ insopts -m 0600
+ newins doc/l2tp-secrets.sample l2tp-secrets
+}