summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-07-19 17:05:59 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-07-19 17:05:59 +0200
commit121d50b721b90369c1a05f3db38844db0402c337 (patch)
tree0a3938979cf78c2d467ca4ca118830bad8492f1b /net-dns/coredns/coredns-009.ebuild
parentwww-servers/caddy: Version bump to 0.10.4 (diff)
downloadgentoo-121d50b721b90369c1a05f3db38844db0402c337.tar.gz
gentoo-121d50b721b90369c1a05f3db38844db0402c337.tar.bz2
gentoo-121d50b721b90369c1a05f3db38844db0402c337.zip
net-dns/coredns: Version bump to 009
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'net-dns/coredns/coredns-009.ebuild')
-rw-r--r--net-dns/coredns/coredns-009.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-dns/coredns/coredns-009.ebuild b/net-dns/coredns/coredns-009.ebuild
new file mode 100644
index 000000000000..a86b55246df0
--- /dev/null
+++ b/net-dns/coredns/coredns-009.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_VENDOR=( "github.com/mholt/caddy 6aba4a311ac1f12c762d6b54a77aedec7d42f615" )
+
+EGO_PN="github.com/${PN}/${PN}"
+
+inherit golang-build golang-vcs-snapshot
+
+EGIT_COMMIT="v${PV}"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="A DNS server that chains middleware"
+HOMEPAGE="https://github.com/coredns/coredns"
+
+SRC_URI="${ARCHIVE_URI}
+ ${EGO_VENDOR_URI}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RESTRICT="test"
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ GOPATH="${S}" go build || die
+ popd || die
+}
+
+src_install() {
+ pushd src/${EGO_PN}
+ dobin ${PN}
+ dodoc README.md
+ popd || die
+}