summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-10 23:02:54 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-11 00:22:38 +0100
commit064af661d0c9a31cecdf348632bc5603333a9149 (patch)
tree2202373a7cafcb8a761d32747d4f62263aed64d5 /net-dns
parentdev-python/passlib: keyworded 1.7.1-r2 for hppa, bug #700918 (diff)
downloadgentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.gz
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.bz2
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.zip
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.19.ebuild1
-rw-r--r--net-dns/dnsdist/dnsdist-1.3.3-r1.ebuild1
-rw-r--r--net-dns/dnsdist/dnsdist-9999.ebuild1
-rw-r--r--net-dns/opendnssec/opendnssec-1.3.18-r1.ebuild3
-rw-r--r--net-dns/opendnssec/opendnssec-1.4.12-r1.ebuild3
-rw-r--r--net-dns/opendnssec/opendnssec-1.4.8.2.ebuild3
-rw-r--r--net-dns/opendnssec/opendnssec-2.0.1-r1.ebuild3
-rw-r--r--net-dns/opendnssec/opendnssec-2.0.3-r1.ebuild1
-rw-r--r--net-dns/pdns/pdns-4.1.13.ebuild1
-rw-r--r--net-dns/pdns/pdns-4.2.0.ebuild1
-rw-r--r--net-dns/pdns/pdns-4.2.1.ebuild1
-rw-r--r--net-dns/pdnsd/pdnsd-1.2.9a-r1.ebuild3
-rw-r--r--net-dns/pdnsd/pdnsd-1.2.9a-r2.ebuild1
-rw-r--r--net-dns/rbldnsd/rbldnsd-0.998b.ebuild1
-rw-r--r--net-dns/resolv_wrapper/resolv_wrapper-1.1.4.ebuild3
-rw-r--r--net-dns/resolv_wrapper/resolv_wrapper-1.1.5.ebuild3
-rw-r--r--net-dns/unbound/unbound-1.9.4.ebuild1
-rw-r--r--net-dns/validns/validns-0.8.ebuild3
18 files changed, 26 insertions, 8 deletions
diff --git a/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.19.ebuild b/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.19.ebuild
index 2f732970bcdd..fe53b5431fa2 100644
--- a/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.19.ebuild
+++ b/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.19.ebuild
@@ -21,6 +21,7 @@ HOMEPAGE="https://github.com/jedisct1/dnscrypt-proxy"
LICENSE="ISC"
SLOT="0"
IUSE="pie test"
+RESTRICT+=" !test? ( test )"
FILECAPS=( cap_net_bind_service+ep usr/bin/dnscrypt-proxy )
PATCHES=( "${FILESDIR}"/config-full-paths-r10.patch )
diff --git a/net-dns/dnsdist/dnsdist-1.3.3-r1.ebuild b/net-dns/dnsdist/dnsdist-1.3.3-r1.ebuild
index ed3b96e1ed6a..493fd0f5e4c1 100644
--- a/net-dns/dnsdist/dnsdist-1.3.3-r1.ebuild
+++ b/net-dns/dnsdist/dnsdist-1.3.3-r1.ebuild
@@ -25,6 +25,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
IUSE="dnscrypt gnutls fstrm luajit regex remote-logging snmp +ssl systemd test"
+RESTRICT="!test? ( test )"
REQUIRED_USE="dnscrypt? ( ssl )
gnutls? ( ssl )"
diff --git a/net-dns/dnsdist/dnsdist-9999.ebuild b/net-dns/dnsdist/dnsdist-9999.ebuild
index ed3b96e1ed6a..493fd0f5e4c1 100644
--- a/net-dns/dnsdist/dnsdist-9999.ebuild
+++ b/net-dns/dnsdist/dnsdist-9999.ebuild
@@ -25,6 +25,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
IUSE="dnscrypt gnutls fstrm luajit regex remote-logging snmp +ssl systemd test"
+RESTRICT="!test? ( test )"
REQUIRED_USE="dnscrypt? ( ssl )
gnutls? ( ssl )"
diff --git a/net-dns/opendnssec/opendnssec-1.3.18-r1.ebuild b/net-dns/opendnssec/opendnssec-1.3.18-r1.ebuild
index d4bfd0296b7c..c29c6bf1ac7b 100644
--- a/net-dns/opendnssec/opendnssec-1.3.18-r1.ebuild
+++ b/net-dns/opendnssec/opendnssec-1.3.18-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -15,6 +15,7 @@ LICENSE="BSD GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="-auditor +curl debug doc eppclient mysql +signer +sqlite test ${PKCS11_IUSE}"
+RESTRICT="!test? ( test )"
RDEPEND="
dev-lang/perl
diff --git a/net-dns/opendnssec/opendnssec-1.4.12-r1.ebuild b/net-dns/opendnssec/opendnssec-1.4.12-r1.ebuild
index 68d85cf8be58..61d2ca9f1014 100644
--- a/net-dns/opendnssec/opendnssec-1.4.12-r1.ebuild
+++ b/net-dns/opendnssec/opendnssec-1.4.12-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -15,6 +15,7 @@ LICENSE="BSD GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug doc +mysql +signer sqlite test ${PKCS11_IUSE}"
+RESTRICT="!test? ( test )"
RDEPEND="
dev-lang/perl
diff --git a/net-dns/opendnssec/opendnssec-1.4.8.2.ebuild b/net-dns/opendnssec/opendnssec-1.4.8.2.ebuild
index c83f258bb104..271869383a54 100644
--- a/net-dns/opendnssec/opendnssec-1.4.8.2.ebuild
+++ b/net-dns/opendnssec/opendnssec-1.4.8.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -15,6 +15,7 @@ LICENSE="BSD GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug doc +mysql +signer sqlite test ${PKCS11_IUSE}"
+RESTRICT="!test? ( test )"
RDEPEND="
dev-lang/perl
diff --git a/net-dns/opendnssec/opendnssec-2.0.1-r1.ebuild b/net-dns/opendnssec/opendnssec-2.0.1-r1.ebuild
index f4ecf0b3f3eb..4802edd1581e 100644
--- a/net-dns/opendnssec/opendnssec-2.0.1-r1.ebuild
+++ b/net-dns/opendnssec/opendnssec-2.0.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -15,6 +15,7 @@ LICENSE="BSD GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug doc +mysql readline +signer sqlite test ${PKCS11_IUSE}"
+RESTRICT="!test? ( test )"
RDEPEND="
dev-lang/perl
diff --git a/net-dns/opendnssec/opendnssec-2.0.3-r1.ebuild b/net-dns/opendnssec/opendnssec-2.0.3-r1.ebuild
index d8769127684e..71ed1ff5e73b 100644
--- a/net-dns/opendnssec/opendnssec-2.0.3-r1.ebuild
+++ b/net-dns/opendnssec/opendnssec-2.0.3-r1.ebuild
@@ -15,6 +15,7 @@ LICENSE="BSD GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug doc +mysql readline +signer sqlite test ${PKCS11_IUSE}"
+RESTRICT="!test? ( test )"
RDEPEND="
dev-lang/perl
diff --git a/net-dns/pdns/pdns-4.1.13.ebuild b/net-dns/pdns/pdns-4.1.13.ebuild
index ae6ae070db07..41fbabb111d2 100644
--- a/net-dns/pdns/pdns-4.1.13.ebuild
+++ b/net-dns/pdns/pdns-4.1.13.ebuild
@@ -19,6 +19,7 @@ KEYWORDS="amd64 x86"
# xdb: (almost) dead, surely not supported
IUSE="botan debug doc geoip ldap libressl lua luajit mydns mysql opendbx postgres protobuf remote sodium sqlite systemd tools tinydns test"
+RESTRICT="!test? ( test )"
REQUIRED_USE="mydns? ( mysql )"
diff --git a/net-dns/pdns/pdns-4.2.0.ebuild b/net-dns/pdns/pdns-4.2.0.ebuild
index e1229b5437f0..5c7378bfdf75 100644
--- a/net-dns/pdns/pdns-4.2.0.ebuild
+++ b/net-dns/pdns/pdns-4.2.0.ebuild
@@ -19,6 +19,7 @@ KEYWORDS="~amd64 ~x86"
# xdb: (almost) dead, surely not supported
IUSE="debug doc geoip ldap libressl lua luajit lua-records mydns mysql opendbx postgres protobuf remote sodium sqlite systemd tools tinydns test"
+RESTRICT="!test? ( test )"
REQUIRED_USE="lua-records? ( lua ) mydns? ( mysql )"
diff --git a/net-dns/pdns/pdns-4.2.1.ebuild b/net-dns/pdns/pdns-4.2.1.ebuild
index e1229b5437f0..5c7378bfdf75 100644
--- a/net-dns/pdns/pdns-4.2.1.ebuild
+++ b/net-dns/pdns/pdns-4.2.1.ebuild
@@ -19,6 +19,7 @@ KEYWORDS="~amd64 ~x86"
# xdb: (almost) dead, surely not supported
IUSE="debug doc geoip ldap libressl lua luajit lua-records mydns mysql opendbx postgres protobuf remote sodium sqlite systemd tools tinydns test"
+RESTRICT="!test? ( test )"
REQUIRED_USE="lua-records? ( lua ) mydns? ( mysql )"
diff --git a/net-dns/pdnsd/pdnsd-1.2.9a-r1.ebuild b/net-dns/pdnsd/pdnsd-1.2.9a-r1.ebuild
index 67ce6e471960..2fcb1252a535 100644
--- a/net-dns/pdnsd/pdnsd-1.2.9a-r1.ebuild
+++ b/net-dns/pdnsd/pdnsd-1.2.9a-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -13,6 +13,7 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="alpha amd64 arm ia64 ppc ~s390 sparc x86"
IUSE="debug ipv6 isdn +urandom test"
+RESTRICT="!test? ( test )"
RDEPEND=""
DEPEND="test? ( net-dns/bind-tools )"
diff --git a/net-dns/pdnsd/pdnsd-1.2.9a-r2.ebuild b/net-dns/pdnsd/pdnsd-1.2.9a-r2.ebuild
index 941fd2c1f91c..beab65cedd77 100644
--- a/net-dns/pdnsd/pdnsd-1.2.9a-r2.ebuild
+++ b/net-dns/pdnsd/pdnsd-1.2.9a-r2.ebuild
@@ -13,6 +13,7 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~s390 ~sparc ~x86"
IUSE="debug ipv6 isdn +urandom test"
+RESTRICT="!test? ( test )"
RDEPEND="
acct-group/pdnsd
diff --git a/net-dns/rbldnsd/rbldnsd-0.998b.ebuild b/net-dns/rbldnsd/rbldnsd-0.998b.ebuild
index f07bb9465962..19ee0603f04b 100644
--- a/net-dns/rbldnsd/rbldnsd-0.998b.ebuild
+++ b/net-dns/rbldnsd/rbldnsd-0.998b.ebuild
@@ -14,6 +14,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 hppa sparc x86"
IUSE="ipv6 test zlib"
+RESTRICT="!test? ( test )"
RDEPEND="zlib? ( sys-libs/zlib )"
DEPEND="${RDEPEND}"
diff --git a/net-dns/resolv_wrapper/resolv_wrapper-1.1.4.ebuild b/net-dns/resolv_wrapper/resolv_wrapper-1.1.4.ebuild
index 08489fe3e613..46ba959b819d 100644
--- a/net-dns/resolv_wrapper/resolv_wrapper-1.1.4.ebuild
+++ b/net-dns/resolv_wrapper/resolv_wrapper-1.1.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -12,6 +12,7 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~x86"
IUSE="test"
+RESTRICT="!test? ( test )"
DEPEND=""
RDEPEND="${DEPEND}"
diff --git a/net-dns/resolv_wrapper/resolv_wrapper-1.1.5.ebuild b/net-dns/resolv_wrapper/resolv_wrapper-1.1.5.ebuild
index c890434ea595..e717fbe3166a 100644
--- a/net-dns/resolv_wrapper/resolv_wrapper-1.1.5.ebuild
+++ b/net-dns/resolv_wrapper/resolv_wrapper-1.1.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -12,6 +12,7 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 sparc x86"
IUSE="test"
+RESTRICT="!test? ( test )"
DEPEND=""
RDEPEND="${DEPEND}"
diff --git a/net-dns/unbound/unbound-1.9.4.ebuild b/net-dns/unbound/unbound-1.9.4.ebuild
index 9b6df938ec24..cd653fdb32bd 100644
--- a/net-dns/unbound/unbound-1.9.4.ebuild
+++ b/net-dns/unbound/unbound-1.9.4.ebuild
@@ -15,6 +15,7 @@ LICENSE="BSD GPL-2"
SLOT="0/8" # ABI version of libunbound.so
KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~mips ppc ppc64 x86"
IUSE="debug dnscrypt dnstap +ecdsa ecs gost libressl python redis selinux static-libs systemd test threads"
+RESTRICT="!test? ( test )"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
# Note: expat is needed by executable only but the Makefile is custom
diff --git a/net-dns/validns/validns-0.8.ebuild b/net-dns/validns/validns-0.8.ebuild
index b50c9ab0f8d9..88412c36c750 100644
--- a/net-dns/validns/validns-0.8.ebuild
+++ b/net-dns/validns/validns-0.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=4
@@ -11,6 +11,7 @@ LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND="dev-libs/judy"
DEPEND="