summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-07-07 13:00:34 +0100
committerSam James <sam@gentoo.org>2024-07-07 13:00:34 +0100
commitbad905cfd70f133167697c5210ad593676016d71 (patch)
tree4765f5c986fb0216af9d91497f01547a5363ddfe /net-dns
parentmedia-sound/rosegarden: Stabilize 24.06 amd64, #935713 (diff)
downloadgentoo-bad905cfd70f133167697c5210ad593676016d71.tar.gz
gentoo-bad905cfd70f133167697c5210ad593676016d71.tar.bz2
gentoo-bad905cfd70f133167697c5210ad593676016d71.zip
net-dns/c-ares: add 1.32.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/c-ares/Manifest2
-rw-r--r--net-dns/c-ares/c-ares-1.32.0.ebuild93
2 files changed, 95 insertions, 0 deletions
diff --git a/net-dns/c-ares/Manifest b/net-dns/c-ares/Manifest
index 081bfb41fc66..45a521f2d68d 100644
--- a/net-dns/c-ares/Manifest
+++ b/net-dns/c-ares/Manifest
@@ -4,3 +4,5 @@ DIST c-ares-1.29.0.tar.gz 1329299 BLAKE2B 7dd6a0dc85d3383087726cd48e75b481f4ef75
DIST c-ares-1.29.0.tar.gz.asc 488 BLAKE2B 3d955b0a130dce562436d9629f1403e30ee5ebd2e981a9c2220b51d129222c3760d6bd8a681cab6115e3f2ef0bcf8e8d600792fc498bc0c05638ce7fcac0d509 SHA512 a379f3c5338073810b7bf932fecf0ce1f0b382cfbc75521f4b135cb78d0a9fd418b06f7affd747fa00d11479186db248fe8ef8120858de2b8f562b56cc41ecb2
DIST c-ares-1.31.0.tar.gz 1012373 BLAKE2B d302862148998fbfb737e5f78826a3152b299fbbf04db4d80580daeaade77e4ea1a9513f4d194746733c33a35474f39dce43dd0562b3faa8673b366a2190c87c SHA512 571d2555b4aaf3bf9cd7b5c89be8448ca26fe0ea1f3d664b07a01b42d28af4f5412b30485ef01d4bacc4e08de487dc6eeda98acf212a6a08edec6805f17210cc
DIST c-ares-1.31.0.tar.gz.asc 228 BLAKE2B 41d35804e4f5d0e11c2c6c192453a0d48f779be999a3f9c1bd8066c547e0ed9959083d953b7735ca15699444913bcdd7d43c3871e11a381e9c8ee508086fc3d8 SHA512 ea2decdec5913f25e690e6c7437fad1682b2df807397e4b764ebb2a8b010804f77b91a889e8aa00471cd1bba3b96c5f90d815ffa677598e9b516909e29b7f960
+DIST c-ares-1.32.0.tar.gz 1021855 BLAKE2B b60c924581ba7db1d87350929d22b5e15684484579e0a7d46068438ca8a953bfb7945cb38cad42f008631bb7ea51e10acb074053d485cd91a52eef742f09fdc1 SHA512 15b9dc967f66a355095f68ef84238776f6ed826fc9077702ffbb6b136be1befadcb9da1f07956079efe593434c1e912993f6e93e948291668b806be50f03136c
+DIST c-ares-1.32.0.tar.gz.asc 228 BLAKE2B d9cf726e42d79ccdaeca2aafc028c1d03aa56acd1cf03b118070968a31655046a3d609e8ea529f03465341d6decaa7f8eace4310487e7028e3a1ad355d25fa4c SHA512 7554b37e470a57ad0175050c1966e1b72bf67791aa860b113a66688ac28e525b93a633a472dd43c8a16bddb366e918b202760efab5ab311c4b6ee63e72869552
diff --git a/net-dns/c-ares/c-ares-1.32.0.ebuild b/net-dns/c-ares/c-ares-1.32.0.ebuild
new file mode 100644
index 000000000000..d6ad901bd330
--- /dev/null
+++ b/net-dns/c-ares/c-ares-1.32.0.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Both Daniel and Brad are listed as possible signers on the homepage
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/bradhouse.asc
+inherit edo multilib-minimal verify-sig
+
+DESCRIPTION="C library that resolves names asynchronously"
+HOMEPAGE="https://c-ares.org/"
+SRC_URI="
+ https://github.com/c-ares/c-ares/releases/download/v${PV}/${P}.tar.gz
+ verify-sig? ( https://github.com/c-ares/c-ares/releases/download/v${PV}/${P}.tar.gz.asc )
+"
+
+# ISC for lib/{bitncmp.c,inet_ntop.c,inet_net_pton.c} (bug #912405)
+LICENSE="MIT ISC"
+# Subslot = SONAME of libcares.so.2
+SLOT="0/2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="static-libs test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? ( dev-cpp/gtest )
+ verify-sig? ( sec-keys/openpgp-keys-bradhouse )
+"
+
+DOCS=( AUTHORS README.md RELEASE-NOTES.md )
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/ares_build.h
+)
+
+A__QA_CONFIG_IMPL_DECL_SKIP=(
+ # Checking for obsolete headers
+ malloc
+ calloc
+ free
+
+ # Non-existent on Linux
+ closesocket
+ CloseSocket
+ ioctlsocket
+ bitncmp
+ ConvertInterfaceIndexToLuid
+ ConvertInterfaceLuidToNameA
+)
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --enable-symbol-hiding
+ $(use_enable static-libs static)
+ $(use_enable test tests)
+ )
+
+ # Needed for running unit tests only
+ # Violates sandbox and tests pass fine without
+ export ax_cv_uts_namespace=no
+ export ax_cv_user_namespace=no
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_test() {
+ cd "${BUILD_DIR}"/test || die
+
+ # We're skipping the "real" network tests with the filter
+ # see https://github.com/c-ares/c-ares/tree/main/test
+ local network_tests=(
+ # Most live tests have Live in the name
+ *Live*
+ # These don't but are still in ares-test-live.cc => live
+ *GetTCPSock*
+ *TimeoutValue*
+ *GetSock*
+ *GetSock_virtualized*
+ *VerifySocketFunctionCallback*
+ # Seems flaky, even run manually
+ # https://github.com/c-ares/c-ares/commit/9e542a8839f81c990bb0dff14beeaf9aa6bcc18d
+ *MockUDPMaxQueriesTest.GetHostByNameParallelLookups*
+ )
+
+ # The format for disabling test1, test2, and test3 looks like:
+ # -test1:test2:test3
+ edo ./arestest --gtest_filter=-$(echo $(IFS=:; echo "${network_tests[*]}"))
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ find "${ED}" -name "*.la" -delete || die
+}