summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2022-07-21 23:39:21 +0100
committerJames Le Cuirot <chewi@gentoo.org>2022-07-21 23:39:21 +0100
commit28f7686eec572ee9d5e6c956b68c4582197f763d (patch)
treebbbca3877e94520b85ea5a4b79bca64607e984d7 /net-firewall/firehol/firehol-3.1.7-r2.ebuild
parentgames-util/game-device-udev-rules: Call udev_reload in pkg_postrm (diff)
downloadgentoo-28f7686eec572ee9d5e6c956b68c4582197f763d.tar.gz
gentoo-28f7686eec572ee9d5e6c956b68c4582197f763d.tar.bz2
gentoo-28f7686eec572ee9d5e6c956b68c4582197f763d.zip
net-firewall/firehol: Install systemd service units, EAPI 8
Closes: https://bugs.gentoo.org/856964 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'net-firewall/firehol/firehol-3.1.7-r2.ebuild')
-rw-r--r--net-firewall/firehol/firehol-3.1.7-r2.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/net-firewall/firehol/firehol-3.1.7-r2.ebuild b/net-firewall/firehol/firehol-3.1.7-r2.ebuild
new file mode 100644
index 000000000000..79ef83977169
--- /dev/null
+++ b/net-firewall/firehol/firehol-3.1.7-r2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info systemd
+
+DESCRIPTION="iptables firewall generator"
+HOMEPAGE="https://firehol.org/ https://github.com/firehol/firehol"
+SRC_URI="https://github.com/firehol/firehol/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="doc ipv6 ipset"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+
+RDEPEND="net-firewall/iptables
+ sys-apps/iproute2[-minimal,ipv6(+)?]
+ sys-apps/kmod[tools]
+ net-misc/iputils[ipv6(+)?]
+ net-misc/iprange
+ net-analyzer/traceroute
+ app-arch/gzip
+ ipset? (
+ net-firewall/ipset
+ )"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ local CONFIG_CHECK=" \
+ ~IP_NF_FILTER \
+ ~IP_NF_IPTABLES \
+ ~IP_NF_MANGLE \
+ ~IP_NF_TARGET_MASQUERADE
+ ~IP_NF_TARGET_REDIRECT \
+ ~IP_NF_TARGET_REJECT \
+ ~NETFILTER_XT_CONNMARK \
+ ~NETFILTER_XT_MATCH_HELPER \
+ ~NETFILTER_XT_MATCH_LIMIT \
+ ~NETFILTER_XT_MATCH_OWNER \
+ ~NETFILTER_XT_MATCH_STATE \
+ ~NF_CONNTRACK \
+ ~NF_CONNTRACK_IPV4 \
+ ~NF_CONNTRACK_MARK \
+ ~NF_NAT \
+ ~NF_NAT_FTP \
+ ~NF_NAT_IRC \
+ "
+ linux-info_pkg_setup
+}
+
+src_configure() {
+ econf \
+ --disable-vnetbuild \
+ $(use_enable ipset update-ipsets) \
+ $(use_enable doc) \
+ $(use_enable ipv6)
+}
+
+src_install() {
+ default
+
+ newconfd "${FILESDIR}"/firehol.confd firehol
+ newinitd "${FILESDIR}"/firehol.initd firehol
+ newconfd "${FILESDIR}"/fireqos.confd fireqos
+ newinitd "${FILESDIR}"/fireqos.initd fireqos
+
+ systemd_dounit contrib/fire{hol,qos}.service
+}