summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-04-28 18:19:50 -0500
committerAustin English <wizardedit@gentoo.org>2016-04-28 18:36:35 -0500
commit574a37fafc49e0165c952af204821f8d25967f88 (patch)
tree4662a6097e05a76a0fde494b853008e85bb675c7 /net-firewall/ipkungfu/ipkungfu-0.6.1-r1.ebuild
parentnet-dns/mydns: remove mydns-1.2.8.31 (diff)
downloadgentoo-574a37fafc49e0165c952af204821f8d25967f88.tar.gz
gentoo-574a37fafc49e0165c952af204821f8d25967f88.tar.bz2
gentoo-574a37fafc49e0165c952af204821f8d25967f88.zip
net-firewall/ipkungfu: use #!/sbin/openrc-run instead of #!/sbin/runscript
Gentoo-Bug: https://bugs.gentoo.org/573846 Package-Manager: portage-2.2.26
Diffstat (limited to 'net-firewall/ipkungfu/ipkungfu-0.6.1-r1.ebuild')
-rw-r--r--net-firewall/ipkungfu/ipkungfu-0.6.1-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-firewall/ipkungfu/ipkungfu-0.6.1-r1.ebuild b/net-firewall/ipkungfu/ipkungfu-0.6.1-r1.ebuild
new file mode 100644
index 000000000000..19014844a68e
--- /dev/null
+++ b/net-firewall/ipkungfu/ipkungfu-0.6.1-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="A nice iptables firewall script"
+HOMEPAGE="http://www.linuxkungfu.org/"
+SRC_URI="http://www.linuxkungfu.org/ipkungfu/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="net-firewall/iptables"
+RDEPEND="${DEPEND}
+ virtual/logger"
+
+src_prepare() {
+ eapply "${FILESDIR}/ipkungfu_noiseless.patch"
+ eapply_user
+}
+
+src_install() {
+ default
+
+ # Install configuration files
+ emake DESTDIR="${D}" install-config
+
+ # Install Gentoo init script
+ newinitd "${FILESDIR}"/ipkungfu.init ipkungfu
+}
+
+pkg_postinst() {
+ # Remove the cache dir so ipkungfu won't fail when running for
+ # the first time, in case 0.6.0 was installed before.
+ rm -rf /etc/ipkungfu/cache
+
+ einfo "Be sure, before running ipkungfu, to edit the config files in:"
+ einfo "/etc/ipkungfu/"
+ einfo
+ einfo "Also, be sure to run ipkungfu prior to rebooting,"
+ einfo "especially if you you're updating from <0.6.0 to >=0.6.0."
+ einfo "There are some significant configuration changes on this"
+ einfo "release covered by the ipkungfu script."
+}