summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-10-09 17:46:50 +0200
committerPacho Ramos <pacho@gentoo.org>2016-10-09 18:18:46 +0200
commit2a0014ed41fbf6dbb2a60f88b1227859177215fc (patch)
treecbabb19b9604574e1e9e27ce33a48084bf9d749f /net-ftp
parentnet-ftp/frox: Drop old (diff)
downloadgentoo-2a0014ed41fbf6dbb2a60f88b1227859177215fc.tar.gz
gentoo-2a0014ed41fbf6dbb2a60f88b1227859177215fc.tar.bz2
gentoo-2a0014ed41fbf6dbb2a60f88b1227859177215fc.zip
net-ftp/frox: Support libressl (#565374)
Package-Manager: portage-2.3.1
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/frox/files/0.7.18-netfilter-includes.patch4
-rw-r--r--net-ftp/frox/files/0.7.18-respect-CFLAGS.patch4
-rw-r--r--net-ftp/frox/frox-0.7.18-r6.ebuild86
3 files changed, 90 insertions, 4 deletions
diff --git a/net-ftp/frox/files/0.7.18-netfilter-includes.patch b/net-ftp/frox/files/0.7.18-netfilter-includes.patch
index e40ce52862c9..889f42121722 100644
--- a/net-ftp/frox/files/0.7.18-netfilter-includes.patch
+++ b/net-ftp/frox/files/0.7.18-netfilter-includes.patch
@@ -1,5 +1,5 @@
---- configure.in.ori 2012-03-01 22:32:17.044450088 +0100
-+++ configure.in 2012-03-01 22:36:40.995882948 +0100
+--- a/configure.in.ori 2012-03-01 22:32:17.044450088 +0100
++++ b/configure.in 2012-03-01 22:36:40.995882948 +0100
@@ -331,7 +331,12 @@
AC_HEADER_STDC
AC_HEADER_SYS_WAIT
diff --git a/net-ftp/frox/files/0.7.18-respect-CFLAGS.patch b/net-ftp/frox/files/0.7.18-respect-CFLAGS.patch
index 9fb54ac153cd..8076d91ea268 100644
--- a/net-ftp/frox/files/0.7.18-respect-CFLAGS.patch
+++ b/net-ftp/frox/files/0.7.18-respect-CFLAGS.patch
@@ -1,5 +1,5 @@
---- configure.in 2005-02-04 11:24:55.000000000 +0100
-+++ configure.in 2012-03-01 22:56:25.985725178 +0100
+--- a/configure.in 2005-02-04 11:24:55.000000000 +0100
++++ b/configure.in 2012-03-01 22:56:25.985725178 +0100
@@ -46,11 +46,9 @@
;;
*)
diff --git a/net-ftp/frox/frox-0.7.18-r6.ebuild b/net-ftp/frox/frox-0.7.18-r6.ebuild
new file mode 100644
index 000000000000..a6bc4910d51e
--- /dev/null
+++ b/net-ftp/frox/frox-0.7.18-r6.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools eutils user
+
+DESCRIPTION="A transparent ftp proxy"
+SRC_URI="http://frox.sourceforge.net/download/${P}.tar.bz2"
+HOMEPAGE="http://frox.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="clamav libressl ssl transparent"
+
+DEPEND="
+ clamav? ( >=app-antivirus/clamav-0.80 )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl:0= ) )
+ kernel_linux? ( >=sys-kernel/linux-headers-2.6 )
+"
+RDEPEND="${DEPEND}"
+
+# INSTALL has useful filewall rules
+DOCS=(
+ BUGS README
+ doc/CREDITS doc/ChangeLog doc/FAQ doc/INSTALL
+ doc/INTERNALS doc/README.transdata doc/RELEASE
+ doc/SECURITY doc/TODO
+)
+
+pkg_setup() {
+ enewgroup ftpproxy
+ enewuser ftpproxy -1 -1 /var/spool/frox ftpproxy
+
+ use clamav && ewarn "Virus scanner potentialy broken in chroot - see bug #81035"
+}
+
+src_prepare () {
+ HTML_DOCS=( doc/*.html doc/*.sgml )
+
+ default
+
+ eapply "${FILESDIR}/${PV}-respect-CFLAGS.patch"
+ eapply "${FILESDIR}/${PV}-netfilter-includes.patch"
+ eapply "${FILESDIR}/${P}-config.patch"
+
+ if use clamav ; then
+ sed -i -e "s:^# VirusScanner.*:# VirusScanner '\"/usr/bin/clamscan\" \"%s\"':" \
+ "src/${PN}.conf" || die
+ fi
+
+ mv configure.in configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-http-cache --enable-local-cache \
+ --enable-procname \
+ --enable-configfile=/etc/frox.conf \
+ $(use_enable !kernel_linux libiptc) \
+ $(use_enable clamav virus-scan) \
+ $(use_enable ssl) \
+ $(use_enable transparent transparent-data) \
+ $(use_enable !transparent ntp)
+}
+
+src_install() {
+ default
+
+ keepdir /var/{log,spool}/"${PN}"
+
+ fperms 700 /var/spool/frox
+ fowners ftpproxy:ftpproxy /var/{log,spool}/frox
+
+ newman "doc/${PN}.man" "${PN}.man.8"
+ newman "doc/${PN}.conf.man" "${PN}.conf.man.5"
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+
+ insinto /etc
+ newins "src/${PN}.conf" "${PN}.conf.example"
+}