summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-im/birdie
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-im/birdie')
-rw-r--r--net-im/birdie/Manifest1
-rw-r--r--net-im/birdie/birdie-1.1-r1.ebuild79
-rw-r--r--net-im/birdie/metadata.xml10
3 files changed, 90 insertions, 0 deletions
diff --git a/net-im/birdie/Manifest b/net-im/birdie/Manifest
new file mode 100644
index 000000000000..b1e9c43b5205
--- /dev/null
+++ b/net-im/birdie/Manifest
@@ -0,0 +1 @@
+DIST birdie-1.1.tar.gz 218970 SHA256 c9b652b157f09241197c859d2c77f14becaf1b1031b1d2140dcc052a6227a338 SHA512 dc9fabebe580648227f0decc8bd441db4049559086db828957147f99cce0dc16a7b063f84092c8c7d712463e16f448cf6c3691e090cdb56dd5eed9c854bdaeae WHIRLPOOL 2cdbc9c2a536d81446484ede0b29c7849d42407755ac44cec60293b959ec79e2e6be6967fa3c6e871796a923553399d383e2465bf44fb592205e57c09a14a9f0
diff --git a/net-im/birdie/birdie-1.1-r1.ebuild b/net-im/birdie/birdie-1.1-r1.ebuild
new file mode 100644
index 000000000000..ad75635ab48a
--- /dev/null
+++ b/net-im/birdie/birdie-1.1-r1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+VALA_MIN_API_VERSION=0.22
+CMAKE_MAKEFILE_GENERATOR=ninja
+
+inherit cmake-utils fdo-mime gnome2 vala
+
+DESCRIPTION="Twitter client for Linux"
+HOMEPAGE="http://birdieapp.github.io/"
+SRC_URI="https://github.com/birdieapp/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-db/sqlite:3
+ >=dev-libs/granite-0.2.1
+ dev-libs/json-glib
+ dev-libs/libdbusmenu
+ dev-libs/libgee:0
+ net-libs/libsoup:2.4
+ net-libs/rest:0.7
+ media-libs/libcanberra
+ net-im/pidgin
+ net-libs/webkit-gtk:3
+ >=x11-libs/gtk+-3.10:3
+ x11-libs/gtksourceview:3.0
+ x11-libs/libnotify
+ x11-libs/libXtst
+"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+"
+
+src_prepare() {
+ sed \
+ -e '/ggdb/d' \
+ -e 's:gtk-update-icon-cache:true:g' \
+ -e 's:update-desktop-database:true:g' \
+ -i icons/CMakeLists.txt data/CMakeLists.txt CMakeLists.txt || die
+ vala_src_prepare
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DVALA_EXECUTABLE="${VALAC}"
+ -DGSETTINGS_COMPILE=OFF
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+}
+
+pkg_preinst() {
+ gnome2_pkg_preinst
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ gnome2_pkg_postinst
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ gnome2_pkg_postrm
+}
diff --git a/net-im/birdie/metadata.xml b/net-im/birdie/metadata.xml
new file mode 100644
index 000000000000..d2c94161ca63
--- /dev/null
+++ b/net-im/birdie/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">birdieapp/birdie</remote-id>
+ </upstream>
+</pkgmetadata>