summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@gentoo.org>2021-10-22 11:39:20 +0100
committerAndrey Utkin <andrey_utkin@gentoo.org>2021-10-22 12:45:15 +0100
commitba37afa4406e0cf14e9fb5af84d528f2980ff065 (patch)
tree68a0df5aff2723d456e52cb6e8f6a54346b768c0 /net-im/dino
parentnet-analyzer/zabbix: bump to 5.0.17 (diff)
downloadgentoo-ba37afa4406e0cf14e9fb5af84d528f2980ff065.tar.gz
gentoo-ba37afa4406e0cf14e9fb5af84d528f2980ff065.tar.bz2
gentoo-ba37afa4406e0cf14e9fb5af84d528f2980ff065.zip
net-im/dino: document how to enable video calls
Video calls need some runtime dependencies. Video calls are not going to be used by everyone (at least not immediately) so these dependencies are optional. So they go to post-installation notice and not RDEPEND for now. Bug: https://bugs.gentoo.org/795129 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andrey Utkin <andrey_utkin@gentoo.org>
Diffstat (limited to 'net-im/dino')
-rw-r--r--net-im/dino/dino-9999.ebuild12
-rw-r--r--net-im/dino/files/README.gentoo23
2 files changed, 34 insertions, 1 deletions
diff --git a/net-im/dino/dino-9999.ebuild b/net-im/dino/dino-9999.ebuild
index 408e90c29689..ec609bb4854e 100644
--- a/net-im/dino/dino-9999.ebuild
+++ b/net-im/dino/dino-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=7
CMAKE_MAKEFILE_GENERATOR="ninja"
VALA_MIN_API_VERSION="0.34"
-inherit cmake vala xdg
+inherit cmake vala xdg readme.gentoo-r1
DESCRIPTION="Modern Jabber/XMPP Client using GTK+/Vala"
HOMEPAGE="https://dino.im"
@@ -79,3 +79,13 @@ src_configure() {
src_test() {
"${BUILD_DIR}"/xmpp-vala-test || die
}
+
+src_install() {
+ cmake_src_install
+ readme.gentoo_create_doc
+}
+
+src_postinst() {
+ xdg_pkg_postinst
+ readme.gentoo_print_elog
+}
diff --git a/net-im/dino/files/README.gentoo b/net-im/dino/files/README.gentoo
new file mode 100644
index 000000000000..b51e4391562e
--- /dev/null
+++ b/net-im/dino/files/README.gentoo
@@ -0,0 +1,23 @@
+To enable video calls, install the following packages.
+
+Transport level security:
+- gst-plugins-srtp
+- gst-plugins-dtls
+
+Peer to peer connection reliability:
+- gst-plugins-libnice
+
+Video output into a window:
+- gst-plugins-gtk
+
+At least one codec is needed in common with the other end of the call, as they
+are negotiated when the call begins.
+
+Video codecs:
+- gst-plugins-x264
+- gst-plugins-vpx
+
+Audio codecs:
+- gst-plugins-good
+- gst-plugins-speex
+- gst-plugins-opus