summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYu Gu <guyu2876@gmail.com>2023-02-26 20:38:03 +0800
committerJoonas Niilola <juippis@gentoo.org>2023-03-08 15:43:45 +0200
commit7646f9ed71ae9e81bba91815ea7e1965bc6f4438 (patch)
tree8a13e42ce7d95af6add5b9895dd41c0a07de078b /net-im/err
parentnet-im/err: enable py3.11 (diff)
downloadgentoo-7646f9ed71ae9e81bba91815ea7e1965bc6f4438.tar.gz
gentoo-7646f9ed71ae9e81bba91815ea7e1965bc6f4438.tar.bz2
gentoo-7646f9ed71ae9e81bba91815ea7e1965bc6f4438.zip
net-im/err: drop old
Signed-off-by: Yu Gu <guyu2876@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/29806 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-im/err')
-rw-r--r--net-im/err/Manifest2
-rw-r--r--net-im/err/err-6.1.7.ebuild87
-rw-r--r--net-im/err/err-6.1.8-r1.ebuild93
-rw-r--r--net-im/err/files/err-6.1.8-fix-irc-backend.patch18
4 files changed, 0 insertions, 200 deletions
diff --git a/net-im/err/Manifest b/net-im/err/Manifest
index 8acdb8c9e6ba..56c41525b4c0 100644
--- a/net-im/err/Manifest
+++ b/net-im/err/Manifest
@@ -1,3 +1 @@
-DIST err-6.1.7.tar.gz 1359383 BLAKE2B 400bbf4a4180f74993a4414dc55f07a69b34b04277fecd073bd860df9dcd5da4873949df766c0c2f6b7a43b4e87153d0aa77b0abaf95bf9702d76c3c7b290abe SHA512 cd0dadc5ff380c71631bae7711bdba7345046fbe14e369c8efa8eed98752b9ea03f6e4fa3171df257a9d76686c610e28fac5f39f7e8e107348a5746e4354694b
-DIST err-6.1.8.tar.gz 1609310 BLAKE2B e3682bfccd548c92160322287a17e26448322abd3956d464b393f333c0cc521d6d5183dab799d280603995a4508a2eb300fefb9c6159da6ed1c550247fa375d9 SHA512 5413f667ee4e121134b791f0dc8fd709ecbd9093a237b9637d282f41458c40076615ffc9167cfa95f297ae416c38b16ded8ae97aece55a81d88dc46b324ec851
DIST err-6.1.9.tar.gz 1554146 BLAKE2B 62a715d57c213b8d68c40afad92c14d26ff23fdce1df6b489be23817d33d8bc01c7c400ca7360546abc880b4a7e6205f92a3787cabfce3e14500ef8918a4b010 SHA512 cc8f7a00bc9bd7680d978b4c2e6c9ac78f32e0a99796cc9933802206b2c2998caf060d474aca374d8102923bf8eb64f69a01846c5761b13a8624641796893c9b
diff --git a/net-im/err/err-6.1.7.ebuild b/net-im/err/err-6.1.7.ebuild
deleted file mode 100644
index f214822c7eef..000000000000
--- a/net-im/err/err-6.1.7.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_9 )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-inherit distutils-r1
-
-MY_PN="errbot"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Multiprotocol chatbot designed to be easily deployable and maintainable"
-HOMEPAGE="https://errbot.readthedocs.io/en/latest/"
-SRC_URI="https://github.com/errbotio/errbot/archive/${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-KEYWORDS="~amd64"
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="irc +xmpp"
-
-DEPEND="
- acct-group/err
- acct-user/err"
-RDEPEND="${DEPEND}
- dev-python/ansi[${PYTHON_USEDEP}]
- dev-python/bottle[${PYTHON_USEDEP}]
- dev-python/colorlog[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/daemonize[${PYTHON_USEDEP}]
- dev-python/deepmerge[${PYTHON_USEDEP}]
- dev-python/dulwich[${PYTHON_USEDEP}]
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/markdown[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/webtest[${PYTHON_USEDEP}]
- irc? (
- dev-python/irc[${PYTHON_USEDEP}]
- )
- xmpp? (
- dev-python/pyasn1[${PYTHON_USEDEP}]
- dev-python/pyasn1-modules[${PYTHON_USEDEP}]
- dev-python/slixmpp[${PYTHON_USEDEP}]
- )"
-BDEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}] )"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- sed -i -e '/pygments-markdown-lexer/d' setup.py || die
-
- # NameError: name 'slack' is not defined
- rm tests/backend_tests/slack_test.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local deselect=(
- --deselect tests/commands_test.py::test_plugin_cycle
- --deselect tests/commands_test.py::test_broken_plugin
- --deselect tests/commands_test.py::test_backup
- --deselect tests/plugin_management_test.py::test_check_dependencies_requi
- )
-
- pytest -vv "${deselect[@]}" || die "Tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- newinitd "${FILESDIR}"/errd.initd.2 errd
- newconfd "${FILESDIR}"/errd.confd errd
-
- dodir /etc/${PN}
- keepdir /var/lib/${PN}
- keepdir /var/log/${PN}
- fowners -R err:err /var/lib/${PN}
- fowners -R err:err /var/log/${PN}
-
- insinto /etc/${PN}
- newins errbot/config-template.py config.py
-}
diff --git a/net-im/err/err-6.1.8-r1.ebuild b/net-im/err/err-6.1.8-r1.ebuild
deleted file mode 100644
index 420f3ad28dc1..000000000000
--- a/net-im/err/err-6.1.8-r1.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..10} )
-DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1
-
-MY_PN="errbot"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Multiprotocol chatbot designed to be easily deployable and maintainable"
-HOMEPAGE="https://errbot.readthedocs.io/en/latest/"
-SRC_URI="https://github.com/errbotio/errbot/archive/${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-PATCHES="${FILESDIR}/err-6.1.8-fix-irc-backend.patch"
-
-KEYWORDS="~amd64 ~riscv"
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="irc +xmpp"
-
-DEPEND="
- acct-group/err
- acct-user/err"
-RDEPEND="${DEPEND}
- dev-python/ansi[${PYTHON_USEDEP}]
- dev-python/bottle[${PYTHON_USEDEP}]
- dev-python/colorlog[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/daemonize[${PYTHON_USEDEP}]
- dev-python/deepmerge[${PYTHON_USEDEP}]
- dev-python/dulwich[${PYTHON_USEDEP}]
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/markdown[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/webtest[${PYTHON_USEDEP}]
- irc? (
- dev-python/irc[${PYTHON_USEDEP}]
- )
- xmpp? (
- dev-python/pyasn1[${PYTHON_USEDEP}]
- dev-python/pyasn1-modules[${PYTHON_USEDEP}]
- dev-python/slixmpp[${PYTHON_USEDEP}]
- )"
-BDEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}] )"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- sed -i -e '/pygments-markdown-lexer/d' setup.py || die
-
- # NameError: name 'slack' is not defined
- rm tests/backend_tests/slack_test.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local deselect=(
- tests/commands_test.py::test_plugin_cycle
- tests/commands_test.py::test_broken_plugin
- tests/commands_test.py::test_backup
- tests/plugin_management_test.py::test_check_dependencies_requi
- )
-
- epytest ${deselect[@]/#/--deselect }
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- newinitd "${FILESDIR}"/errd.initd.2 errd
- newconfd "${FILESDIR}"/errd.confd errd
-
- dodir /etc/${PN}
- keepdir /var/lib/${PN}
- keepdir /var/log/${PN}
- fowners -R err:err /var/lib/${PN}
- fowners -R err:err /var/log/${PN}
-
- insinto /etc/${PN}
- newins errbot/config-template.py config.py
-}
-
-pkg_postinst() {
- elog "For more backends (Hipchat, Slact, Telegram) support, use pip"
-}
diff --git a/net-im/err/files/err-6.1.8-fix-irc-backend.patch b/net-im/err/files/err-6.1.8-fix-irc-backend.patch
deleted file mode 100644
index 0874e7352bc1..000000000000
--- a/net-im/err/files/err-6.1.8-fix-irc-backend.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-From 34df1dd98a7ce3a17c22081fadb427827b431d7f Mon Sep 17 00:00:00 2001
-From: Carlos <nzlosh@yahoo.com>
-Date: Fri, 22 Apr 2022 23:45:44 +0200
-Subject: [PATCH] Fixes #1566 remove unsupport argument reconnection_interval
- from irc backend.
-
-diff --git a/errbot/backends/irc.py b/errbot/backends/irc.py
-index 95a8757d4..9f7e75b29 100644
---- a/errbot/backends/irc.py
-+++ b/errbot/backends/irc.py
-@@ -377,7 +377,6 @@ def __init__(
- [(server, port, password)],
- nickname,
- username,
-- reconnection_interval=reconnect_on_disconnect,
- )
-
- def connect(self, *args, **kwargs) -> None: