summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Heidelberg <david@ixit.cz>2019-12-20 16:49:58 +0100
committerMatt Turner <mattst88@gentoo.org>2020-02-08 11:47:54 -0800
commitdeaa180d8b54aba6764ea5a8bdfa935ee7e5da5a (patch)
tree47a17d5563e175058f8b969d6f33254550544269 /net-im/telepathy-mission-control/telepathy-mission-control-5.16.5.ebuild
parentsys-cluster/cinder: 15.0.0 cleanup (diff)
downloadgentoo-deaa180d8b54aba6764ea5a8bdfa935ee7e5da5a.tar.gz
gentoo-deaa180d8b54aba6764ea5a8bdfa935ee7e5da5a.tar.bz2
gentoo-deaa180d8b54aba6764ea5a8bdfa935ee7e5da5a.zip
net-im/telepathy-mission-control: bump 5.16.5
- includes upstream patch, which makes Polari works again! [1] [1] https://gitlab.gnome.org/GNOME/polari/issues/119 Closes: https://bugs.gentoo.org/703424 Closes: https://github.com/gentoo/gentoo/pull/14058 Signed-off-by: David Heidelberg <david@ixit.cz> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'net-im/telepathy-mission-control/telepathy-mission-control-5.16.5.ebuild')
-rw-r--r--net-im/telepathy-mission-control/telepathy-mission-control-5.16.5.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-im/telepathy-mission-control/telepathy-mission-control-5.16.5.ebuild b/net-im/telepathy-mission-control/telepathy-mission-control-5.16.5.ebuild
new file mode 100644
index 000000000000..9018152235cf
--- /dev/null
+++ b/net-im/telepathy-mission-control/telepathy-mission-control-5.16.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+# Needed for tests and build #489466
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-any-r1
+
+DESCRIPTION="An account manager and channel dispatcher for the Telepathy framework"
+HOMEPAGE="https://cgit.freedesktop.org/telepathy/telepathy-mission-control/"
+SRC_URI="https://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug networkmanager" # test
+
+RDEPEND="
+ >=dev-libs/dbus-glib-0.82
+ >=dev-libs/glib-2.46:2
+ >=sys-apps/dbus-0.95
+ >=net-libs/telepathy-glib-0.20
+ networkmanager? ( >=net-misc/networkmanager-1:= )
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ dev-libs/libxslt
+ >=dev-util/gtk-doc-am-1.17
+ virtual/pkgconfig
+"
+# test? ( dev-python/twisted-words )"
+
+# Tests are broken, see upstream bug #29334 and #64212
+# upstream doesn't want it enabled everywhere (#29334#c12)
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}/5.16.5-account-fix-property-name.patch" )
+
+src_configure() {
+ # creds is not available
+ gnome2_src_configure \
+ --disable-static \
+ --disable-upower \
+ $(use_enable debug) \
+ $(use_with networkmanager connectivity nm)
+}