summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-06-17 08:35:55 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-06-17 08:36:52 +0200
commit02a06f1f8947aef969467514ff9f0c16f75ab6c6 (patch)
tree3a79ac1857b77ddd39484703376e967e5c398a8b /net-im
parentdev-python/pynest2d: drop old (diff)
downloadgentoo-02a06f1f8947aef969467514ff9f0c16f75ab6c6.tar.gz
gentoo-02a06f1f8947aef969467514ff9f0c16f75ab6c6.tar.bz2
gentoo-02a06f1f8947aef969467514ff9f0c16f75ab6c6.zip
net-im/rocketchat-desktop-bin: version bump 3.3.0
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/rocketchat-desktop-bin/Manifest1
-rw-r--r--net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.3.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/net-im/rocketchat-desktop-bin/Manifest b/net-im/rocketchat-desktop-bin/Manifest
index a1e56775b509..5508f6378281 100644
--- a/net-im/rocketchat-desktop-bin/Manifest
+++ b/net-im/rocketchat-desktop-bin/Manifest
@@ -1 +1,2 @@
DIST rocketchat-3.2.2.x86_64.rpm 55347028 BLAKE2B 77fb7f5461b28ae4cf896742b4a65bd19a877aa69984f1040e509b2dfdacdceb4db83d9f6af58e2ef357e5884a927a05d707b0af502cf83c9aeb238a1cec8fad SHA512 5f48168529804d6fc849dac21f3ca0f94b6d8cb5d3ef0086a8f1631c0a66b69741ff5e642e64b08a3df2dd7e3a6d36f97dca5157a43c3a716238f293dcadad7e
+DIST rocketchat-3.3.0.x86_64.rpm 56322356 BLAKE2B 9d1caaceb16fa68fdfb11d41dae4a7d464e7bb9f92fa3f734f273447228faee53e958e0e87934e9cc5c4b1a133e18ebe610dcf429b780993a20e9a44251d7480 SHA512 e3bda69d0395823a40c56909ef4ae6faee1dcc733eee20ef3067cd7bf57066056505efa2a3817d2640ea7bee0cc0920cdf187dddd53320c224cbe2c3efc21088
diff --git a/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.3.0.ebuild b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.3.0.ebuild
new file mode 100644
index 000000000000..0c6ba72c3682
--- /dev/null
+++ b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.3.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit rpm xdg
+
+DESCRIPTION="The Ultimate Open Source Web Chat Platform"
+HOMEPAGE="https://rocket.chat"
+SRC_URI="https://github.com/RocketChat/Rocket.Chat.Electron/releases/download/${PV}/rocketchat-${PV}.x86_64.rpm"
+
+KEYWORDS="-* ~amd64"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ app-accessibility/at-spi2-atk:2
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/libappindicator
+ dev-libs/nspr
+ dev-libs/nss
+ media-fonts/noto-emoji
+ media-libs/alsa-lib
+ net-print/cups
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libnotify
+ x11-libs/libxcb
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/libXScrnSaver
+ x11-libs/pango
+"
+
+QA_PREBUILT="/opt/Rocket.Chat/*"
+
+S="${WORKDIR}"
+
+src_install() {
+ # remove files useless for Gentoo
+ rm -r usr/lib || die
+ cp -a "${S}"/* "${ED}" || die
+}