summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-17 03:44:15 +0000
committerSam James <sam@gentoo.org>2021-01-17 04:10:23 +0000
commit0faf81bb0123105cf859dd3e543b2dee40783948 (patch)
tree64f898b94d0ac79e4c62af4dff6fcd261b2552aa /net-libs/libesmtp
parentnet-firewall/pglinux: fix MissingUnpackerDep (diff)
downloadgentoo-0faf81bb0123105cf859dd3e543b2dee40783948.tar.gz
gentoo-0faf81bb0123105cf859dd3e543b2dee40783948.tar.bz2
gentoo-0faf81bb0123105cf859dd3e543b2dee40783948.zip
net-libs/libesmtp: fix DeprecatedInsinto
Package-Manager: Portage-3.0.12.0.2-prefix, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs/libesmtp')
-rw-r--r--net-libs/libesmtp/libesmtp-1.0.6-r3.ebuild10
-rw-r--r--net-libs/libesmtp/libesmtp-9999.ebuild2
2 files changed, 9 insertions, 3 deletions
diff --git a/net-libs/libesmtp/libesmtp-1.0.6-r3.ebuild b/net-libs/libesmtp/libesmtp-1.0.6-r3.ebuild
index cedef690ec47..c2724ec96bce 100644
--- a/net-libs/libesmtp/libesmtp-1.0.6-r3.ebuild
+++ b/net-libs/libesmtp/libesmtp-1.0.6-r3.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit autotools
DESCRIPTION="lib that implements the client side of the SMTP protocol"
@@ -19,7 +20,9 @@ RDEPEND="
libressl? ( dev-libs/libressl:0= )
)"
DEPEND="${RDEPEND}"
+
DOCS=( AUTHORS ChangeLog NEWS Notes README TODO )
+
PATCHES=(
"${FILESDIR}/${P}-openssl-1.1-api-compatibility.patch"
)
@@ -31,8 +34,8 @@ src_prepare() {
src_configure() {
econf \
- $(use_enable static-libs static) \
--enable-all \
+ $(use_enable static-libs static) \
$(use_enable ntlm) \
$(use_enable threads pthreads) \
$(use_enable debug) \
@@ -41,6 +44,7 @@ src_configure() {
src_install() {
default
- insinto /usr/share/doc/${PF}/xml
- doins doc/api.xml
+
+ docinto xml
+ dodoc doc/api.xml
}
diff --git a/net-libs/libesmtp/libesmtp-9999.ebuild b/net-libs/libesmtp/libesmtp-9999.ebuild
index 78e059810faf..20a4ae8e7534 100644
--- a/net-libs/libesmtp/libesmtp-9999.ebuild
+++ b/net-libs/libesmtp/libesmtp-9999.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit meson
DESCRIPTION="lib that implements the client side of the SMTP protocol"
@@ -13,6 +14,7 @@ else
SRC_URI="https://github.com/libesmtp/libESMTP/archive/v${PV/_}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
fi
+
LICENSE="LGPL-2.1 GPL-2"
SLOT="0"
IUSE="libressl ssl static-libs threads"