summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2024-04-24 13:22:37 +0100
committerMarek Szuba <marecki@gentoo.org>2024-04-24 13:38:19 +0100
commitb53980535864e0f237a00d27673764fbca95482c (patch)
tree8a8718b5801b2969063c1b0318ccbe1039338690 /net-libs/libhtp/libhtp-0.5.48.ebuild
parentsys-fs/xfsdump: Keyword 3.1.12 riscv, #930551 (diff)
downloadgentoo-b53980535864e0f237a00d27673764fbca95482c.tar.gz
gentoo-b53980535864e0f237a00d27673764fbca95482c.tar.bz2
gentoo-b53980535864e0f237a00d27673764fbca95482c.zip
net-libs/libhtp: add 0.5.48, drop 0.5.47
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'net-libs/libhtp/libhtp-0.5.48.ebuild')
-rw-r--r--net-libs/libhtp/libhtp-0.5.48.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-libs/libhtp/libhtp-0.5.48.ebuild b/net-libs/libhtp/libhtp-0.5.48.ebuild
new file mode 100644
index 000000000000..2bef77203967
--- /dev/null
+++ b/net-libs/libhtp/libhtp-0.5.48.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Security-aware parser for the HTTP protocol and the related bits and pieces"
+HOMEPAGE="https://github.com/OISF/libhtp"
+SRC_URI="https://github.com/OISF/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~riscv ~x86"
+IUSE="debug"
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.5.48-configure_fortify_source.patch
+)
+
+# false positive -- function specific to dev-libs/libiconv, which is only used
+# in Windows-based Prefix installations
+QA_CONFIG_IMPL_DECL_SKIP=( iconvctl )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # The debug configure logic is broken.
+ econf $(usev debug '--enable-debug')
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die "Failed to remove .la files"
+}