summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2023-08-20 21:52:23 -0400
committerRick Farina <zerochaos@gentoo.org>2023-08-20 21:55:24 -0400
commit8d1b2e91d02f5a5fd17768d5293f94269e5f24e4 (patch)
treedc2ce9a395f4b1a9654a841ae0c4cd0d0d6d8a84 /net-libs/libiio
parentdev-python/pybind11: Remove old (diff)
downloadgentoo-8d1b2e91d02f5a5fd17768d5293f94269e5f24e4.tar.gz
gentoo-8d1b2e91d02f5a5fd17768d5293f94269e5f24e4.tar.bz2
gentoo-8d1b2e91d02f5a5fd17768d5293f94269e5f24e4.zip
net-libs/libiio: add 0.25
sync live ebuild add python support Closes: https://bugs.gentoo.org/823137 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'net-libs/libiio')
-rw-r--r--net-libs/libiio/Manifest1
-rw-r--r--net-libs/libiio/libiio-0.25.ebuild53
-rw-r--r--net-libs/libiio/libiio-9999.ebuild43
3 files changed, 89 insertions, 8 deletions
diff --git a/net-libs/libiio/Manifest b/net-libs/libiio/Manifest
index 42e76fef3fce..ff1b7ab94c35 100644
--- a/net-libs/libiio/Manifest
+++ b/net-libs/libiio/Manifest
@@ -1 +1,2 @@
DIST libiio-0.24.tar.gz 482936 BLAKE2B cd8dce7af7bbafcb10c08722871d3d9abe089cb22fc3a0ada97905a1c5f96c55905980b8511178d662e9316b7ffdada6e84c29b5cbf1ca92b2d53b02d1ac8cfe SHA512 4e7b54870e986e6ba5860ccd8ad6ece4808c21e27a9d3975065f096bac0b035e65bbc68931023c19e69b72006294c3863bfb7272853b5fb1401b77eec88a89fd
+DIST libiio-0.25.tar.gz 518247 BLAKE2B 9b3190b5c69fc9fc624f4b0c686cace828fc34219a986a306ffba6b4c2a4f3b8c60cd8d5c67c350033d83ecdaeb010559318bbf76f0b0565bdbcbe119d85e097 SHA512 e0f2f5545b4c78d1f0f56b037db6e363aab01aad69af3a095b3546af74dab6effe0b00f5c336ef799a739f76c5f16ab76a6b8e823508861edd2745a9d3fd2599
diff --git a/net-libs/libiio/libiio-0.25.ebuild b/net-libs/libiio/libiio-0.25.ebuild
new file mode 100644
index 000000000000..d65727ab9981
--- /dev/null
+++ b/net-libs/libiio/libiio-0.25.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit cmake udev python-single-r1
+
+DESCRIPTION="Library for interfacing with IIO devices"
+HOMEPAGE="https://github.com/analogdevicesinc/libiio"
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/analogdevicesinc/libiio"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/analogdevicesinc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+IUSE="+aio python +zeroconf"
+
+BDEPEND="python? ( ${PYTHON_DEPS} )"
+RDEPEND="python? ( ${PYTHON_DEPS} )
+ dev-libs/libxml2
+ virtual/libusb:1
+ aio? ( dev-libs/libaio )
+ zeroconf? ( net-dns/avahi[dbus] )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DHAVE_DNS_SD="$(usex zeroconf)"
+ -DWITH_AIO="$(usex aio)"
+ -DPYTHON_BINDINGS="$(usex python)"
+ )
+ use python && mycmakeargs+=(-DPYTHON_EXECUTABLE="${PYTHON}")
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ python_fix_shebang "${ED}"
+ python_optimize
+}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}
diff --git a/net-libs/libiio/libiio-9999.ebuild b/net-libs/libiio/libiio-9999.ebuild
index 66f1603cbe68..d65727ab9981 100644
--- a/net-libs/libiio/libiio-9999.ebuild
+++ b/net-libs/libiio/libiio-9999.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+PYTHON_COMPAT=( python3_{10..12} )
-inherit cmake
+inherit cmake udev python-single-r1
DESCRIPTION="Library for interfacing with IIO devices"
HOMEPAGE="https://github.com/analogdevicesinc/libiio"
@@ -12,15 +13,41 @@ if [ "${PV}" = "9999" ]; then
inherit git-r3
else
SRC_URI="https://github.com/analogdevicesinc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="~amd64 ~arm ~riscv ~x86"
fi
LICENSE="LGPL-2.1"
SLOT="0/${PV}"
-IUSE="+aio +zeroconf"
+IUSE="+aio python +zeroconf"
-RDEPEND="dev-libs/libxml2:=
- virtual/libusb:1=
+BDEPEND="python? ( ${PYTHON_DEPS} )"
+RDEPEND="python? ( ${PYTHON_DEPS} )
+ dev-libs/libxml2
+ virtual/libusb:1
aio? ( dev-libs/libaio )
- zeroconf? ( net-dns/avahi )"
+ zeroconf? ( net-dns/avahi[dbus] )"
DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DHAVE_DNS_SD="$(usex zeroconf)"
+ -DWITH_AIO="$(usex aio)"
+ -DPYTHON_BINDINGS="$(usex python)"
+ )
+ use python && mycmakeargs+=(-DPYTHON_EXECUTABLE="${PYTHON}")
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ python_fix_shebang "${ED}"
+ python_optimize
+}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}