summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/liblockfile/files/Makefile.Darwin.in
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/liblockfile/files/Makefile.Darwin.in')
-rw-r--r--net-libs/liblockfile/files/Makefile.Darwin.in80
1 files changed, 80 insertions, 0 deletions
diff --git a/net-libs/liblockfile/files/Makefile.Darwin.in b/net-libs/liblockfile/files/Makefile.Darwin.in
new file mode 100644
index 000000000000..bdd320fe6d49
--- /dev/null
+++ b/net-libs/liblockfile/files/Makefile.Darwin.in
@@ -0,0 +1,80 @@
+#
+# Makefile.in Makefile for the liblockfile package (Darwin version)
+#
+# Gentoo version for Darwin, based on original:
+# version: @(#)Makefile.in 1.01 16-Apr-1999 miquels@cistron.nl
+#
+
+VER = 1.0
+NVER = 0.1
+
+CFLAGS = @CFLAGS@ -I.
+LDFLAGS = @LDFLAGS@
+CC = @CC@
+
+prefix = @prefix@
+exec_prefix = @exec_prefix@
+bindir = @bindir@
+libdir = @libdir@
+mandir = @mandir@
+nfslockdir = @nfslockdir@
+includedir = @includedir@
+
+MAILGROUP = @MAILGROUP@
+
+all: @TARGETS@
+install: @INSTALL_TARGETS@
+
+static: liblockfile.a dotlockfile
+shared: liblockfile.dylib dotlockfile
+nfslib: nfslock.$(VER).dylib
+
+liblockfile.a: lockfile.o
+ ar rv liblockfile.a lockfile.o
+
+liblockfile.dylib: liblockfile.a
+ $(CC) $(LDFLAGS) -fPIC -dynamiclib -install_name @libdir@/liblockfile.1.0.dylib \
+ -o liblockfile.dylib lockfile.o -lc
+
+nfslock.$(VER).dylib: nfslock.o
+ $(CC) $(LDFLAGS) -fPIC -dynamiclib -install_name nfslock.0.dylib \
+ -o nfslock.$(NVER).dylib nfslock.o
+
+dotlockfile: dotlockfile.o xlockfile.o
+ $(CC) $(LDFLAGS) -o dotlockfile dotlockfile.o xlockfile.o
+
+lockfile.o: lockfile.c
+ $(CC) $(CFLAGS) -DLIB -DLOCKPROG=\"$(bindir)/dotlockfile\" \
+ -c lockfile.c
+
+xlockfile.o: lockfile.c
+ $(CC) $(CFLAGS) -c lockfile.c -o xlockfile.o
+
+install_static: static install_common
+ install -m 644 liblockfile.a $(ROOT)$(libdir)
+
+install_shared: shared install_common
+ install -m 755 liblockfile.dylib \
+ $(ROOT)$(libdir)/liblockfile.$(VER).dylib
+ ln -s liblockfile.$(VER).dylib $(ROOT)$(libdir)/liblockfile.dylib
+
+install_common:
+ install -m 644 lockfile.h maillock.h $(ROOT)$(includedir)
+ if [ "$(MAILGROUP)" != "" ]; then\
+ install -g $(MAILGROUP) -m 2755 dotlockfile $(ROOT)$(bindir);\
+ else \
+ install -g root -m 755 dotlockfile $(ROOT)$(bindir); \
+ fi
+ install -m 644 *.1 $(ROOT)$(mandir)/man1
+ install -m 644 *.3 $(ROOT)$(mandir)/man3
+
+install_nfslib: nfslib
+ install -m 755 nfslock.$(VER).dylib $(ROOT)$(nfslockdir)
+
+clean:
+ rm -f *.a *.o *.dylib dotlockfile
+
+distclean: clean
+ rm -f Makefile autoconf.h maillock.h \
+ config.cache config.log config.status
+