summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-06-08 15:11:38 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-06-08 15:13:06 +0200
commit85c5034c00b6055485b5716f4b543a8abd076ece (patch)
tree7730e52a822ecd17484b7eacdad7b49ee5ba7604 /net-libs/libquotient
parentmedia-libs/harfbuzz: increase test timeout (diff)
downloadgentoo-85c5034c00b6055485b5716f4b543a8abd076ece.tar.gz
gentoo-85c5034c00b6055485b5716f4b543a8abd076ece.tar.bz2
gentoo-85c5034c00b6055485b5716f4b543a8abd076ece.zip
net-libs/libquotient: Add missing dependencies
See also: https://github.com/gentoo/gentoo/pull/31113 Closes: https://bugs.gentoo.org/908064 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs/libquotient')
-rw-r--r--net-libs/libquotient/libquotient-0.7.2-r2.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/net-libs/libquotient/libquotient-0.7.2-r2.ebuild b/net-libs/libquotient/libquotient-0.7.2-r2.ebuild
new file mode 100644
index 000000000000..3d1736b98370
--- /dev/null
+++ b/net-libs/libquotient/libquotient-0.7.2-r2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Qt-based SDK to develop applications for Matrix"
+HOMEPAGE="https://github.com/quotient-im/libQuotient"
+SRC_URI="https://github.com/quotient-im/libQuotient/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/libQuotient-${PV}"
+
+LICENSE="LGPL-2+"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/libqtolm
+ dev-libs/openssl:=
+ dev-libs/olm
+ dev-libs/qtkeychain:=[qt5(+)]
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtsql:5
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-qt/qtconcurrent:5
+ dev-qt/qttest:5
+ )
+"
+
+PATCHES=(
+ # downstream patches
+ "${FILESDIR}"/${PN}-0.7.0-no-android.patch
+ "${FILESDIR}"/${PN}-0.7.0-no-tests.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_WITH_QT6=OFF
+ -DBUILD_TESTING=$(usex test)
+ -DQuotient_ENABLE_E2EE=ON
+ )
+ use test && mycmakeargs+=(
+ -DQuotient_INSTALL_TESTS=OFF
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ # https://github.com/quotient-im/libQuotient/issues/435
+ # testolmaccount requires network connection/server set up
+ local myctestargs=(
+ -j1
+ -E "(testolmaccount)"
+ )
+ cmake_src_test
+}