summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-10-08 09:32:07 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-10-08 09:37:32 +0200
commit8a094ae4e756002bc57f24b149eb2269f4431c87 (patch)
treeca9d8376135633ff248748fd92eeafc74fbf1a32 /net-libs/libquotient
parentapp-xemacs/pcomplete: drop 1.04, 1.06 (diff)
downloadgentoo-8a094ae4e756002bc57f24b149eb2269f4431c87.tar.gz
gentoo-8a094ae4e756002bc57f24b149eb2269f4431c87.tar.bz2
gentoo-8a094ae4e756002bc57f24b149eb2269f4431c87.zip
net-libs/libquotient: 0.6.11 version bump
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs/libquotient')
-rw-r--r--net-libs/libquotient/Manifest1
-rw-r--r--net-libs/libquotient/libquotient-0.6.11.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/net-libs/libquotient/Manifest b/net-libs/libquotient/Manifest
index d4dfe16ef548..e011aebd4e97 100644
--- a/net-libs/libquotient/Manifest
+++ b/net-libs/libquotient/Manifest
@@ -1 +1,2 @@
DIST libquotient-0.6.10.tar.gz 561503 BLAKE2B ee5f15af16a964a517e9d51befbf79dbaeb433f366cc1c730681f1bf088a53a38a2ccacfcf4f3cc38998b4a15dbb8418d0864da936f00911f0af94f5aadac36f SHA512 3a70f06c6f74d599033a17527e0bd7abd2b52b9425114def3b0630fbf8ff5c22095227856cae7319e2fb6f7025439606cd986183c5d530463c092209b7291f5a
+DIST libquotient-0.6.11.tar.gz 562144 BLAKE2B 75be68371ac1873e38f9ff81273419ed1eb773d02408137a7dafc9a60f520a2ba0b5556783272f8902dd98f7f5dac3a92ab393da5dd48acfffeba8b1631a84dd SHA512 76a11c80822ae3279d643559b481a09fe45b1f8effb7b0efeeb7ab54f13dd06997d9220dcb36c13d270f5641f496dba350f528c49e239757f4546de9fbe940fa
diff --git a/net-libs/libquotient/libquotient-0.6.11.ebuild b/net-libs/libquotient/libquotient-0.6.11.ebuild
new file mode 100644
index 000000000000..f18a7ff72943
--- /dev/null
+++ b/net-libs/libquotient/libquotient-0.6.11.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Qt5-based SDK to develop applications for Matrix"
+HOMEPAGE="https://github.com/quotient-im/libQuotient"
+SRC_URI="https://github.com/quotient-im/libQuotient/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/libQuotient-${PV}"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ # downstream patches
+ "${FILESDIR}"/${PN}-0.6.3-no-android.patch
+ "${FILESDIR}"/${PN}-0.6.3-no-tests.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DQuotient_INSTALL_TESTS=OFF
+ -DQuotient_ENABLE_E2EE=OFF # TODO: libolm, libqtolm not packaged
+ -DCMAKE_DISABLE_FIND_PACKAGE_Git=ON # no thanks.
+ )
+ cmake_src_configure
+}