summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-30 23:20:55 +0100
committerSam James <sam@gentoo.org>2022-08-30 23:21:19 +0100
commit68be73afc06c27eeeef724acbaa6ff5b20dacc3f (patch)
tree09ebb894beeb76c991c1e8b386664b9543c9d0fc /net-libs/libssh
parentdev-util/ninja: add 1.11.1 (diff)
downloadgentoo-68be73afc06c27eeeef724acbaa6ff5b20dacc3f.tar.gz
gentoo-68be73afc06c27eeeef724acbaa6ff5b20dacc3f.tar.bz2
gentoo-68be73afc06c27eeeef724acbaa6ff5b20dacc3f.zip
net-libs/libssh: add 0.10.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs/libssh')
-rw-r--r--net-libs/libssh/Manifest1
-rw-r--r--net-libs/libssh/files/libssh-0.10.1-disable-broken-test.patch28
-rw-r--r--net-libs/libssh/libssh-0.10.1.ebuild127
-rw-r--r--net-libs/libssh/libssh-9999.ebuild31
4 files changed, 174 insertions, 13 deletions
diff --git a/net-libs/libssh/Manifest b/net-libs/libssh/Manifest
index e353f0232c89..f4d48d1a6473 100644
--- a/net-libs/libssh/Manifest
+++ b/net-libs/libssh/Manifest
@@ -1,2 +1,3 @@
DIST libssh-0.10.0.tar.xz 553384 BLAKE2B 4a57e2095a4f56d06b2be591e02c9b9ded5e1fa28ed2774389a2902a8277f6e6b99014f8868f0740ca2900409d33b968f65c9eaa312e259926436afb49fc108c SHA512 d97235f78b94a980aabc844ee7614108944967441219f0c2417b207734d5200eb26efd5fd6de0da97a34fb612b843dc0a3b32a3364c1d8333e4c49680212aaaa
+DIST libssh-0.10.1.tar.xz 553808 BLAKE2B 1e0a648153122619e473481484af70b9c388e75a6586a7b5ea605fede4a592f2f1ae2978c19762ac396d3dff2a3dd03451ee293c9fbd4f861a1bb5668e2489b7 SHA512 d56b2809527d4f3c1d88881b8f7a7cd49321df8abe4fde011dfe7323e7552641b36a607f3b1b37c26703adae01d0176fc3d71c6c207598aaae5ebdf10237742e
DIST libssh-0.9.6.tar.xz 1053056 BLAKE2B e8565279a430786b8877386a26700a39386e908546a209815b135a2bf4ef42c37b9890dc29cda9ce6c8bfe3f3bae4942097dc794302aec767d106a45c44b811d SHA512 4040ec4af937e95be2e41313ef6d4db60b46b8d4dea10c09402398127c1d1ca8843392d207088aeee3c7ef631c6ae7b66861327dcebf78ed3af0723777619fd1
diff --git a/net-libs/libssh/files/libssh-0.10.1-disable-broken-test.patch b/net-libs/libssh/files/libssh-0.10.1-disable-broken-test.patch
new file mode 100644
index 000000000000..0e91bedaef6e
--- /dev/null
+++ b/net-libs/libssh/files/libssh-0.10.1-disable-broken-test.patch
@@ -0,0 +1,28 @@
+https://sources.debian.org/patches/libssh/0.9.6-2/2003-disable-expand_tilde_unix-test.patch/
+
+Description: Disable torture_path_expand_tilde_unix, its not working well on buildd
+ On buildd, the HOME is set to a non-existing directory, this makes
+ torture_path_expand_tilde_unix fail
+Author: Laurent Bigonville <bigon@debian.org>
+Forwarded: not-needed
+
+--- a/tests/unittests/torture_misc.c
++++ b/tests/unittests/torture_misc.c
+@@ -662,11 +662,11 @@ int torture_run_tests(void) {
+ cmocka_unit_test(torture_basename),
+ cmocka_unit_test(torture_dirname),
+ cmocka_unit_test(torture_ntohll),
+-#ifdef _WIN32
+- cmocka_unit_test(torture_path_expand_tilde_win),
+-#else
+- cmocka_unit_test(torture_path_expand_tilde_unix),
+-#endif
++//#ifdef _WIN32
++// cmocka_unit_test(torture_path_expand_tilde_win),
++//#else
++// cmocka_unit_test(torture_path_expand_tilde_unix),
++//#endif
+ cmocka_unit_test_setup_teardown(torture_path_expand_escape, setup, teardown),
+ cmocka_unit_test_setup_teardown(torture_path_expand_known_hosts, setup, teardown),
+ cmocka_unit_test_setup_teardown(torture_path_expand_percent, setup, teardown),
+
diff --git a/net-libs/libssh/libssh-0.10.1.ebuild b/net-libs/libssh/libssh-0.10.1.ebuild
new file mode 100644
index 000000000000..25b41a81f804
--- /dev/null
+++ b/net-libs/libssh/libssh-0.10.1.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+DESCRIPTION="Access a working SSH implementation by means of a library"
+HOMEPAGE="https://www.libssh.org/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.libssh.org/projects/libssh.git"
+else
+ SRC_URI="https://www.libssh.org/files/$(ver_cut 1-2)/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0/4" # subslot = soname major version
+IUSE="debug doc examples gcrypt gssapi mbedtls pcap server +sftp static-libs test zlib"
+# Maintainer: check IUSE-defaults at DefineOptions.cmake
+
+REQUIRED_USE="?? ( gcrypt mbedtls )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ !gcrypt? (
+ !mbedtls? (
+ >=dev-libs/openssl-1.0.1h-r2:0=[${MULTILIB_USEDEP}]
+ )
+ )
+ gcrypt? ( >=dev-libs/libgcrypt-1.5.3:0[${MULTILIB_USEDEP}] )
+ gssapi? ( >=virtual/krb5-0-r1[${MULTILIB_USEDEP}] )
+ mbedtls? ( net-libs/mbedtls:=[${MULTILIB_USEDEP}] )
+ zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-util/cmocka-0.3.1[${MULTILIB_USEDEP}]
+ elibc_musl? ( sys-libs/argp-standalone )
+ )
+"
+BDEPEND="doc? ( app-doc/doxygen[dot] )"
+
+DOCS=( AUTHORS CHANGELOG README )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.10.1-disable-broken-test.patch
+)
+
+src_prepare() {
+ cmake_src_prepare
+
+ # just install the examples, do not compile them
+ cmake_comment_add_subdirectory examples
+
+ sed -e "/^check_include_file.*HAVE_VALGRIND_VALGRIND_H/s/^/#DONT /" \
+ -i ConfigureChecks.cmake || die
+
+ if use test; then
+ # keyfile torture test is currently broken
+ sed -e "/torture_keyfiles/d" \
+ -i tests/unittests/CMakeLists.txt || die
+
+ # disable tests that take too long (bug #677006)
+ if use sparc; then
+ sed -e "/torture_threads_pki_rsa/d" -e "/torture_pki_dsa/d" \
+ -i tests/unittests/CMakeLists.txt || die
+ fi
+
+ if use elibc_musl; then
+ sed -e "/SOLARIS/d" \
+ -i tests/CMakeLists.txt || die
+ fi
+ fi
+}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DWITH_NACL=OFF
+ -DWITH_STACK_PROTECTOR=OFF
+ -DWITH_STACK_PROTECTOR_STRONG=OFF
+ -DWITH_DEBUG_CALLTRACE=$(usex debug)
+ -DWITH_DEBUG_CRYPTO=$(usex debug)
+ -DWITH_GCRYPT=$(usex gcrypt)
+ -DWITH_GSSAPI=$(usex gssapi)
+ -DWITH_MBEDTLS=$(usex mbedtls)
+ -DWITH_PCAP=$(usex pcap)
+ -DWITH_SERVER=$(usex server)
+ -DWITH_SFTP=$(usex sftp)
+ -DBUILD_STATIC_LIB=$(usex static-libs)
+ # TODO: try enabling {CLIENT,SERVER}_TESTING
+ -DUNIT_TESTING=$(usex test)
+ -DWITH_ZLIB=$(usex zlib)
+ )
+
+ multilib_is_native_abi || mycmakeargs+=( -DCMAKE_DISABLE_FIND_PACKAGE_Doxygen=ON )
+
+ cmake_src_configure
+}
+
+multilib_src_compile() {
+ cmake_src_compile
+ multilib_is_native_abi && use doc && cmake_src_compile docs
+}
+
+multilib_src_install() {
+ cmake_src_install
+ multilib_is_native_abi && use doc && local HTML_DOCS=( "${BUILD_DIR}"/doc/html/. )
+
+ use static-libs && dolib.a src/libssh.a
+
+ # compatibility symlink until all consumers have been updated
+ # to no longer use libssh_threads.so
+ dosym libssh.so /usr/$(get_libdir)/libssh_threads.so
+}
+
+multilib_src_install_all() {
+ use mbedtls && DOCS+=( README.mbedtls )
+ einstalldocs
+
+ if use examples; then
+ docinto examples
+ dodoc examples/*.{c,h,cpp}
+ fi
+}
diff --git a/net-libs/libssh/libssh-9999.ebuild b/net-libs/libssh/libssh-9999.ebuild
index 9b897cf8885e..25b41a81f804 100644
--- a/net-libs/libssh/libssh-9999.ebuild
+++ b/net-libs/libssh/libssh-9999.ebuild
@@ -45,7 +45,9 @@ BDEPEND="doc? ( app-doc/doxygen[dot] )"
DOCS=( AUTHORS CHANGELOG README )
-PATCHES=( "${FILESDIR}/${PN}-0.8.0-tests.patch" )
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.10.1-disable-broken-test.patch
+)
src_prepare() {
cmake_src_prepare
@@ -53,22 +55,24 @@ src_prepare() {
# just install the examples, do not compile them
cmake_comment_add_subdirectory examples
- # keyfile torture test is currently broken
- sed -e "/torture_keyfiles/d" \
- -i tests/unittests/CMakeLists.txt || die
+ sed -e "/^check_include_file.*HAVE_VALGRIND_VALGRIND_H/s/^/#DONT /" \
+ -i ConfigureChecks.cmake || die
- # disable tests that take too long (bug #677006)
- if use sparc; then
- sed -e "/torture_threads_pki_rsa/d" -e "/torture_pki_dsa/d" \
+ if use test; then
+ # keyfile torture test is currently broken
+ sed -e "/torture_keyfiles/d" \
-i tests/unittests/CMakeLists.txt || die
- fi
- sed -e "/^check_include_file.*HAVE_VALGRIND_VALGRIND_H/s/^/#DONT /" \
- -i ConfigureChecks.cmake || die
+ # disable tests that take too long (bug #677006)
+ if use sparc; then
+ sed -e "/torture_threads_pki_rsa/d" -e "/torture_pki_dsa/d" \
+ -i tests/unittests/CMakeLists.txt || die
+ fi
- if use test && use elibc_musl; then
- sed -e "/SOLARIS/d" \
- -i tests/CMakeLists.txt || die
+ if use elibc_musl; then
+ sed -e "/SOLARIS/d" \
+ -i tests/CMakeLists.txt || die
+ fi
fi
}
@@ -86,6 +90,7 @@ multilib_src_configure() {
-DWITH_SERVER=$(usex server)
-DWITH_SFTP=$(usex sftp)
-DBUILD_STATIC_LIB=$(usex static-libs)
+ # TODO: try enabling {CLIENT,SERVER}_TESTING
-DUNIT_TESTING=$(usex test)
-DWITH_ZLIB=$(usex zlib)
)