summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2021-12-18 12:42:19 -0500
committerCraig Andrews <candrews@gentoo.org>2021-12-18 12:43:19 -0500
commit088a04f559d61690423839c7171dd34e6d31c0fa (patch)
tree4461e81e958e816ac4a8a8ab93427d6e0ad49052 /net-libs/stem
parentnet-analyzer/netdata: Cleanup old versions (diff)
downloadgentoo-088a04f559d61690423839c7171dd34e6d31c0fa.tar.gz
gentoo-088a04f559d61690423839c7171dd34e6d31c0fa.tar.bz2
gentoo-088a04f559d61690423839c7171dd34e6d31c0fa.zip
net-libs/stem: 1.8.0_p20211118 version bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-libs/stem')
-rw-r--r--net-libs/stem/Manifest1
-rw-r--r--net-libs/stem/stem-1.8.0_p20211118.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/net-libs/stem/Manifest b/net-libs/stem/Manifest
index 1a541ce1a82c..1e1202d8069a 100644
--- a/net-libs/stem/Manifest
+++ b/net-libs/stem/Manifest
@@ -1 +1,2 @@
+DIST 57364fae7269ec562c5fc8cdb073ff9463d9a0f0.tar.gz 2862928 BLAKE2B 0c284be96332e11c011eb69d4448fab5c33cc59e4107abad44d7bc1186629112ca8658aade28e486c0eed873524e18ed87edf5920520d5c8dd854b2fec7867ea SHA512 b8afb5d2203b19930e8c1eaa3cad331c0df8b8bcffe4b224b8bab549866f53a5f06001d2141a0a8b7becfa8b7c1281ef5d9584423c8ba25dc4198cfaf07d3a14
DIST stem-1.8.0.tar.gz 2853802 BLAKE2B a275a38e53c5a4a3771a30528fd5781c51370352dd384a77ce27b31f034bece6fef448d74008adb82d2d909104b7338b5168a1a343c799637f9e12d39028bd09 SHA512 aa2033567b79aef960f8321e4c6cbc28105c59d6513ff49a9f12509d8f97b1a2e8a3b04dc28abb07fad59b0f6ba66443b92bbefa0d08b26038bbaf24f7f2846d
diff --git a/net-libs/stem/stem-1.8.0_p20211118.ebuild b/net-libs/stem/stem-1.8.0_p20211118.ebuild
new file mode 100644
index 000000000000..871f70905a6d
--- /dev/null
+++ b/net-libs/stem/stem-1.8.0_p20211118.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python3_{7,8,9,10} pypy3)
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+DESCRIPTION="Stem is a Python controller library for Tor"
+HOMEPAGE="https://stem.torproject.org"
+COMMIT="57364fae7269ec562c5fc8cdb073ff9463d9a0f0"
+SRC_URI="https://github.com/torproject/stem/archive/${COMMIT}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}]
+ net-vpn/tor )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RDEPEND="net-vpn/tor"
+
+DOCS=( docs/{_static,_templates,api,tutorials,{change_log,api,contents,download,faq,index,tutorials}.rst} )
+
+python_prepare_all() {
+ # Disable failing test
+ sed -i -e "/test_expand_path/a \
+ \ \ \ \ return" test/integ/util/system.py || die
+ sed -i -e "/test_parsing_with_example/a \
+ \ \ \ \ return" test/unit/manual.py || die
+ sed -i -e "/test_parsing_with_unknown_options/a \
+ \ \ \ \ return" test/unit/manual.py || die
+ sed -i -e "/test_saving_manual/a \
+ \ \ \ \ return" test/unit/manual.py || die
+ sed -i -e "/test_sdist_matches_git/a \
+ \ \ \ \ return" test/integ/installation.py || die
+ sed -i -e "/test_connections_by_ss/a \
+ \ \ \ \ return" test/integ/util/connection.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ ${PYTHON} run_tests.py --all --target RUN_ALL || die
+}