summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/xrootd/xrootd-3.3.6.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/xrootd/xrootd-3.3.6.ebuild')
-rw-r--r--net-libs/xrootd/xrootd-3.3.6.ebuild78
1 files changed, 78 insertions, 0 deletions
diff --git a/net-libs/xrootd/xrootd-3.3.6.ebuild b/net-libs/xrootd/xrootd-3.3.6.ebuild
new file mode 100644
index 000000000000..5ca003f361bf
--- /dev/null
+++ b/net-libs/xrootd/xrootd-3.3.6.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils eutils user multilib
+
+DURI="http://xrootd.slac.stanford.edu/doc/prod"
+
+DESCRIPTION="Extended ROOT remote file server"
+HOMEPAGE="http://xrootd.org/"
+SRC_URI="${HOMEPAGE}/download/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc fuse kerberos perl readline ssl test"
+
+RDEPEND="
+ !<sci-physics/root-5.32[xrootd]
+ sys-libs/zlib:0=
+ fuse? ( sys-fs/fuse )
+ kerberos? ( virtual/krb5 )
+ perl? (
+ dev-lang/perl
+ readline? ( dev-perl/Term-ReadLine-Perl )
+ )
+ readline? ( sys-libs/readline:0= )
+ ssl? ( dev-libs/openssl:= )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[dot] )
+ perl? ( dev-lang/swig )
+ test? ( dev-util/cppunit )"
+
+pkg_setup() {
+ enewgroup xrootd
+ enewuser xrootd -1 -1 "${EPREFIX}"/var/spool/xrootd xrootd
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enable fuse)
+ $(cmake-utils_use_enable kerberos KRB5)
+ $(cmake-utils_use_enable perl)
+ $(cmake-utils_use_enable readline)
+ $(cmake-utils_use_enable ssl CRYPTO)
+ $(cmake-utils_use_enable test TESTS)
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ use doc && doxygen Doxyfile
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ # base configs
+ insinto /etc/xrootd
+ doins packaging/common/*.cfg
+
+ fowners root:xrootd /etc/xrootd
+ keepdir /var/log/xrootd
+ fowners xrootd:xrootd /var/log/xrootd
+
+ local i
+ for i in cmsd frm_purged frm_xfrd xrootd; do
+ newinitd "${FILESDIR}"/${i}.initd ${i}
+ done
+ # all daemons MUST use single master config file
+ newconfd "${FILESDIR}"/xrootd.confd xrootd
+
+ dodoc docs/ReleaseNotes.txt
+ use doc && dohtml -r doxydoc/html/*
+}