summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2024-05-09 10:20:33 -0400
committerCraig Andrews <candrews@gentoo.org>2024-05-09 10:21:01 -0400
commit09740a12db553a583a5a8675495375c4b899ef88 (patch)
treead8b5923298416fe734fd98a273c4fb24d5e0bf6 /net-libs
parentnet-libs/ngtcp2: add 1.5.0 (diff)
downloadgentoo-09740a12db553a583a5a8675495375c4b899ef88.tar.gz
gentoo-09740a12db553a583a5a8675495375c4b899ef88.tar.bz2
gentoo-09740a12db553a583a5a8675495375c4b899ef88.zip
net-libs/nghttp3: add 1.3.0
Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/nghttp3/Manifest1
-rw-r--r--net-libs/nghttp3/nghttp3-1.3.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/net-libs/nghttp3/Manifest b/net-libs/nghttp3/Manifest
index de40c8a844fc..8a065c0e7ab8 100644
--- a/net-libs/nghttp3/Manifest
+++ b/net-libs/nghttp3/Manifest
@@ -1 +1,2 @@
DIST nghttp3-1.2.0.tar.xz 387592 BLAKE2B b3ad897fda5d616a93f063bafde760eda6f597c90de6c81793abef3ff30de05bb2a06388fa868f95c0871a6592331d17a2d344c63817179ad21c6390bc0e499b SHA512 51ade6b17215eb15c92b18ad7a94b70e0a442d5968aee31ec734e5826d09ca34197e64407a1ac3f7bfb4ed1a0b3c3b58afc4a152542bacdcc4c71140931a7652
+DIST nghttp3-1.3.0.tar.xz 390176 BLAKE2B 8ff17da3e53efb27b13e9ab17dba4ca27cc8fd948b160a36a0b0496f61a49c2729f1281f9a29cb8fecd4dd2c274696885a3c5e001be3dcfc30f5f1c9b6339467 SHA512 a862e7a3c3f6722b07d5437976850b2998032d1f7b9da7a49e6863d59c611ff7204c9923e8e570301a9bfbd91931a30f8f85e96cfb35481783adfc2f955a8b8c
diff --git a/net-libs/nghttp3/nghttp3-1.3.0.ebuild b/net-libs/nghttp3/nghttp3-1.3.0.ebuild
new file mode 100644
index 000000000000..6715be902969
--- /dev/null
+++ b/net-libs/nghttp3/nghttp3-1.3.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/ngtcp2/nghttp3.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/ngtcp2/nghttp3/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~hppa"
+fi
+
+DESCRIPTION="HTTP/3 library written in C"
+HOMEPAGE="https://github.com/ngtcp2/nghttp3/"
+
+LICENSE="MIT"
+SLOT="0/0"
+IUSE="static-libs"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND=""
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DENABLE_LIB_ONLY=ON
+ -DENABLE_STATIC_LIB=$(usex static-libs)
+ -DENABLE_EXAMPLES=OFF
+ )
+ cmake_src_configure
+}
+
+multilib_src_test() {
+ cmake_build check
+}