summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Quinn <code@danielquinn.org>2015-12-16 15:36:17 +0000
committerDaniel Quinn <code@danielquinn.org>2015-12-17 01:08:17 +0000
commit0b989c5d6de5322d071a81b2869db047ecae0d3e (patch)
tree095cc6f2eff89b365a4364e8fe34993a3a55b871 /net-libs
parentsys-kernel/hardened-sources: version bump to 4.3.3 (diff)
downloadgentoo-0b989c5d6de5322d071a81b2869db047ecae0d3e.tar.gz
gentoo-0b989c5d6de5322d071a81b2869db047ecae0d3e.tar.bz2
gentoo-0b989c5d6de5322d071a81b2869db047ecae0d3e.zip
net-libs/ripe-atlas-sagan: Initial commit
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/ripe-atlas-sagan/Manifest2
-rw-r--r--net-libs/ripe-atlas-sagan/metadata.xml10
-rw-r--r--net-libs/ripe-atlas-sagan/ripe-atlas-sagan-1.1.8.ebuild37
3 files changed, 49 insertions, 0 deletions
diff --git a/net-libs/ripe-atlas-sagan/Manifest b/net-libs/ripe-atlas-sagan/Manifest
new file mode 100644
index 000000000000..fc2affdacedd
--- /dev/null
+++ b/net-libs/ripe-atlas-sagan/Manifest
@@ -0,0 +1,2 @@
+DIST ripe.atlas.sagan-1.1.8.tar.gz 100037 SHA256 bb394f738570b0b0c18257856b61c730375d91996c8c726f9dcd367fd618b3d8 SHA512 9e89eff270d58ac0d69abf5c589a129b468ad7adbe49144eae9e3ee1a73ada3278efbf395aea02b612fd3b3b3db2996d68587f5465b1cec29de79b112cb20b53 WHIRLPOOL 7bb747e21a0ab6030e9fa1de827bfecddc34e596aadea5f9de2f05b13d6aff221982ed3a7bdd13256c6686e644b611bc80d395a401eaa0c0fda95f856b543339
+EBUILD ripe-atlas-sagan-1.1.8.ebuild 867 SHA256 54ec81409ed737b6fffe212f4c6b547e99b8727a4c437357610d89a38ef2cc9a SHA512 39247425d6acd7bb9d634f02e853b517af2934ddd3080a70b1ca8936cb1d7bf58c305fd5abe10694600dc0452c38e9f761471cd1ce341a502e3f716b556bf51e WHIRLPOOL de71191fefb430394684096d657340a55ef1021e2b4c5ade8b6b3674e978a28ce862eb4cb9a8b879cc336867c4431ac5d6d768c50e552a98f231aacefa7218a1
diff --git a/net-libs/ripe-atlas-sagan/metadata.xml b/net-libs/ripe-atlas-sagan/metadata.xml
new file mode 100644
index 000000000000..46c572635b0b
--- /dev/null
+++ b/net-libs/ripe-atlas-sagan/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>gentoo@danielquinn.org</email>
+ <name>Daniel Quinn</name>
+ <description>Proxied maintainer; set to assignee in all bugs</description>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-libs/ripe-atlas-sagan/ripe-atlas-sagan-1.1.8.ebuild b/net-libs/ripe-atlas-sagan/ripe-atlas-sagan-1.1.8.ebuild
new file mode 100644
index 000000000000..8a26303832bf
--- /dev/null
+++ b/net-libs/ripe-atlas-sagan/ripe-atlas-sagan-1.1.8.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit distutils-r1
+
+MY_PN=${PN//-/.}
+DESCRIPTION="A parsing library for RIPE Atlas result strings"
+HOMEPAGE="https://atlas.ripe.net/"
+SRC_URI="mirror://pypi/${PN:0:1}/ripe.atlas.sagan/ripe.atlas.sagan-${PVR}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+S="${WORKDIR}/${MY_PN}-${PVR}"
+
+RDEPEND="
+ dev-python/ipy[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/ujson[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ "${RDEPEND}"
+ dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests --verbose || die "Tests failed with ${EPYTHON}"
+}