summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-05 04:00:14 +0100
committerSam James <sam@gentoo.org>2022-07-05 04:02:44 +0100
commit49775e284a9ce5cee4e57f20c0462ed56786a0f4 (patch)
tree2bcb3de845e1544a007a4a98517f060ed0725b3b /net-libs
parentnet-libs/libtrace: drop 4.0.15_p1, 4.0.17_p1 (diff)
downloadgentoo-49775e284a9ce5cee4e57f20c0462ed56786a0f4.tar.gz
gentoo-49775e284a9ce5cee4e57f20c0462ed56786a0f4.tar.bz2
gentoo-49775e284a9ce5cee4e57f20c0462ed56786a0f4.zip
net-libs/wandio: update EAPI 7 -> 8
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/wandio/files/wandio-4.2.3_p1-fix-lz4-check.patch12
-rw-r--r--net-libs/wandio/wandio-4.2.3_p1-r2.ebuild65
2 files changed, 77 insertions, 0 deletions
diff --git a/net-libs/wandio/files/wandio-4.2.3_p1-fix-lz4-check.patch b/net-libs/wandio/files/wandio-4.2.3_p1-fix-lz4-check.patch
new file mode 100644
index 000000000000..db50cf1c0c04
--- /dev/null
+++ b/net-libs/wandio/files/wandio-4.2.3_p1-fix-lz4-check.patch
@@ -0,0 +1,12 @@
+https://github.com/wanduow/wandio/pull/51
+--- a/configure.ac
++++ b/configure.ac
+@@ -260,7 +260,7 @@ AC_ARG_WITH([lz4],
+ AS_IF([test "x$with_lz4" != "xno"],
+ [
+ AC_CHECK_LIB(lz4, LZ4F_createDecompressionContext, have_lz4f=yes, have_lz4f=no)
+- ], [have_zstd=no])
++ ], [have_lz4f=no])
+
+ AS_IF([test "x$have_lz4f" = "xyes"], [
+ if test "$ac_cv_lib_lz4_code" != "none required"; then
diff --git a/net-libs/wandio/wandio-4.2.3_p1-r2.ebuild b/net-libs/wandio/wandio-4.2.3_p1-r2.ebuild
new file mode 100644
index 000000000000..d927232b4f66
--- /dev/null
+++ b/net-libs/wandio/wandio-4.2.3_p1-r2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="C library for simple and efficient file IO"
+HOMEPAGE="https://research.wand.net.nz/software/libwandio.php"
+SRC_URI="https://github.com/wanduow/${PN}/archive/${PV/_p/-}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P/_p/-}"
+
+LICENSE="LGPL-3"
+SLOT="0/6"
+KEYWORDS="~amd64 ~x86"
+IUSE="bzip2 http lzma lzo lz4 test zlib zstd"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="test? ( lzma lzo )"
+
+RDEPEND="
+ !<net-libs/libtrace-4
+ bzip2? ( app-arch/bzip2 )
+ lzma? ( app-arch/xz-utils )
+ lzo? ( dev-libs/lzo )
+ lz4? ( app-arch/lz4:= )
+ http? ( net-misc/curl )
+ zlib? ( sys-libs/zlib )
+ zstd? ( app-arch/zstd:= )
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( app-arch/lzop )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.2.3_p1-fix-lz4-check.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with bzip2) \
+ $(use_with http) \
+ $(use_with lzma) \
+ $(use_with lzo) \
+ $(use_with lz4) \
+ $(use_with zlib) \
+ $(use_with zstd)
+}
+
+src_test() {
+ pushd test || die
+ "${BROOT}"/bin/bash do-basic-tests.sh || die
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}