summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-11-06 09:25:12 +0100
committerJeroen Roovers <jer@gentoo.org>2019-11-06 09:25:40 +0100
commit58f74662711953e590ab48131b24daa728b894c5 (patch)
treef15221d7f9df58177d59d5e5d56342c37d3458e3 /net-libs
parentnet-libs/nodejs: Version 13.1.0 (diff)
downloadgentoo-58f74662711953e590ab48131b24daa728b894c5.tar.gz
gentoo-58f74662711953e590ab48131b24daa728b894c5.tar.bz2
gentoo-58f74662711953e590ab48131b24daa728b894c5.zip
net-libs/nodejs: Update live ebuild
Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/nodejs/nodejs-99999999.ebuild11
1 files changed, 2 insertions, 9 deletions
diff --git a/net-libs/nodejs/nodejs-99999999.ebuild b/net-libs/nodejs/nodejs-99999999.ebuild
index 1b6515a23d40..e5e6f8a9d81c 100644
--- a/net-libs/nodejs/nodejs-99999999.ebuild
+++ b/net-libs/nodejs/nodejs-99999999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
-PYTHON_REQ_USE="threads"
+PYTHON_REQ_USE="threads(+)"
inherit bash-completion-r1 flag-o-matic git-r3 pax-utils python-any-r1 toolchain-funcs xdg-utils
DESCRIPTION="A JavaScript runtime built on Chrome's V8 JavaScript engine"
@@ -22,7 +22,6 @@ REQUIRED_USE="
RDEPEND="
>=dev-libs/libuv-1.33.1:=
>=net-dns/c-ares-1.15.0
- >=net-libs/http-parser-2.9.0:=
>=net-libs/nghttp2-1.39.2
sys-libs/zlib
icu? ( >=dev-libs/icu-64.2:= )
@@ -93,8 +92,7 @@ src_configure() {
xdg_environment_reset
local myconf=(
- --shared-cares --shared-http-parser --shared-libuv --shared-nghttp2
- --shared-zlib
+ --shared-cares --shared-libuv --shared-nghttp2 --shared-zlib
)
use debug && myconf+=( --debug )
use icu && myconf+=( --with-intl=system-icu ) || myconf+=( --with-intl=none )
@@ -144,11 +142,6 @@ src_install() {
done
if use doc; then
- # Patch docs to make them offline readable
- for i in `grep -rl 'fonts.googleapis.com' "${S}"/out/doc/api/*`; do
- sed -i '/fonts.googleapis.com/ d' $i;
- done
- # Install docs
docinto html
dodoc -r "${S}"/doc/*
fi