summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-05-03 12:08:21 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-05-03 13:30:22 +0200
commit6b5cfb0bfc1744682d7bd3d3e279e3bafd7f4c94 (patch)
treed545ce8862440664ffcd8d356671c0c58df350db /net-libs
parentdev-libs/qcoro5: add 0.9.0 (diff)
downloadgentoo-6b5cfb0bfc1744682d7bd3d3e279e3bafd7f4c94.tar.gz
gentoo-6b5cfb0bfc1744682d7bd3d3e279e3bafd7f4c94.tar.bz2
gentoo-6b5cfb0bfc1744682d7bd3d3e279e3bafd7f4c94.zip
net-libs/libquotient: add 0.7.2
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libquotient/Manifest1
-rw-r--r--net-libs/libquotient/libquotient-0.7.2.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/net-libs/libquotient/Manifest b/net-libs/libquotient/Manifest
index 002b058fad7e..fd608d1eb791 100644
--- a/net-libs/libquotient/Manifest
+++ b/net-libs/libquotient/Manifest
@@ -1 +1,2 @@
DIST libquotient-0.7.1.tar.gz 667590 BLAKE2B 93c601960c43511ba0118ac0224c34064a6c1b1fa9a526ca8a064495e8d5b981ab197ed958ced3ba4bf869e0554ee37d2be82cddb6610e9d5ef371a1d3a144a7 SHA512 88819cafb49712d53c692008be69ea1fc01ca1ac6aedc15696eba2f830956660d185fb07273d50c7dc3e9208314ac24838746d5d9e70b3aad7fccbd15fd7c545
+DIST libquotient-0.7.2.tar.gz 671676 BLAKE2B 37a22c01b94bb77b89534e48ebcf8427429760095ecdc9427297c57e1d7dabdaaeaf9c7498b4695d23e468b89e1ac9cd44b9f64593454e5c3f8f452b95745c75 SHA512 ba849b938c0bf93e075da466a8360703fb903ac2735b35a7e83944a1288c9324ff76daaf57164144c55cef450fc658e42e6dcacfd23f87a4db455019e9c21f47
diff --git a/net-libs/libquotient/libquotient-0.7.2.ebuild b/net-libs/libquotient/libquotient-0.7.2.ebuild
new file mode 100644
index 000000000000..1c2a488fd687
--- /dev/null
+++ b/net-libs/libquotient/libquotient-0.7.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Qt-based SDK to develop applications for Matrix"
+HOMEPAGE="https://github.com/quotient-im/libQuotient"
+SRC_URI="https://github.com/quotient-im/libQuotient/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/libQuotient-${PV}"
+
+LICENSE="LGPL-2+"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/qtkeychain:=[qt5(+)]
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5[ssl]
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ # downstream patches
+ "${FILESDIR}"/${PN}-0.7.0-no-android.patch
+ "${FILESDIR}"/${PN}-0.7.0-no-tests.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_WITH_QT6=OFF
+ -DBUILD_TESTING=OFF
+ -DQuotient_ENABLE_E2EE=OFF # TODO: libolm, libqtolm not packaged
+ )
+ cmake_src_configure
+}