summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-02-03 16:10:45 -0500
committerMichael Orlitzky <mjo@gentoo.org>2020-02-03 16:14:19 -0500
commit2484132579ec86372a1f243c6a2ba4e807fd1431 (patch)
treec0c140ae728e4eb52b0324183eb88fca725b903e /net-mail/mailbox-count/mailbox-count-0.0.5.ebuild
parentsys-apps/fwupd: Removed old (diff)
downloadgentoo-2484132579ec86372a1f243c6a2ba4e807fd1431.tar.gz
gentoo-2484132579ec86372a1f243c6a2ba4e807fd1431.tar.bz2
gentoo-2484132579ec86372a1f243c6a2ba4e807fd1431.zip
net-mail/mailbox-count: new version 0.0.5.
This new version contains a one-line upstream fix to unbreak the build on ghc-8.0 and ghc-8.2 (but not higher or lower versions...). Poor Toralf. Closes: https://bugs.gentoo.org/708030 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'net-mail/mailbox-count/mailbox-count-0.0.5.ebuild')
-rw-r--r--net-mail/mailbox-count/mailbox-count-0.0.5.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-mail/mailbox-count/mailbox-count-0.0.5.ebuild b/net-mail/mailbox-count/mailbox-count-0.0.5.ebuild
new file mode 100644
index 000000000000..00d1fe4550c6
--- /dev/null
+++ b/net-mail/mailbox-count/mailbox-count-0.0.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CABAL_FEATURES="test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Count mailboxes in a SQL database"
+HOMEPAGE="http://hackage.haskell.org/package/mailbox-count"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-haskell/cmdargs-0.10
+ >=dev-haskell/configurator-0.2
+ >=dev-haskell/hdbc-2.4
+ >=dev-haskell/hdbc-postgresql-2.3
+ >=dev-haskell/hdbc-sqlite3-2.3
+ >=dev-haskell/missingh-1.2
+ >=dev-haskell/tasty-0.8
+ >=dev-haskell/tasty-hunit-0.8
+ || ( >=dev-lang/ghc-8.0
+ ( >=dev-lang/ghc-7.10.1
+ <dev-lang/ghc-8.0
+ <dev-haskell/semigroups-0.18.2 ) )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.16.0
+ test? ( >=dev-haskell/doctest-0.9
+ >=dev-haskell/filemanip-0.3.6 )"
+
+src_install() {
+ haskell-cabal_src_install
+ dodoc "${S}/doc/${PN}rc.example"
+ doman "${S}/doc/man1/${PN}.1"
+}