summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-06-21 11:40:28 +0200
committerDavid Seifert <soap@gentoo.org>2022-06-21 11:40:28 +0200
commitf479cc80ee08a51b73e4c8aa50421e4ccf761bd7 (patch)
treeb094dc46856f83109b653be119154a59742b3e1d /net-misc/bridge-utils/bridge-utils-1.6.ebuild
parentnet-libs/rpcsvc-proto: drop 1.4.2 (diff)
downloadgentoo-f479cc80ee08a51b73e4c8aa50421e4ccf761bd7.tar.gz
gentoo-f479cc80ee08a51b73e4c8aa50421e4ccf761bd7.tar.bz2
gentoo-f479cc80ee08a51b73e4c8aa50421e4ccf761bd7.zip
net-misc/bridge-utils: drop 1.6, 1.7.1
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-misc/bridge-utils/bridge-utils-1.6.ebuild')
-rw-r--r--net-misc/bridge-utils/bridge-utils-1.6.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/net-misc/bridge-utils/bridge-utils-1.6.ebuild b/net-misc/bridge-utils/bridge-utils-1.6.ebuild
deleted file mode 100644
index 273624c416b4..000000000000
--- a/net-misc/bridge-utils/bridge-utils-1.6.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools linux-info toolchain-funcs
-
-DESCRIPTION="Tools for configuring the Linux kernel 802.1d Ethernet Bridge"
-HOMEPAGE="http://bridge.sourceforge.net/"
-#SRC_URI="mirror://sourceforge/bridge/${P}.tar.gz"
-SRC_URI="https://www.kernel.org/pub/linux/utils/net/${PN}/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 sparc x86"
-IUSE="selinux"
-
-DEPEND="virtual/os-headers"
-RDEPEND="selinux? ( sec-policy/selinux-brctl )"
-
-CONFIG_CHECK="~BRIDGE"
-WARNING_BRIDGE="CONFIG_BRIDGE is required to get bridge devices in the kernel"
-
-get_headers() {
- CTARGET=${CTARGET:-${CHOST}}
- dir=/usr/include
- tc-is-cross-compiler && dir=/usr/${CTARGET}/usr/include
- echo "${dir}"
-}
-
-src_prepare() {
- local PATCHES=(
- "${FILESDIR}"/libbridge-substitute-AR-variable-from-configure.patch
- )
- default
- eautoreconf
-}
-
-src_configure() {
- # use santitized headers and not headers from /usr/src
- local myeconfargs=(
- --prefix=/
- --libdir=/usr/$(get_libdir)
- --includedir=/usr/include
- --with-linux-headers="$(get_headers)"
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- emake install DESTDIR="${D}"
- dodoc AUTHORS ChangeLog README THANKS TODO \
- doc/{FAQ,FIREWALL,HOWTO,PROJECTS,RPM-GPG-KEY,SMPNOTES,WISHLIST}
- [ -f "${ED%/}"/sbin/brctl ] || die "upstream makefile failed to install binary"
-}